Announcement

Collapse
No announcement yet.

[RELEASE vb2.0] Show admin groups

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Just incase anyone wants it, I took 2 mins and make a View List link next to my Moderator column. It underlines on mouseover like the categories.

    Open FORUMHOME Template. Find:
    PHP Code:
    <td valign=bottom><smallfont COLOR="#afa3c5"><B>Moderator</B></smallfont
    Under it add:
    PHP Code:
    <!--- Veiw Mod List --->
    |&
    nbsp;<b><a href="showmods.php?s=$session[sessionhash]target="_blank"><smallfont COLOR="#FFFFFF">View List</a></smallfont>
    <!--- /
    Veiw Mod List ---> 
    snyx
    (i just wanna help)
    MSN: [email protected] | MAIL: [email protected] | FOLIO: mholman.com

    Comment


    • #17
      I'm getting this error

      Parse error: parse error in /home/sites/home/web/forum/showmods.php on line 72

      any ideas?

      Comment


      • #18
        Originally posted by upgrader
        I'm getting this error

        Parse error: parse error in /home/sites/home/web/forum/showmods.php on line 72

        any ideas?
        find:
        Code:
        	if ($modforums[$user[userid]] == "")
        		eval("\$modforums[".$user[userid]."] .= \"".gettemplate("showmods_forumbit")."\";");
        	else {
        		eval("\$modforums[".$user[userid]."] .= \"".gettemplate("showmods_forumsplit")."\";");
        		eval("\$modforums[".$user[userid]."] .= \"".gettemplate("showmods_forumbit")."\";");
        		}
        try change it to:
        Code:
        	if ($modforums[$user[userid]] == "") {
        		eval("\$modforums[".$user[userid]."] .= \"".gettemplate("showmods_forumbit")."\";");
        	} else {
        		eval("\$modforums[".$user[userid]."] .= \"".gettemplate("showmods_forumsplit")."\";");
        		eval("\$modforums[".$user[userid]."] .= \"".gettemplate("showmods_forumbit")."\";");
        		}
        Last edited by The_Sisko; Thu 15 Mar '01, 10:47am.
        The Sisko
        SciFi-Forum.de

        Comment


        • #19
          Not putting the brackets around a one line if/else is valid. I would guess (without looking at the code) that your problem is that you need to change eval("$modforums to eval("\$modforums

          Comment


          • #20
            DO NOT copy the code in The Sisko's post above.

            The vB PHP parsing feature has a problem with some escaped characters, so if you put \$ into a [ PHP ] block, it will be printed out as $.

            The code in showmods.php already has those $ symbols escaped.

            [edit] - now that The Sisko has changed hos post to use [ code ] tags instead of [ php ] tags, go ahead and try the modification if you like... although I can't see that it would make a difference, as leaving out the braces for a single statement in a loop is perfectly legal syntax in PHP
            Last edited by Kier; Thu 15 Mar '01, 2:10pm.

            Comment


            • #21
              Didn't know that the: The vB PHP parsing funktion
              has an error...sorry for that!
              The Sisko
              SciFi-Forum.de

              Comment


              • #22
                Well sisco's code change actually cured my problem

                Comment


                • #23
                  nice

                  what is the adress of your forums kier???

                  Comment


                  • #24
                    Originally posted by jojo85
                    nice

                    what is the adress of your forums kier???
                    My forums are not currently open to the public. I'll post an announcement when the site opens.

                    Comment


                    • #25
                      Originally posted by Kier
                      How did you get hold of that version? The version downloadable above does not use the foreach() function at all.
                      my version is vb2 b2 upgraded from vb114, is htat possible to solve it? thanks you offer a nice hack

                      Comment


                      • #26
                        KIER ROCKS

                        Hey kier that was an excellent hack...

                        YOU simply ROCK
                        www.shayri.com

                        Comment


                        • #27
                          I just fixed it...

                          I can't believe how stupid the problem was... the reason I couldn't reproduce the error on my board was because I was using a completely different version of the code.

                          Somehow I managed to zip up an old version of the code for the attachment.

                          I'm just adding the requested avatar functionality, and I'll upload the new version.

                          ::hides face in shame::

                          Comment


                          • #28
                            ok hurry up open your forums

                            Comment


                            • #29
                              New version (2.0) now available

                              Updated - check the first post in this thread

                              The new version fixes the administrative-moderator bug, and adds full avatar support (can be turned off easily if you don't want it).

                              Originally posted by jojo85
                              ok hurry up open your forums
                              Erm... no .

                              My current hosting arrangement is about to go belly-up, and I'm trying to raise the cash to organise a new server... which is not easy for a site as large and complex as that which I've built...

                              Comment


                              • #30
                                Re: New version (2.0) now available

                                Originally posted by Kier
                                Updated - check the first post in this thread

                                The new version fixes the administrative-moderator bug, and adds full avatar support (can be turned off easily if you don't want it).

                                Erm... no .

                                My current hosting arrangement is about to go belly-up, and I'm trying to raise the cash to organise a new server... which is not easy for a site as large and complex as that which I've built...
                                do we need remove old templates before install new version?

                                Comment

                                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                                Working...
                                X