Announcement

Collapse
No announcement yet.

"Submit" leads to Blank Page & Hang . . .

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • "Submit" leads to Blank Page & Hang . . .

    The link below points to a two-week old thread that describes almost exactly what I am experiencing.

    http://www.vbulletin.com/forum/showt...ighlight=blank

    Regrettably, the thread above doesn't contain a solution to the reported problem.

    I am a new customer -- just purchased the full version of vBulletin today. I downloaded the "full install" versions of both 1.1.5 and 2.0 Beta2

    VBLite installed & operated just peachy. So did 1.1.5

    When I install 2.0 Beta2, however, I am unable to post. Clicking the "Submit" button directs one to a blank screen, and script processing seems to just hang.

    Like the previous poster, I am running RH 7.0, and the very latest PHP & mySQL versions from the RedHat Errata pages.

    mySQL and PHP are both operating, as other scripts that utilize both are functioning properly (as are VBLite and 1.1.5). In VB2 Beta2 I was able to define some additional categories and create some new forums; all forums remain at zero messages, however, as I am unable to post to any of them.

    Registration appears to work fine. The script connects & interacts with mySQL, and the registration e-mail is properly generated.

    IE 5.X on WinNT just leaves one sitting at a blank page. Netscape 4.76 on Linux returns the error dialog "The document contained no data".

    This condition does NOT appear to be related to:

    1) whether a URL appears in the message body (needing to be parsed & converted to a link)

    2) Whether a file attachment is provided or not

    These were a couple of the permutations I experimented with, to see if either was responsible for the failure.

    The failing installation can be viewed at:

    http://atlas.binderbulletin.org/forums

    Any experience with this set of symptoms? Or suggestions as to where I should start looking?

    Bill Thebert
    The Binder Bulletin
    Last edited by Bill Thebert; Thu 1 Mar '01, 4:43pm.

  • #2
    I spent several hours last night combing the various boards here for similar reports. I found several, but none that contained any definitive cures or advice.

    It seems like this behavior is pretty chronic with folks using the latest mySQL RPM from RedHat (3.23.32) -- which was released on 23 Jan 2001.

    In the absence of any input from this board or the vBulletin development team, I'm inclined to try backing off a version or two on the mySQL engine.

    Does anyone have any comments on this strategy before I dive in?

    Comment


    • #3
      Did I post this in the wrong place?

      I realize I'm new to your community and not well known.

      Is there a better forum in which to post -- if my hope is to draw a response from someone on the vBulletin development team?

      Comment


      • #4
        Fact is, no one really knows what causes this issue.

        If you want to give me FTP and CP access, I'll try my best to fix it.

        Comment


        • #5
          Originally posted by Ed Sullivan
          Fact is, no one really knows what causes this issue.

          If you want to give me FTP and CP access, I'll try my best to fix it.
          This alone, Ed, feels lots better than simply being ignored. I can handle hearing: "Dunno. This one's got us stumped for the time being."

          Like I said, I can't really *expect* a Beta product to work perfectly.

          I work for IBM (Printing Systems Division) here in Boulder, Colorado. And though I'm doing other things now, I spent nearly five years in the development group for "Workgroup Printers" (read: "small printers, <= 100 pages per minute) -- designing & building test labs, designing software test suites, executing same.

          I'm familiar with software development, and scientific/methodical testing. Maybe together we can slay this critter.

          I'll contact you privately about the access issues. I presume you have tools for using openssh?

          Thanks (heartily) for your response.

          Bill

          Comment


          • #6
            I'll contact you privately about the access issues. I presume you have tools for using openssh?
            Yeah, I do -- don't really need shell access though, but I'll get into the privately.

            Comment


            • #7
              I'd like to publicly thank Ed for his fine work.

              He's made some code changes in newthread.php and newreply.php that appear to have solved the problem.

              Several other folks have reported similar symptoms:

              http://www.vbulletin.com/forum/showt...&threadid=9559
              (2/23, 0 responses)

              http://www.vbulletin.com/forum/showt...&threadid=9671
              (2/24, 0 responses)

              http://www.vbulletin.com/forum/showt...threadid=10148
              (3/1, 0 responses)

              http://www.vbulletin.com/forum/showt...&threadid=8649
              (2/14, possible clue)

              http://www.vbulletin.com/forum/showt...lank#post63172
              (2/13, 0 responses)

              Might be nice to hear from some of these folks -- see whether the same fix works for them.

              Some outstanding issues:
              • There is still the identical problem in "editpost.php"
              • I'm experiencing some anomalies with the "image attach/upload" function
              • Lastly, the auto-parsing of embedded URLs in message posts appears inoperable on my installation.


              But at least I'm able to operate and contribute to the testing effort.

              Auto-parsing of URLs works fine in the CALENDAR module on my installation. Though long/complex URLs with a semi-colon in the query string are prematurely truncated.

              For example:

              http://www.binderbulletin.org/techta...ex.pl?noframes;read=130488

              Regards to all, and special thanks to Ed . . .

              Bill

              Comment


              • #8
                (I didn't make any changes to editpost.php so that would explain it )

                Comment


                • #9
                  Well, I am now having the exact same problem.

                  Everything was working well, I was on version 2.0.3.

                  I finally got around to doing the upgrade, and now nobody can register on the board.

                  As soon as you hit the submit button, you get a blank white screen.

                  There has to be a solution to this problem.

                  After searching the forums here, there are lots of people having this same problem, but so far no answers...

                  =(

                  Should I try and go back to an older version?

                  Comment


                  • #10
                    I'm running to boards - v2.2.3 and v2.2.4 - and both have blank page errors. Originally, I thought it was because of my server, but I recently moved one board to a new host (new company) and it's still having blank page errors.




                    How do we get rid of them, if it's known. Or should we do the "submit a ticket" to support?


                    www.simpsonsboard.com/forums
                    www.charmed-boards.com

                    Comment


                    • #11
                      Here is a fix that worked for myself and Jeff Bronstein.

                      The reason it worked however is because we are both using the same host.

                      Basically the problem was that our server is using 3 different versions of PHP on their servers at the same time. Depending on what the extension of the php file, that determines what version of php the server will use.

                      vBulletin uses .php, so on our server it defaults to PHP version 3.0.15. Because that version is too old, that is why it is giving you blank screens.

                      Here is how we fixed it for us:

                      1. Open up your favorite .txt editor. I use ultra edit but notepad will work too.

                      2. Paste this code into it:

                      AddType application/x-httpd-php4 .php
                      Action application/x-httpd-php4 "/cgi-bin/php"
                      3. Save the files as:
                      .htaccess
                      4. Upload the file into your root directory of your vBulletin board.

                      Note: If the file exists, DONT OVER WRITE IT. Download that file and open it up and just add those two lines of code to the end of it. Save it then upload the newer .htaccess file.

                      That’s it man, try that and see if it works for ya.

                      Good luck!

                      Comment

                      Related Topics

                      Collapse

                      Working...
                      X