Announcement

Collapse
No announcement yet.

Install Script / Database Q

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Install Script / Database Q

    I just moved my site from one host to another and am in the process of re-installing vB. We were running v2 for awhile, but just moved to v3 a few days before the move. I am reinstalling a clean v2 and then will update to v3, but I've hit a snag. The database has been uploaded to our new host and when attempting to attach the database the connection succeeds telling me my database already exists (as it should). When I clicked to continue the install script I received the following database error:


    Creating table access

    There seems to have been a slight problem with the database.
    Please try again by pressing the refresh button in your browser.

    An E-Mail has been dispatched to our Technical Staff, who you can also contact if the problem persists.

    We apologise for any inconvenience.



    Any ideas?
    Last edited by Foo216; Fri 2 Apr '04, 5:55pm.

  • #2
    If you upgraded before you moved, why arent you just moving the database and files if i my ask?


    And please view the source and paste the full error message here.

    Comment


    • #3
      Here's the source:

      <!-- Database error in vBulletin Installer :

      Invalid SQL: CREATE TABLE access (
      userid int(10) unsigned DEFAULT '0' NOT NULL,
      forumid smallint(5) unsigned DEFAULT '0' NOT NULL,
      accessmask smallint(5) unsigned DEFAULT '0' NOT NULL
      )
      mysql error: Table 'access' already exists

      mysql error number: 1050


      The database was moved from one server to the next, but the files were lost.

      Comment


      • #4
        Then you dont need to install / upgrade

        If you were on vB3 just download the vB3 files and configure the config.php.new file to the proper varibles and your done.

        Comment


        • #5
          I believe my co-admin reverted the database to the last day we were on v2. I know we've lost all posts over the past 3 days (that we've been on v3) doing this, but that's the info I received. I was told we need to do a v2 install and then v3 upgrade...

          Comment


          • #6
            what version of vB2 were you using?

            Comment


            • #7
              If I remember correctly it was 2.3.2

              Comment


              • #8
                If the database i uploaded, and you were running vB2.3.2

                Upload the vB3 files, and configure the new config.php. then point your browser at site.com/forums/install/upgrade.php

                That should guide you thought the install steps, if your wanting to upgrade to vB3 that is

                Comment


                • #9
                  Uploaded all files and when pointed to upgrade I receive the database error:

                  <!--
                  Database error in vBulletin :
                  Invalid SQL:
                  SELECT title, data FROM datastore
                  WHERE title IN ('options', 'cron', 'forumcache', 'usergroupcache', 'stylecache')

                  mysql error: Table 'reds_vbulletin.datastore' doesn't exist
                  mysql error number: 1146

                  Comment


                  • #10
                    Weird, do you have a table prefix?

                    Comment


                    • #11
                      Not that I'm aware of.

                      Comment


                      • #12
                        open your config.php

                        Look for this

                        // Prefix that your vBulletin tables have in the database.

                        Do the lines after it look like this
                        PHP Code:
                        // For example: $tableprefix = 'vb3_'; 
                        $tableprefix ''
                        OR

                        PHP Code:
                        // For example: $tableprefix = 'vb3_'; 
                        $tableprefix 'red'
                        ?

                        Comment


                        • #13
                          number 1

                          Comment


                          • #14
                            I deleted the v3 files and re-uploaded the v2.3.5 and am still getting the install script error:


                            <!-- Database error in vBulletin Installer :
                            Invalid SQL: CREATE TABLE access (
                            userid int(10) unsigned DEFAULT '0' NOT NULL,
                            forumid smallint(5) unsigned DEFAULT '0' NOT NULL,
                            accessmask smallint(5) unsigned DEFAULT '0' NOT NULL
                            )
                            mysql error: Table 'access' already exists
                            mysql error number: 1050


                            Does anyone have any idea?

                            Comment


                            • #15
                              You dont need to install vB2 if the database was already at vB2. just configure the config.php files and run the forums.

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X