Announcement

Collapse
No announcement yet.

User Title Malfunction

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • User Title Malfunction

    Following my failed attempt to upgrade to 3.0.0 this weekend (thanks again for everyone here's help in straightening that out), my host restored my 2.3.0 database and I reuploaded all of the old files. For all intents and purposes, everything seems to be working fine: users can post, browse, send PMs, etc.

    I noticed a discrepancy last night when one user's title was "Registered User" rather than the custom title for newbies I had in place. I checked it out and sure enough, he was the only one to have that title. Thinking it was isolated, I went to bed. When I checked this morning, more people had joined him (their first post since the restoration seems to serve as a catalyst of sorts). I resaved the custom title and updated user titles, but that only increased the amount of users listed as "Register User".

    So, I went into the User Groups section and noticed that the box used to override the ladder was filled in in the "Registered" group (with "Registered User"). I deleted that and tried saving when I was hit with an error message.

    <!-- Database error in vBulletin Control Panel 2.3.0:

    Invalid SQL: UPDATE usergroup SET title='Registered',usertitle='',cancontrolpanel=0,canmodifyprofile=1,canviewmembers=1,canv iew=1,showgroup=0,cansearch=1,canemail=1,canpostnew=1,canmove=0,canopenclose=0,candeleteth read=0,canreplyown=1,canreplyothers=1,canviewothers=1,caneditpost=1,candeletepost=0,canuse pm=1,canpostpoll=1,canvote=1,canpostattachment=0,ismoderator=0,canpublicedit=0,canpublicev ent=0,canthreadrate=1,cantrackpm=1,candenypmreceipts=0,maxbuddypm=,maxforwardpm=5,canwhoso nline=1,canwhosonlineip=0,cangetattachment=1 WHERE usergroupid=2
    mysql error: You have an error in your SQL syntax near 'maxforwardpm=5,canwhosonline=1,canwhosonlineip=0,cangetattachment=1 WHERE usergr' at line 1

    mysql error number: 1064

    Date: Tuesday 23rd of March 2004 11:26:49 AM
    Script: http://forums.longpatrolclub.com/admin/usergroup.php
    Referer: http://forums.longpatrolclub.com/adm...&usergroupid=2
    -->
    I closed my board and ran the repair.php script, but everything came back as "OK". Do I need to repair a table directly in phpMyAdmin or what?

    Thanks for your help.

    Martin

  • #2
    That error is a problem with the query itself, not the database.

    The first thing you should try is uploading the original 2.3.0 PHP files, overwriting the existing files. Make sure you upload the PHP files in ASCii mode.

    Comment


    • #3
      I appreciate the help. I reuploaded all of the non-image 2.3.0 files (and made sure they were ASCii) but I still get that error-- with any user group, not just "Registered". Is there anything else I could try?

      Would upgrading to 2.3.4 possibly work? (Is upgrading even advisable while I'm getting this error?)

      Additionally, the only other place I'm getting an error right now is when I click on "Forum Leaders". I'm assuming it's somehow related.

      <!-- Database error in vBulletin 2.3.0:

      Invalid SQL:
      SELECT
      userfield.field2, usergroup.title, user.username, user.userid, user.invisible, user.receivepm,
      user.usergroupid, user.lastactivity, user.lastvisit
      FROM usergroup
      LEFT JOIN user ON (usergroup.usergroupid = user.usergroupid)
      LEFT JOIN userfield ON (userfield.userid = user.userid)
      WHERE usergroup.showgroup = 1
      mysql error: Unknown column 'usergroup.showgroup' in 'where clause'

      mysql error number: 1054

      Date: Tuesday 23rd of March 2004 08:46:42 PM
      Script: http://forums.longpatrolclub.com/showgroups.php?
      Referer: http://forums.longpatrolclub.com/
      -->
      Thanks again in advance.

      Martin

      Comment


      • #4
        That last error refers to an unknown column "showgroup" in the "usergroup" table. I am looking at my 2.2.9 database and that column exists, but it doesn't exist in my 3.0.0 database. I am guessing that your database is upgraded (at least partially) to 3.0.0 which is causing problems.

        Do you have phpmyadmin on your server that I can use to look at your database?

        Comment


        • #5
          Dang, I was afraid of that. I started the upgrade process Saturday night, hit a snag, and while I was trying to resolve it, my host wiped and then restored the database a little over twelve hours later. It seemed to be the pre-upgrade DB, so I was hoping that wouldn't be the problem.

          I do have phpMyAdmin, yes, although I have no idea how to give you access. Let me know.

          Thanks again.

          Martin

          Comment


          • #6
            You can send me a private message with the login info.

            Comment

            Loading...
            Working...
            X