Announcement

Collapse
No announcement yet.

Problem with Rebuilding the Search Index

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    What I suggest is the you or your host edit php.ini and increase the max_execution_time variable to 90 to see if this fixes the problem.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #17
      My host is requesting admin access, to "further investigate this issue."

      May I ask for your advice? If you were in my shoes, would you provide this?
      Thanks,
      Still Waters

      Comment


      • #18
        I would, but that's just me.

        BTW, we had something similar when we upgraded to vb3 RC2. We reindexed everything multiple times, and it took days to reindex but the searches didn't work properly. It wasn't fixed till I manually emptied the search index and word tables then reindexed.
        Last edited by cirisme; Sun 28 Mar '04, 8:58am.
        TheologyWeb. We debate theology. srsly.

        Comment


        • #19
          Changing the max_execution_time variable did not solve the problem

          Thanks for your input, cirisme. After another round of question-and-answer, they agreed to increase the max_execution_time variable to 90. So, I don't have to worry about giving them admin access, after all.

          Here's an update.

          (1) The max_execution_time variable is now 90.

          (2) I tried to rebuild the search index (with default settings) and experienced the exact same problem, as before. The script would process only the first 65 posts.

          (3) I tried to rebuild the search index (with customized setting... Number of threads to do per cycle = 1). The script worked without interruption, except whenever it encountered a thread that was greater than 65 posts in length. For those very long threads, only the first 65 posts would be indexed and then the script would simply stop. After each interruption, I would start the script at the next thread number (and Number of threads to do per cycle = 1). I continued this way, until the script displayed a message stating it was done.

          Therefore, my index is not complete.

          Any additional ideas to troubleshoot this?
          Thanks,
          Still Waters

          Comment


          • #20
            Hmmm...maybe there's a problem with the database. Run Repair/Optimize in the Admin CP:

            Admin CP -> Import & Maintenance -> Repair/Optimize Tables -> Check All -> Continue

            Then empty the search index and try again.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #21
              Originally posted by Steve Machol
              Run Repair/Optimize in the Admin CP:

              Admin CP -> Import & Maintenance -> Repair/Optimize Tables -> Check All -> Continue
              I don't have that option (Repair/Optimize Tables) in my admin cp.

              Under "Import & Maintenance," I have the following three options, only:
              • Back-up Database
              • BB Import Systems
              • Update Counters
              What to do?
              Thanks,
              Still Waters

              Comment


              • #22
                Bumping.

                As I mentioned, above, I don't have the option "Repair/Optimize" in the admin cp (version vB 2.3.4). Please provide alternate instructions?
                Thanks,
                Still Waters

                Comment


                • #23
                  upload the repair.php to your admin folder, from your extras folder and point your browser at it, it should give you instructions, run it a few times, all tables shoudl check back on but the session table

                  Comment


                  • #24
                    I uploaded and ran repair.php, 3 times. Each time, the screen displayed "OK" for every table (except the sessions table, as you mentioned). I am now able to fully index the search engine, without the script interrupting.

                    Thank you, to Steve and Zachery.
                    Thanks,
                    Still Waters

                    Comment


                    • #25
                      I had the same issue and this thread could help me very much. I just add that the optimize function of phpmyadmin (applied on the searchindex, search and word tables) had the same result as repair.php
                      In my case, at the moment the php.ini entry : max_execution_time is still at 30. The script is still running
                      Thanks to all of you

                      I have a question though :
                      my searchindex table is over 500 Mo large is it not too big anyway ? Is it necssary to archive the forum ? My hosting admin tells me it is normal that the database becomes corrupted...
                      What is your advice ? (the dedicated server runs on a singl P4 2,4 Ghz with 1 gig ram.)

                      Michel
                      Last edited by Mireade; Tue 10 May '05, 12:45am.

                      Comment


                      • #26
                        Originally posted by Mireade
                        I had the same issue and this thread could help me very much. I just add that the optimize function of phpmyadmin (applied on the searchindex, search and word tables) had the same result as repair.php
                        In my case, at the moment the php.ini entry : max_execution_time is still at 30. The script is still running
                        Thanks to all of you

                        I have a question though :
                        my searchindex table is over 500 Mo large is it not too big anyway ? Is it necssary to archive the forum ? My hosting admin tells me it is normal that the database becomes corrupted...
                        What is your advice ? (the dedicated server runs on a singl P4 2,4 Ghz with 1 gig ram.)

                        Michel
                        what version of vB ? no it isn't normal that databases become corrupted for no reason.. can you provide some info asked at http://www.vbulletin.com/forum/showthread.php?t=70117

                        are you backing up your forum with something that touches the actual mysql data files *.myd, *.myi, *.frm ? how large is your total database ?
                        :: Always Back Up Forum Database + Attachments BEFORE upgrading !
                        :: Nginx SPDY SSL - World Flags Demo [video results]
                        :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

                        Comment


                        • #27
                          Originally posted by eva2000
                          what version of vB ? no it isn't normal that databases become corrupted for no reason.. can you provide some info asked at http://www.vbulletin.com/forum/showthread.php?t=70117

                          are you backing up your forum with something that touches the actual mysql data files *.myd, *.myi, *.frm ? how large is your total database ?
                          Thank you Eva.

                          I tried to gather the required information in the attached txt.

                          I don't think that the actual mysql data files are 'touched' by anything else than by the server itself.
                          The whole database is about 1 Go

                          Thank you for your time.

                          Michel
                          Attached Files

                          Comment


                          • #28
                            I had a related question..running v.2.34 with about 17,000 threads and about 183,000 posts..I emptied the search index table (130MB) a couple of days ago to move servers faster...now the current search index already has indexed the posts over the last 2 days....but I wanna go back and rebuild it for all the threads I have..my question is: since I know that the last 100 threads (over the last 2 days) have already been taken care of ...and I need the indexing of the first 16,900 threads ONLY...should I still empty the search index table before starting the rebuilding from the CP panel? since the last 100 threads are already in there so to speak..

                            Also, when I moved I only emptied the search index table, not the word table...does that matter? The messageboard is now functioning OK, but I have disabled the search function for the moment..

                            Thanks for your help!

                            Comment


                            • #29
                              I would use the function in the Admin CP to empty the search index first, then rebuild it.
                              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                              Change CKEditor Colors to Match Style (for 4.1.4 and above)

                              Steve Machol Photography


                              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                              Comment


                              • #30
                                Originally posted by Steve Machol
                                I would use the function in the Admin CP to empty the search index first, then rebuild it.
                                Thanks. How long do you think it is going to take for that many threads & posts?

                                Comment

                                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                                Working...
                                X