Announcement

Collapse
No announcement yet.

Too Many Connections...

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Too Many Connections...

    I guess this isnt a bug in the software, but I am reporting this error here. I did a search and found some people have the same problem but no one really answered it. Right now at [url]http://www.wrestlingtalks.com[/url] I am getting this error.

    Warning: MySQL Connection Failed: Too many connections
    in admin/db_mysql.php on line 31

    When I view the source I get this:

    Database error in vBulletin: Link-ID == false, connect failed
    mysql error:
    mysql error number:
    Date: Saturday 02nd of September 2000 01:54:23 AM
    Script: /
    Referer:

    (I changed the default error message when you go to my site so people know it will be down for a while since our admin isnt here to restart mySQL)

    I know it isnt because there are too many people online since there isnt right now and we have it set high. And hitting refresh gives that message all the time. It has happened before and our admin restarted mySQL I beleive, but I cannot get in touch with him due to the holiday weekend. Im having a hell of a time here.

    I think it could be because PHP isnt closing the connections after someone loads up the page, is that a possibility?

    Anyone know how I can go about fixing it, its kind of urgent. Thanks.
    Jake Lawson
    Owner, Peterborough Web Design & Development: Total Internet Solutions

  • #2
    Restart MySQL

    IMPORTANT: THis works on my FreeBSD system. It may not be the correct way of doing it though. Some admins might completely disagree with the process...but it works.

    Your best bet would be to go into Telnet...type:
    ps aux

    and find the MySQLd process...kill it
    by typing: kill PID#
    (Replace PID # with the PID number you found doing the ps aux.)

    This will kill your current MySQL deamon.

    Then go to: /etc
    and type: ./mysql.sh

    If mysql.sh does not exist in /etc do a search for mysql.sh by typing: find / -name 'mysql.sh'

    I hope this helps. Good luck! :)
    PaintballCity.com
    VB Board of the Month: October

    Comment


    • #3
      I believe you are seeing this because you have too many connections to Mysql. What is your current MySQL variables? You will most likely have to up that number by issuing something like:

      -O max_connections=500


      Obviously you have to change "500" to whatever you wish. You will also have to restart Mysql after you do so. Restarting Mysqld will also reset this so your forums will be back up immediately.
      We're Here Forums!
      [email protected]

      Comment

      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
      Working...
      X