Announcement

Collapse
No announcement yet.

Problem with installing on Win2k system

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem with installing on Win2k system

    Hi,

    I did post this on the end of another similar thread, but it didn't seem to get much attention there, so I thought it would be better to start a new thread. :)

    I am trying to install vBulletin on a Win2k Server machine...I have PHP4 and mySQL 3.3.2.
    When i run install.php, it gets through the first few steps fine. It completes step 5 totally succesfully, but when i click on the Next link it times out with this error:

    [quote]
    Setting up templates...


    Fatal error: Maximum execution time of 120 seconds exceeded in installtemplate.php on line 3
    [/quote]

    I followed some suggestions which included increasing the timeout from 30 to 120 seconds, no luck. I also changed in my IIS config so that it didn't use the PHP ISAPI dll anymore, so that it uses the php.exe file instead.


    Does anyone have any suggestions?

  • #2
    hi could use your help if you don't mind

    i am also installing on a win2k server...but i got stuck at step one...when it says to click on the link to install...nothing happens. i am sure it is the mysql setup....if you have a chance, could you email and help me out with it? i would really appreciate it..you can reach me at [email protected]

    Comment


    • #3
      Aright, I did a little looking at installtemplate.php and this is the code that is on line 3:
      [CODE]$DB_site->query("DELETE FROM template WHERE title<>'options'");[/CODE]

      I'm guessing you're system is either having trouble executing the delete statement, or it could be that you don't have delete priveleges in mysql.

      It would help if I knew what version of vbulletin you are trying to install, and if you're running this on a dedicated server or a virtual server. Judging from your post it seems that you're on a dedicated server, but it would be nice to have this confirmed.
      Aaron
      aewebdesign

      Comment


      • #4
        thanks for the repy!

        wow! its been a battle getting help. yes i am running on a dedicated server. I just installed mysql...just the basic installation. I can create a database...with the create database command...but how do i assign a user and a password? under the mysql admin page, i have a local username , a local hostname, under mysql.ini setup, i have a different username and password...i have no idea is the right one? nor do i understand how it applies to a created database? I also do not know if i have delete privileges or not...basically its my own machine, and my own installation...i can do whatever i need to, i just am confused as to what i need to do! Thanks again, i really really appreciate your help.

        Comment


        • #5
          Don&#039;t be afraid to experiment a bit :)

          Personally, I'm still running on a virtual server, so I haven't actually gone through the process of installing mysql, but I have looked a couple things up for ya.

          Ok, first I would try using the password that you have under mysql.ini setup, if that doesn't work, then try your local username and password... If that doesn't work either, then it looks like you're gonna hafta specify a user and password for the database, and it just so happens that I've looked up a lil sample of how that can be done.
          [CODE][B]From the mysql monitor.....

          CREATE DATABASE database_name;
          GRANT select, insert, update, delete ON database_name.* TO [email protected] IDENTIFIED BY 'mypassword'; [/B][/CODE]

          This code came from [URL="http://www.vbulletin.com/forum/showthread.php?threadid=2699"]here[/URL], which is a thread in the [URL="http://www.vbulletin.com/forum/forumdisplay.php?forumid=18"]mysql[/URL] section of this forum.

          Another thread that might prove useful, and is also located in the mysql section of vbulletin forums is [URL="http://www.vbulletin.com/forum/showthread.php?threadid=1635"]Win 2K and MySQL[/URL].

          Hope this stuff helps ya out a bit. :)


          Aaron
          aewebdesign

          Comment


          • #6
            wow!

            that is incredibly helpful! thank you very much. if you ever need help with flash please ask, as my speciality is animation and action script.

            Comment


            • #7
              hehe, just glad to help
              I'll keep your offer in mind. :D
              Aaron
              aewebdesign

              Comment


              • #8
                arg...still nothin

                ran grant all privileges on mysql, but still nothing...anyone have any ideas?

                Comment


                • #9
                  I also get nothing when I run that command.
                  I didn't think it would do anything, cos I am logging in as root, and root should already have those permissions.
                  Can anyone offer any more help?

                  Comment

                  widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                  Working...
                  X