No announcement yet.

Parse error: in global.php on line 0

  • Filter
  • Time
  • Show
Clear All
new posts

  • Parse error: in global.php on line 0

    This problem occurs on on FreeBSD/unix-based but not Windoze 2k is the ISP
    Apache v. 1.3.x
    PHP version 4.PHP version 4.0B2
    PHP is a CGI application

    MySQL is latest stable version

    1.1.3 BETA 3 with.php extensions is the vBBS software d/l today


    Parse error: parse error in global.php on line 0

    Action taken:

    1. Installed
    2. Changed board general options
    3. Changed style options
    4. Parse error: parse error in global.php on line 0
    5. Also colors on page are not as set - bright blue page background color, for example, when page color is set to white!


  • #2
    it looks like your server isn't parsing PHP correctly.
    - Insert viable disclaimer here -



    • #3
      I had the exact same problem with vservers a few months ago, I don't remember how I fixed things at the moment, but give me a little bit and I'll see if it comes to mind.

      I made a few changes around the same time that I got vbulletin running correctly, so its kinda hard to tell exactly what solved the problem.

      Here is a list of all the changes that took place around the time that the problem was fixed.

      1. vservers upgraded to php version 4 w/ zend optimizer

      2. I emailed tech support to have them turn gpc_magic_quotes off after having trouble getting a php.ini file to make the changes for me on the server, I think tech support told me where to put the php.ini file, but they may have also made some changes as well

      3. I slapped a php.ini file up on my server to turn gpc_magic_quotes off (I think).

      4. I upgraded to vbulletin 1.1.3 beta 3 (I think, it might have been 1.1.2... been so long its hard to remember)

      Thats about all that comes to mind at the moment, I made all of those changes on one day, and none of them seemed to work, however, the next day when I checked the boards all was fine, so its tough to pinpoint what actually fixed the problem.

      oh, I also remember tech support restarting mysql for me once, but if I remember correctly it was several days before I made the changes listed above. All of this took place MONTHS ago, sometime around the beginning of the summer so I dunno how accurate or helpful this info will be for you, but just lemme know if ya need any help an I'll try to walk ya through things.



      • #4
        Nice one! Thanks - I solved the thing with htaccess file but if you could let me know where to put the php.ini file I would be very grateful - as I am on vservers it should be quite simple to do.

        Thanks in advance!



        • #5
          haha.. that was a fast edit there forefront, I saw your first response to menno, then went back to the front page and reloaded an all the sudden its back to 2 posts and showing me as the last to post, so I'm like wtf! then I load the page up again an your post is different.. hehe

          anyway, I'll try to look up the directory I got the php.ini file in, but come to think of it, I remember dumping some settings into .htaccess as well.. haha.. its been so long its tough to remember, ah well, I'll get back to ya on the php.ini location. Glad to hear ya got things worked out!


          • #6
            RE: fast edit

            Yup...I was replying to the first answer in its brevity :-)

            Then I saw your detailed response and felt my answer was unjustified - info. on php.ini would be gr8


            • #7
              php.ini path

              ok, php.ini goes in /usr/local/lib
              or more specifically, on vservers virtual servers it goes in the /usr/home/(virtual server name)/usr/local/lib directory.
              A quick way to find out where php is looking for the php.ini file is to load up phpinfo real quick and in the header of the page it'll tell you the path to php.ini.


              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.