Announcement

Collapse
No announcement yet.

.php3 version ?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • .php3 version ?

    I just logged into the members area and downloaded the software for the first time but I see its only in .php format. In the lite version there was both .php and .php3
    Where can I get the .php3 ?

  • #2
    John still hasn't got the .php3 version uploaded, I guess.

    if you use Homesite or Textpad, it takes about 1 minute to make it a php3 version.

    just do a search and replace on .php to .php3 and change your file extensions.

    when doing the search and replace, make sure to not forget the . before the extensions

    there's also an .htaccess method to force apache to parse php as php3 buried in here somewhere.
    Webmaster:
    @forumz

    Comment


    • #3
      It's actually buried in this thread:

      [url]http://www.vbulletin.com/forum/showthread.php?threadid=1811[/url]

      :)

      -jim

      Comment


      • #4
        I have a suggestion for John on this matter.
        I know UltraBoard used to do this, so I'm assuming it can be done in PHP, but since I know nothing about PHP I'm not sure.

        In UB, all references to the files were in the format index.$ext, search.$ext, so on and so forth. That way, in the config file you could set $ext to cgi, or pl, and when the script was installed it would change all $ext to whatever you chose.
        If you did this with vB it would save lots of people lots of headaches. Although you would still have to change the file extensions, you wouldn't have to go through each file individually and change all references to php3

        And BTW, I have HomeSite too, what a wonderfull product, but most people don't, so they'd have to go through each file.

        Comment


        • #5
          Thanks for the help, I asked my sys admin about it and he just set something up in Apache to recognize .php
          Sorry for troubles.

          Comment


          • #6
            no trouble at all:)

            I think we've answered that one enough where we can just copy and paste the answers;)
            Webmaster:
            @forumz

            Comment


            • #7
              LOL, yeah, the same problems keep coming back :)

              Using a variable for the file extension might not be a bad idea, though.
              - Insert viable disclaimer here -

              ArtBeast!

              Comment


              • #8
                Here's a related follow-up question --

                I recently upgraded my server's PHP to 4.0 - Martin had installed the php3 version for me a few weeks earlier - I changed my server's Apache config file so that .php3 as well as .php files are run through php version 4, removed the Apache php3 module, and restared Apache ... but the message boards don't seem to run any faster (though maybe I just don't notice the speed-up). I'm wondering if you know whether there's something hard-coded into the software that holds back a version that still has the php3 extensions on the filenames (I didn't change them when I upgraded, figuring the Apache config would bring up php ver 4 instead).

                [Edited by Dave Baker on 07-24-2000 at 02:10 PM]

                Comment

                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                Working...
                X