Announcement

Collapse
No announcement yet.

Backup is not showing!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Backup is not showing!

    I made a fresh install for 1.1.6,and I had 2 previous backup files before I made this installation.Now I cannot restore any of my backups to the forum again.I tried few different commands,but it keep giving me that some tables are already exists!

    mysql -uUser -pPass DBname < path/to/backup.sql
    //and
    mysql> -uUser -pPass DBname < path/to/backup.sql

    the second command brings me back to the prompt like it's done,but I dont see anything in the forum!

    Can I do restoring by phpMyAdmin or any other scripts instead?

    Your help is much appreciated

    [Edit: the backup files are not corrupted,I viewed'em and each one has 49994037 bytes of data.
    Last edited by theGAME; Fri 27th Apr '01, 9:47pm.

  • #2
    Empty your database (with something like phpMyAdmin), and retry the first command:
    mysql -uUser -pPass DBname < path/to/backup.sql

    Comment


    • #3
      I dropped the database with phpMyAdmin,then tried the command again,but it gave me:

      Unknown database 'dbname'

      If the database doesnt have any tables then it's Unknown?!!

      Comment


      • #4
        Not drop, but empty the database. :)

        Obviously it's unknown because it doesn't exist! :) You'll have to recreate it.

        Comment


        • #5
          grrrr

          Ok I recreated the DB and then emptied the tables one by one,each table with a value of 0.

          still the same error:

          Table "access" already exist
          //and when I drop "access" I get :
          Table "announcment" already exists
          //and so on :(
          Last edited by theGAME; Sat 28th Apr '01, 3:42pm.

          Comment


          • #6
            Run this query, separating each table name by a comma:

            DROP TABLE tablename, tablename, tablename [etc etc etc] ;

            Comment


            • #7
              DROP TABLE announcement, bbcode, category, forum, forumpermission, icon, post, replacement, session, smilie, template, thread, user, usergroup, usertitle;

              bash: DROP: command not found

              Comment


              • #8
                That's a MySQL query. Hence you have to run it on your database from the mysql client or another MySQL administrator (phpMyAdmin).

                Comment


                • #9
                  Ed, this dropped the whole database,it's the same as clicking on DROP in front of each table name under Action!

                  I did dropped the tables where it says already exists,but then it keep telling me that other tables exists too (bbcode,post..etc)

                  Thats like dropping all the tables,so the whole DB is dropped,then what? :confused:

                  Comment


                  • #10
                    Yes, that's what I meant for you to do. Then you import your backup.

                    In the future, if you're using mysqldump to dump your database, you can specify the --add-drop-table option.

                    Comment


                    • #11
                      Ohh finally :)
                      Now I see the data backedup in phpMyAdmin.However,there is a slight problem in the forum url:

                      <!-- Database error in vBulletin: Invalid SQL: SELECT template,title
                      FROM template
                      WHERE title='options' OR title='cssinclude' OR title='header' OR title='footer' OR title='fivelinks'
                      OR title='jumpforumbit' OR title='forumjump'
                      mysql error: Unknown column 'title' in 'field list'
                      mysql error number: 1054
                      Date: Sunday 29th of April 2001 04:38:38 AM
                      Script: /vb2/index.php
                      Referer:
                      -->

                      Comment


                      • #12
                        I don't know what would cause that except if your backup wasn't correct (read: corrupt).

                        Comment


                        • #13
                          I actually made the backup from 1.1.5,should I revert to 1.1.5 then import again?

                          Comment

                          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                          Working...
                          X