Announcement

Collapse
No announcement yet.

Fatal error in step #3

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Fatal error in step #3

    hi,,,

    anybody knows whats the problem in step 3 :

    -------
    Attempting to connect...

    Fatal error: Call to unsupported or undefined function mysql_pconnect() in db_mysql.php on line 29
    -------

    help me please to solve this one

    thank you :)

  • #2
    also

    whereto find this file db_mysql.php, in which dirctory exactley

    Comment


    • #3
      first, could you tell me what OS and what version of mySQL and PHP you're using? I ran into this problem when trying to install on NT with PHP 3.0.x When I upgraded to PHP 4.0.0 all those problems went away
      Webmaster:
      @forumz

      Comment


      • #4
        It sounds like you do not have MySQL support turned on. In windows, that is just a matter of editing the php.ini file. In Unix systems, it is slightly more complicated.

        As Martin said - could you post a few more details please.

        John
        John Percival

        Artificial intelligence usually beats real stupidity ;)

        Comment


        • #5

          I'm using

          Red Hat Linux release 6.0

          MYSQL 3.22.32

          PHP 3.0.16

          Comment


          • #6
            In that case it looks like you have permanent connections to MySQL disabled. You can enable them in your php.ini (they are faster than standard connections) or you can change mysql_pconnect to mysql_connect in the db_mysql.php

            John
            John Percival

            Artificial intelligence usually beats real stupidity ;)

            Comment


            • #7
              :(

              I tried the second method that to change mysql_pconnect to mysql_connect , but no luck at all, same fatal message appear

              I'd like to try enable mysql in php.ini, but i don't know where the php.ini file located exactley.

              also, maybe the problem with my installation of Mysql

              can you suggest me other page for installation different that what you mentioned befor

              http://hotwired.lycos.com/webmonkey/99/21/index2a.html

              thank you again


              Comment


              • #8
                I do not think that it is a MySQL problem.

                The php.ini file should be installed to /usr/local/lib if I remember correctly. If there is no php.ini file there, you should extract the default one from the archive (php.ini-dist) and upload it to /usr/local/lib

                You can then edit that file.

                John
                John Percival

                Artificial intelligence usually beats real stupidity ;)

                Comment


                • #9
                  sam,
                  Red Hat does not install MySQL support in PHP by default. If you go to rpmfind.net you will find an rpm that will enable it.
                  Interested in Linux?
                  Have a question?
                  http://www.linuxquestions.org

                  Comment


                  • #10
                    Went and looked up the URL for you. [url]http://www.rpmfind.net/linux/RPM/mandrakecooker/contrib/RPMS/php-mysql-3.0.14-2mdk.i586.html[/url]

                    NOTE: I HAVE seen this RPM work with PHP 3.0.16.
                    Interested in Linux?
                    Have a question?
                    http://www.linuxquestions.org

                    Comment


                    • #11
                      Thank you customcpu

                      Actually I know little about linux, so i don't know how to install the rpm you mentioned.

                      Can you tell me how to install this rpm.

                      Thanks alot

                      Comment


                      • #12
                        sure...
                        You will need to be root to do this.

                        1) To be safe shutdown MySQL
                        2) At a prompt type "rpm -ivh php-mysql-3.0.14-2mdk.rpm"
                        (NOTE: Do not type the quotes + file name may differ)
                        3) Restart MySQL and apache

                        That's it. If you have any problems let me know.
                        Interested in Linux?
                        Have a question?
                        http://www.linuxquestions.org

                        Comment


                        • #13
                          WHOA!!!!!

                          That is an extremely old version of MySQL!

                          The current stable version is 3.22.32!!!!!

                          I highly recommend you use this version for Linux:

                          [url]http://www.mysql.com/Downloads/MySQL-3.22/MySQL-3.22.32-1.i386.rpm[/url]

                          and

                          [url]http://www.mysql.com/Downloads/MySQL-3.22/MySQL-devel-3.22.32-1.i386.rpm[/url]

                          Go get'm and make sure to do a "strip" on the *.so files and the binaries in the ~/mysql/bin and ~/mysql/libexec to get all the debug information out of the files if there is any.
                          http://racing.kos.net
                          http://www.rumour.com/

                          Comment


                          • #14
                            Actually 3.0.14 is the version of PHP.
                            Interested in Linux?
                            Have a question?
                            http://www.linuxquestions.org

                            Comment


                            • #15
                              Ah.

                              Now I see it. OK
                              http://racing.kos.net
                              http://www.rumour.com/

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X