Announcement

Collapse
No announcement yet.

vBulletin PHP Minimum Version Changes

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • vBulletin PHP Minimum Version Changes

    This is a quick announcement to alert customers to the fact that with forthcoming vBulletin releases, we will be raising the minimum PHP version required to run vBulletin software from PHP 4.0.6 to 4.1.0.

    However, as of the date of this announcement, the latest version of PHP 4 is the recommended version to run vBulletin, as testing with PHP 5 is not yet complete.

    Support for PHP 4.0.6 will be dropped in order to allow us to remove portions of legacy code whose sole purpose it backward compatability with older versions of PHP, which should afford a minor performance benefit.

    Additionally, this legacy code is not supported by PHP 5, so removing support for PHP 4.0.6 now prepares the way for full PHP 5 compatability.

    In summary:
    • PHP 4.0.6: incompatible
    • PHP 4.1.0: better
    • PHP 4.3.8: recommended
    • PHP 5: testing incomplete
widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X