Announcement

Collapse
No announcement yet.

Upgrade from 4.19 patch 4 to 5.0 beta 25 failed

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Upgrade from 4.19 patch 4 to 5.0 beta 25 failed

    Hi,

    I've tried several times to upgrade my board to the 5.0 b25 and it keeps failing around the same position. The board has almost 4 million posts, so it takes around 5 hours to get to the failed point.

    Basically after finally making it through to finish upgrading 5.0 Alpha 27 it seems to go back to trying to upgrade from 4.0



    If I continue to enter '1' I eventually get to this position





    I disable all plugins before I try to update and I do a repair database before the update. The database I'm upgrading from is a copy of a live site which works fine. After wasting about 2 days on this I'm now pretty much lost.

    Any help would be appreciated.

  • #2
    You're not even making it though the vB4 update steps atm, and if you're on 4.1.9 you shouldn't be running 4.1.5 upgrade steps.

    Try upgrading to 4.2.0 first.

    Comment


    • #3
      Originally posted by Zachery View Post
      You're not even making it though the vB4 update steps atm, and if you're on 4.1.9 you shouldn't be running 4.1.5 upgrade steps.

      Try upgrading to 4.2.0 first.
      Hi,

      The top screen dump is after it's upgraded to 5.0.0 Alpha 27 (from memory) it then reverts to try upgrade from 4.0.0, as if the 'upgrade log' version value gets corrupted at that stage - look at the bottom of that screen dump where it states "on current version ." - that screen dump also shows 'Upgrade Complete' after converting stylevars to VB5.

      I have tried updating to 4.2 and the same thing happens. It automatically updates to 4.2 anyway, before trying the 5.0 updates - and the 4 million post conversions take an age, so it is definitely doing a lot of what it should be to convert to 5.0.

      Thanks

      - - - Updated - - -

      Also note I'm on PHP 5.4, which has caused certain issues on my current VB 4 installation which I've got around from some edits recommended by VB users on this site. I installed from a fresh directory as recommended (not sure if all my folder permissions are correct from this new directory?) and yeah basically everything by the book.

      Comment


      • #4
        So, upgraded to 4.2 again and ran the update again and got the same result.

        It seems to revert to try to update from 4.0.0 after finishing 5.0 Alpha 27.

        Straight after this I get to the first screenshot above

        Comment


        • #5
          Why are you trying to upgrade again after the upgrade completes? Or am I missing something simple here?

          Comment


          • #6
            Originally posted by Zachery View Post
            Why are you trying to upgrade again after the upgrade completes? Or am I missing something simple here?
            It's only upgraded to Alpha 27, I'm trying to upgrade to Beta 25 - the upgrade.php script automatically takes me from completing 5.0 Alpha 27 to trying to upgrade from 4.0.0.0 again. Presumably that 'upgrade log' version is being corrupted after Alpha 27 to a value it's reading as null and then it tries to start again.

            Comment


            • #7
              Can you try running the upgrade from the web instead of the cli? Though we should try to get these bugs logged.

              Comment


              • #8
                I've managed to get it sorted now.

                Just to let everyone know how I got around the issue in case it happens to anyone else. After finishing Alpha 27 and when I was prompted to upgrade to version 4.0.0 (from version 'null') I closed my SSH client without choosing either, reopened and went again - it seen that my last update was Alpha 27 and then continued with the Beta updates.

                Comment

                Related Topics

                Collapse

                Working...
                X