Announcement

Collapse
No announcement yet.

PHP Memory Error during upgrade

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • PHP Memory Error during upgrade

    This thread is a continuation of the issue below - apologies for the double up but I cant access the thread now? When trying to enter the thread I've had a database error and this site hangs when I try to enter here LINK

    So... moving forward I'm receiving an error during step 12 of the upgrade script - when XML is being updated. The upgrade script seems to hang on step 12 for several minutes before throwing the error below:

    Code:
     Unexpected Text:
    
    <?xml version="1.0" encoding="windows-1252"?>
    <br />
    <b>Fatal error</b>: Allowed memory size of 134217728 bytes exhausted (tried to allocate 54669 bytes) in <b>/home/snappy/public_html/vB5/core/includes/class_diff.php</b> on line <b>170</b><br />
    I was advised this was a memory issue at server level. On checking I found that PHP had 256mb allocated, so this was increased to 512MB, however the error remained and I'm unable to complete step 12 of the upgrade.

    I have now set allowable memory to 650MB.... same error.

    This has happened during the upgrade script for Beta 20, 21, and now 22.

    My provider has asked if you can please review the PHP setup and advise if there are any changes required..

    PHP info available for your review HERE

    My site "seems" to be functioning fine, though not completing the upgrade is a concern, so any assistance is welcome.

  • #2
    If you're still getting memory exhausted errors and the Memory available is significantly above what is being requested, you should speak to your host to see if they can trace why the server is telling the script there isn't enough
    Vote for:

    - *Admin Settable Paid Subscription Reminder Timeframe*
    -
    *PM - Add ability to reply to originator only*
    - Add Admin ability to auto-subscribe users to specific channel(s)
    - Highlight the correct navigation tab when you are on a custom page
    - "Quick Route" Interface...
    - Allow to use custom icons for individual forums

    Comment


    • #3
      Hi Trevor.

      It was my host that asked for the vB team to check the PHP setup and see if there is anything they can do.... they dont understand why this is happening.

      Right now the site cant be modified via AdminCP. Users can post but anytime I try to modify a user profile etc via admincp I get "cannot modify birthday" or some such. It seems to be a permissions issue however being admin I have full rights......

      So its becoming a problem.

      Comment


      • #4
        We're not server experts, your host should be better placed to see/know why the server is throwing back an out of memory message than we are.

        Can you give me the exact error message for the editing problem please.
        Vote for:

        - *Admin Settable Paid Subscription Reminder Timeframe*
        -
        *PM - Add ability to reply to originator only*
        - Add Admin ability to auto-subscribe users to specific channel(s)
        - Highlight the correct navigation tab when you are on a custom page
        - "Quick Route" Interface...
        - Allow to use custom icons for individual forums

        Comment


        • #5
          Example.

          I try to change a users password via adminCP and I get the following error.

          has no permission to change the date of birth
          I tried to add RSS feeds... same error. Basically most things via adminCP seem to error out with this message, which has only started now with the upgrade to vB22

          Comment


          • #6
            OK - update.

            My host couldnt do anything with the server - we already had basically all memory allocated to PHP.

            I received this feedback:

            Hello Steve,

            I directly add the set memory limit code in the file /home/snappy/public_html/vB5/core/includes/class_diff.php and the upgrade went fine. Below were the changes made in the code.

            ----------------------------------------------------------
            Code:
            Old Code
                    function compress_row($row)
                    {
                            return gzcompress(implode('|', $row), 9);
                    }
            ----------------------------------------------------------
            New Code
                    function compress_row($row)
                    {
                            ini_set('memory_limit','512M');
                            return gzcompress(implode('|', $row), 9);
                    }
            ----------------------------------------------------------
            Please let me know if there is anything else I can assist you with.

            - - - - - - - - - - - - -
            Regards,
            Ray
            Site seemed to work better.

            Interestingly enough I took a backup of the class_diff file prior to running the full upgrade to beta 23 this morning (and expecting to have to hand modify the file) but the upgrade went faultlessly, including overwriting the class_diff file.....

            This is the first time in four beta releases that the upgrade script has worked for me, and it was faultless with no hanging.

            I've added this post for the information of community and developers... maybe it will help someone.

            Comment

            Related Topics

            Collapse

            Working...
            X