Announcement

Collapse
No announcement yet.

4.0.6 upgrade to 5.0 beta 18

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 4.0.6 upgrade to 5.0 beta 18

    Hi

    I have a working 'clean' install of 5.0 beta 16 on my development server but wanted to try and upgrade of the database to the latest version (beta 18).

    New database created, old database schema and data imported and a clean directory for the install.

    Whenever I run the 'upgrade.php' script from either SSH or the browser, I get the following:

    [[email protected] install]# php upgrade.php


    Database error in vBulletin :


    Invalid SQL:
    SELECT * FROM new_setting;


    MySQL Error : Table 'mt_v4.new_datastore' doesn't exist
    Error Number : 1146
    Request Date : Thursday, November 15th 2012 @ 11:07:46 PM
    Error Date : Thursday, November 15th 2012 @ 11:07:46 PM
    Script : http:///upgrade.php
    Referrer :
    IP Address :
    Username :
    Classname : vB_Database
    MySQL Version : 5.1.61

    Any clues?!

    Thanks in advance

  • #2
    Restore the backup of your database again - does the Datastore table exist before you try running the upgrade?
    Vote for:

    - *Admin Settable Paid Subscription Reminder Timeframe*
    -
    *PM - Add ability to reply to originator only*
    - Add Admin ability to auto-subscribe users to specific channel(s)
    - "Quick Route" Interface...

    Comment


    • #3
      Re-imported the backup.

      There is no new_datastore or new_setting in the database.
      There is a 'vb_datastore' which looks like the older stuff?

      Comment


      • #4
        Download a fresh copy of the vB files from the Members Area, delete all the vB4 files from your server (except any custom avatar/images directories) and upload the new copy of the vB5 files. Make sure your config files are updated then retry the upgrade
        Vote for:

        - *Admin Settable Paid Subscription Reminder Timeframe*
        -
        *PM - Add ability to reply to originator only*
        - Add Admin ability to auto-subscribe users to specific channel(s)
        - "Quick Route" Interface...

        Comment


        • #5
          It's literally a blank directory (/forum2) with the vb files I downloaded last night/early hours of this morning, I've not even copied across the images or avatars folder yet.

          I don't need to do anything prior to upgrading - running any other scripts etc?

          Comment


          • #6
            Nope, you shoudl be able to run the upgrade straight off - did you update the URLs in the database given you're using a different URL?
            Vote for:

            - *Admin Settable Paid Subscription Reminder Timeframe*
            -
            *PM - Add ability to reply to originator only*
            - Add Admin ability to auto-subscribe users to specific channel(s)
            - "Quick Route" Interface...

            Comment


            • #7
              Sorted it - my bad

              I was trying to use new_ for table names, when simply they were already vb_

              Comment


              • #8
                Originally posted by LeeRMR View Post
                Re-imported the backup.

                There is no new_datastore or new_setting in the database.
                There is a 'vb_datastore' which looks like the older stuff?
                Make sure the table prefix in /core/includes/config.php matches the table prefix you're using on your vBulletin 4.X installation. You can't simply change it in the config.php file and expect the system to be able to find non-existing tables.

                We do not recommend upgrading your live sites at this time.
                Translations provided by Google.

                Wayne Luke
                The Rabid Badger - a vBulletin Cloud demonstration site.
                vBulletin 5 API

                Comment


                • #9
                  That's a point - what table(s) would I need to update for the reference URL's in the config?

                  - - - Updated - - -

                  PS - this isn't a live site - I'm building a copy of our live site with VB5 connect on our preprod server.

                  Comment


                  • #10
                    Best way would have been to follow the steps here:

                    https://www.vbulletin.com/forum/cont...ng-A-Test-Site

                    If you're comfortable in editing the database, look for the 'bburl' value in the settings and datastore.options tables. Might also want to change the cookie path to '/forum2/ to ensure there's no issue with cookies across both sites.
                    Vote for:

                    - *Admin Settable Paid Subscription Reminder Timeframe*
                    -
                    *PM - Add ability to reply to originator only*
                    - Add Admin ability to auto-subscribe users to specific channel(s)
                    - "Quick Route" Interface...

                    Comment


                    • #11
                      Thanks

                      Comment


                      • #12
                        It isn't an URL that is causing the problem.

                        It is specifically this line:
                        $config['Database']['tableprefix'] = '';

                        In your vBulletin 5 file you have the value as new_. In your database the value is vb_. The value in /core/includes/config.php must match the value in your database. No way around it.
                        Translations provided by Google.

                        Wayne Luke
                        The Rabid Badger - a vBulletin Cloud demonstration site.
                        vBulletin 5 API

                        Comment


                        • #13
                          So far so good.

                          Have been stuck here for some time:

                          Upgrading to 5.0.0 Beta 18
                          ----------------------------------
                          Step 1 - Fixing blog post URLs.
                          Processed 2000 records
                          Process done
                          Step 2 - Fixing social group discussion URLs.
                          Processed 2000 records
                          Process done
                          Step 3 - Altering style Table (1 of 3)
                          Step 4 - Altering style Table (2 of 3)
                          Step 5 - Altering style Table (3 of 3)
                          Step 6 -

                          <waiting for over 70 mins now>

                          Is this normal?

                          Comment


                          • #14
                            How big is your site?
                            Translations provided by Google.

                            Wayne Luke
                            The Rabid Badger - a vBulletin Cloud demonstration site.
                            vBulletin 5 API

                            Comment


                            • #15
                              Turns out pretty large. Finished about 15 mins ago.

                              I've flushed out the cache, removed install.php, changed all of the URL's from our old site to test site, but this is happening:

                              http://www.lapbackup.co.uk/forum2/

                              Any ideas? Some permissions wrong somewhere?

                              Comment

                              Related Topics

                              Collapse

                              Working...
                              X