Announcement

Collapse
No announcement yet.

Unable to Post, and No Stylesheet Applied Unless Logged In

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Unable to Post, and No Stylesheet Applied Unless Logged In

    Just upgraded a test environment from vb4 to vb5, and while we're struggling to learn the in's and out's of all the changes, it would appear two consistent issues have come up:

    1. When I try to post anything, I am given the error message that reads: "Edit Conversation...Maximum number of characters exceeded. It can be more than 0 characters". My test post reads simply, "Test Message".

    2. If I am not logged in, the page does not appear to use any stylesheet.

    Any ideas as to how to fix these? Thanks...

    Web

  • #2
    1) Make sure that the url listed as the baseurl in your /config.php file is the URL that you're accessing the site from.

    2) if you have .htaccess in a parent directly, add RewriteBase to your vB5 .htaccess directly under RewriteEngine On. Should be like RewriteBase /vb5/ where vb5 is the name of the directory you installed the software in.

    3) Verify your permissions for all usergroups for posting under Channels -> Channel Permissions. You can set global permissions by editing the HomePage Channel.
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud demonstration site.
    vBulletin 5 API

    Comment


    • #3
      Originally posted by Wayne Luke View Post
      1) Make sure that the url listed as the baseurl in your /config.php file is the URL that you're accessing the site from.

      2) if you have .htaccess in a parent directly, add RewriteBase to your vB5 .htaccess directly under RewriteEngine On. Should be like RewriteBase /vb5/ where vb5 is the name of the directory you installed the software in.

      3) Verify your permissions for all usergroups for posting under Channels -> Channel Permissions. You can set global permissions by editing the HomePage Channel.
      Did as you suggested, and everything is the same. What else can I try? Thanks...

      Web

      Comment


      • #4
        Any other ideas? Thanks so much....

        Web

        Comment


        • #5
          I'd need a link to your site.
          Translations provided by Google.

          Wayne Luke
          The Rabid Badger - a vBulletin Cloud demonstration site.
          vBulletin 5 API

          Comment


          • #6
            www.nenosplace.com/vb5/

            Thanks so much!

            Comment


            • #7
              It looks like you have css as files on, try disabling that.

              AdminCP > Settings > Options > Style & Language Settings > Store css as files > No

              Comment


              • #8
                Thank you, Zachery. That fixed item #2 in my original post. Item #1 still remains - Unable to post, as administrator, with proper access granted to channel. Keep getting the following error: "Maximum number of characters exceeded. It can be more than 0 characters". I have edited the .htaccess file as suggested, and baseurl in the config file is correct. Any other ideas? Thank you so much...

                Web

                Comment


                • #9
                  What do you have for "Maximum Number of Characters in a Post"?

                  In the Admin CP go to Settings -> Options -> Message Posting and Editing Options. Change Maximum Characters Per Post. Save. Default is 10,000 characters. Could be a bug with 0 there disabling it and we'd need that entered into JIRA.
                  Translations provided by Google.

                  Wayne Luke
                  The Rabid Badger - a vBulletin Cloud demonstration site.
                  vBulletin 5 API

                  Comment


                  • #10
                    That was it, Wayne!! Definite bug then. It was set to 0. I put it to 10,000, and all of a sudden, I'm posting like a champ! Thanks so much!!!

                    Web

                    Comment


                    • #11
                      I've entered it into JIRA, but to be honest the way it works isn't going to be the highest priority to get fixed. They'll get to it though.

                      http://tracker.vbulletin.com/browse/VBV-6014
                      Translations provided by Google.

                      Wayne Luke
                      The Rabid Badger - a vBulletin Cloud demonstration site.
                      vBulletin 5 API

                      Comment


                      • #12
                        Can you upgrade to Beta 18 and set the value to 0 again to see if the same issue continues?
                        Translations provided by Google.

                        Wayne Luke
                        The Rabid Badger - a vBulletin Cloud demonstration site.
                        vBulletin 5 API

                        Comment


                        • #13
                          Yeah, I'll go ahead and upgrade to version 18, but I probably won't be able to get to it until next weekend. So I'll keep this thread bookmarked, and report back when I do. Thanks for keeping on top of this issue. Very much appreciate it...

                          Web

                          Comment

                          Related Topics

                          Collapse

                          Working...
                          X