Announcement

Collapse
No announcement yet.

VBulletin v5.0.3 to v5.0.4 upgrade error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Zachery
    replied
    Make sure to remove your install folder now that your upgrade is done.

    Leave a comment:


  • marky
    replied
    Seems to be working fine now.

    What we did:
    1. Downloaded the new security patch for v5.0.4
    2. Re-uploaded everything (except config.php file)
    3. Ran the upgrade.php script
    4. Upgrade process was successful.
    5. Went to admin cp. Could log in this time.
    6. Turned forum back on and it seemed ok.

    Leave a comment:


  • marky
    replied
    Yes, we just made a backup, but did not utilize it.

    Basically:
    1. Took a back up of code and db on the live server.
    2. Extracted v5.0.4 zip file on local pc and then overrode the files on the live server (other than the config.php files)
    3. Ran the upgrade script
    4. Errors showed up

    Due to the errors, we are unable to log in to the Admin CP.
    We can get to the log in page (/admincp), but upon entering valid log in info, it redirects us to /login.php?do=login and shows a white page.

    Leave a comment:


  • Lynne
    replied
    Ah, I see... you just downloaded the backup to localhost. I misread you.

    Go to admincp > Maintenance > Diagnostics > Suspect File Versions. Anything show up there?

    Leave a comment:


  • marky
    replied
    We turned the site off on the server from the Admin CP.

    We did not install on localhost so we did not need to change the url. We wanted to upgrade and set it up on our server directly.

    Leave a comment:


  • Lynne
    replied
    When you backed up the database that you were going to download to localhost, did you make sure to turn off your site first and change the URLs in AdminCP > Settings > Options > Site Name/URL/etc first so that they would point to your localhost install?

    Leave a comment:


  • marky
    started a topic VBulletin v5.0.3 to v5.0.4 upgrade error

    VBulletin v5.0.3 to v5.0.4 upgrade error

    We recently upgraded out forums from v5.0.3 to v5.0.4 but after we did that we faced 2 issues. This is what we did:

    1. Backed up the DB and v5.0.3 code folder
    2. Extract v5.0.4 on local computer and override all files on server with it (ascii files and binary files were uploaded correctly). Files excluded from upload were the 2 config.php files and the install.php file. No core files were modified (apart from the config.php ones, but this hasnt changed since original install).
    3. Ran the upgrade script on /core/install/upgrade.php
    4. Upgrade process ran successfully. After it upgrade it told us to go to Admin CP.
    5. When we clicked that button it would go to a white page. Tailing the error log we see this when that takes place:

    PHP Fatal error: Class 'vB5_Facebook' not found in /var/www/html/includes/vb5/frontend/routing.php on line 40

    6. We couldn't figure out why that was happening, so we tried to do the upgrade process again.
    7. This ran successfully, but this time we could view the admin login screen. However, once we enter our admin details and log in, we get a white page. No errors show in the log.

    We also see this error message in the log:

    PHP Fatal error: Class 'vB' not found in /var/www/html/includes/vb5/template.php on line 129

    Could you please let us know how to fix this? Thanks.

Related Topics

Collapse

Working...
X