Announcement

Collapse
No announcement yet.

Unicode font in upgrade to 5.x

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Unicode font in upgrade to 5.x

    Hi All

    I upgraded to 5.0.4 version from 4.2.1, and I am facing with Vietnamese font (I am using Unicode font) - you can get my forum on http://www.bsdapp.com/forum/ Note that it is good in version 4.2.1. I also change my database into utf8_unicode_ci (see my picture).

    Please help me to fix it.

    thanks in advance.


    My forum http://forum.bsdinsight.com

  • #2
    I can see that in VB4.2.1 database, I can see in Vietnamese language by PhPMyAdmin program, but I cannot see it in Vietnamese language once upgrade into 5.0.4 version. I think that converting data in upgrade.php program does not keep current font in database.

    Please help me to fix it.

    Thanks in advance.
    My forum http://forum.bsdinsight.com

    Comment


    • #3
      I sure that convert database program did not keep font in database.

      Does any technicians in Vbulletin support me?
      My forum http://forum.bsdinsight.com

      Comment


      • #4
        It seems big problem, you can see http://tracker.vbulletin.com/browse/...mment-tabpanel
        My forum http://forum.bsdinsight.com

        Comment


        • #5
          It isn't a font issue... vBulletin doesn't store fonts anywhere in the system. That is beyond the scope of the software.

          It is a character encoding issue. On your vB 4.2.1 install, what did you have for your character encoding in the Language Manager. Is that database still available?

          Also did you change the encoding of your database before or after running 4.2.1? Before or after the upgrade? Depending on your version of MySQL and how data is stored, changing the encoding can break things.
          Translations provided by Google.

          Wayne Luke
          The Rabid Badger - a vBulletin Cloud demonstration site.
          vBulletin 5 API

          Comment


          • #6
            Yes, I know that it is in system, and system does not store font, but upgrade program covered in incorrect. I am using MySQL and I using collation is utf8_unicode_ci and we can store Vietnames language in database and VB4.2.1 can display correctly.

            I did not change anything, just to do upgarage.php program and all data in data change another font and V5.0.4 displays incorrect language.

            In my forum (www.bsdapp.com/forum/). I can create new topic with Vietnamese language correctly that mean I make sure that upgrade.php program covered incorrect. It does not keep current font in database..
            My forum http://forum.bsdinsight.com

            Comment


            • #7
              I would like to downgrade my forum to 4.2.1, so I copy error forum in here and I would like to say thanks for any one to help me to fix it.

              I also give summary in here with my forum:
              - My forum is in English language, but all content of forum in Vietnamese language. I am using MySQL with collation is utf8_unicode_ci.
              - It is correct in VB4.2.1 that can display content in Vietnamese language and I can see Vietnamese language in my Database.
              - Upgrade to 5.0.4 version, and it cannot display in Vietnamese language, and content of database does not Vietnamese language.
              - In VB5.0.4. I can create new topic in Vietnamese language and it is correct one. It means can display in Vietnamese language, and I can see in database with Vietnamese language also.


              and now, I downgrade it.

              P/S I have a tracker in VB here: http://tracker.vbulletin.com/browse/...mment-tabpanel
              My forum http://forum.bsdinsight.com

              Comment


              • #8
                It is good news - I found solution already.

                Fixed!!!

                Thanks all so much.
                My forum http://forum.bsdinsight.com

                Comment


                • #9
                  Hi bsdvn

                  Can you please describe that how you fix that problem?

                  Because i made same update and my Turkish characters gone also and i'm trying to fix it

                  Comment

                  widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                  Working...
                  X