Announcement

Collapse
No announcement yet.

How to upgrade from vbulletin 4 to latest vbulletin 5

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • janmf1983
    replied
    Can delete my post, i have done it wrong
    Last edited by janmf1983; Mon 1 Apr '13, 11:01pm.

    Leave a comment:


  • Trevor Hannant
    replied
    You don't still have the vB4 files in the same directory as your upgraded site do you?

    Leave a comment:


  • Fera
    replied
    Anyone?

    Leave a comment:


  • Fera
    replied
    I've digged into the code, and found out that it tries to reference the "register.php" file.

    It expects it to be in the path: [baseurl]/core/register.php
    but this file doesn´t exists there. It´s on [baseurl]/core/vb/api/vb4

    If the site works on a clean install and has this kind of bung on a "upgrade" install, it may be some wrong setting value stored on database, I think.
    Any clue on which table should I look for ?



    Last edited by Fera; Fri 22 Mar '13, 8:45am.

    Leave a comment:


  • Fera
    replied
    Good day Joe,

    Let me tell more about my case.
    I first installed the vb5 in a blank database, and everything worked allright. Then I just dropped all tables, restored the vb4 database on it, and runned the upgrade script. The upgrade process runned with no erros. But I can´t login.

    I've tried your suggestions, but it didn´t work.

    I think it´s not cookie related because the site worked when I installed on a blank database. Just after migration I had this issues.
    Hey, I've change the debug config to true, and now I'm getting this error on the registration page. Maybe it´s a bug or something wrong. Look:

    Debug: Error
    Invalid Page URL
    occurred in file /home1/intelig9/public_html/vb/includes/api/interface/collapsed.php on line 114
    Trace
    • Function relay in file /home1/intelig9/public_html/vb/includes/vb5/frontend/controller/relay.php line 56
    • Function legacy in file line
    • Function call_user_func_array in file /home1/intelig9/public_html/vb/index.php line 141


    Thanks for help.


    Leave a comment:


  • BirdOPrey5
    replied
    I see you have a VB4 forum on the same domain.

    I suggest changing the cookie prefix in the 2 VB5 config.php files to something else, maybe bb2 instead ot the default bb so we can eliminate the possibilities cookies are causing the issue.

    Remember you must make the change in both config.php files.

    Also, If you manually add the s after the question mark, does the page work?

    That is to say, change: ?_=1363920292420 to ?s=1363920292420

    Leave a comment:


  • Fera
    replied
    Joe, good to know you're alive. I just bought the license yesterday. My problem is that, after upgrade, I can't login. It seems it authenticate my user but don't get the session. After I put my user name and password it tries to login and return to previous screen but my page acts like I am a visitor. The only change is the URL that gets an question mark and a sort of Id appended to it. Like this: "?_=1363920292420"

    The same occurs if I try the administration login.

    If I try the lost password option, I just get an grey empty screen, just the background of the default style.

    Any clues?

    Leave a comment:


  • BirdOPrey5
    replied
    VB5 has 2 config.php files, you must fill them both out.

    Then you need to run the upgrade script like with any other VB upgrade.

    Make sure you backup your database before attempting to upgrade.

    I am sorry about the 20 days without an answer, in the future feel free to "bump" your thread after a couple days- if it gets too old likely we'll never see it even if answered. 2 to 5 days is fine to "bump" a support thread so long as it's on a supported issue, like this.

    Leave a comment:


  • Fera
    replied
    More then 20 days and no answer here ? What kind of support is there ? I'm having a lot of problems after migrating from vb4 to vb5, and felling alone by myself.

    Leave a comment:


  • How to upgrade from vbulletin 4 to latest vbulletin 5

    Hi im trying to upgrade my vb4 forum to latest vb5 without losing all my posts and users, its possible? i tried but without luck, i just configure vb5 in another folder vb5/ but config.php with same vb4 db mysql so it can upgrades to new vb5 but doesnt work, what im doing wrong?

    thank you very much.

Related Topics

Collapse

Working...
X