Announcement

Collapse
No announcement yet.

Upgrading vBulletin from 4.2.2 to the latest version questions

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Upgrading vBulletin from 4.2.2 to the latest version questions

    I've been asked by a group who is currently running a vBulletin forum to upgrade their vBulletin software to the latest version. They haven't updated in a while and they would like to get back on track. Here is currently what their setup looks like:
    • vBulletin 4.2.2 Patch Level 4
    • PHP 5.5.38
    • MariaDB 5.5.68
    From my understanding, in addition to upgrading the vBulletin software, they are also going to need to upgrade their PHP and MySQL/MariaDB versions as well. If this is the case, I feel like the upgrade will need to be done in stages.

    This is my thinking of how the stages would go:
    1. Upgrade vBulletin to 4.2.5
    2. Upgrade PHP to 7.2+
    3. Upgrade MySQL/MariaDB to 5.6.10+
    4. Upgrade vBulletin to 5.x
    I would appreciate any suggestions if this doesn't look correct.

    It looks like vBulletin supports PHP 7.2.0+. Does that mean just 7.2.x or does that mean that we can run 7.3.x or 7.4.x?

    It looks like vBulletin supports MySQL 5.6.10+/MariaDB 10.0.0+. Does that mean MySQL 8.x can be used as well?

    Can vBulletin be upgraded from 4.2.5 to the latest version directly or does it need to be upgraded to some 5.x version first and then to the latest version?

    The forums are currently running in a sub-directory of their main website. Can the forums be moved to a sub-domain so that it is essentially isolated from the main website?

    I really appreciate any guidance on any of these questions.

    Thank you!

Related Topics

Collapse

Working...
X