Announcement

Collapse
No announcement yet.

vb 5.6.2 requirements not compatible with vb 4.2.5

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • vb 5.6.2 requirements not compatible with vb 4.2.5

    Hello

    I have vB 4.2.5 on same server with vB 5.3.1 (I'm selling plugin which supports vB 4 and 5). I would like to update vB5 but there is an issue - it has requirement not compatible with vB 4

    According to your page:
    vBulletin 5.6.2 - 5.6.4 require PHP 7.2.0+ and MySQL 5.6.10+ (or MariaDB 10.0.0+)
    vBulletin 4.2.5 requires PHP 5.6.0 through PHP 7.1.33 and MySQL 5.5.8+.
    So my question is: can I safely update PHP to 7.2.0?

    According to official information for some reason vB 4 works on PHP up to 7.1.33 but not on 7.2.0
    Does somebody have working vB 4 on PHP 7.2.0 without issues?

    vBulletin Enterprise Translator (vBET) - your forum in 52 languages!

  • #2
    vBulletin 4 is no longer in development, and hasn't been for some years. So it has not been updated to work with later versions of php, and almost certainly never will be.

    If you update to php 7.2, vBulletin 4 will not function correctly.

    You'll need to use something like a php handler to specify different php versions for each installation.
    MARK.B | vBULLETIN SUPPORT

    TalkNewsUK - My vBulletin 5.6.4 Demo
    AdminAmmo - My Cloud Demo

    Comment


    • #3
      So in case if I would like to upgrare from vb 4.2.5 to vb 5.6.2 how can I do that? With some partial upgrate? What would be the glue version then?
      vBulletin Enterprise Translator (vBET) - your forum in 52 languages!

      Comment


      • #4
        Originally posted by NLP-er View Post
        So in case if I would like to upgrare from vb 4.2.5 to vb 5.6.2 how can I do that? With some partial upgrate? What would be the glue version then?
        You wouldn't need one.

        The site is not open at the time you upgrade so you close your site, back it up, switch to php 7.2, then upload the 5.6.4 files and run the upgrade script.
        MARK.B | vBULLETIN SUPPORT

        TalkNewsUK - My vBulletin 5.6.4 Demo
        AdminAmmo - My Cloud Demo

        Comment

        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
        Working...
        X