Announcement

Collapse
No announcement yet.

Issue upgrading to 5.6.3

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • petec
    replied
    Hi Wayne,

    I think I've sorted it.

    The words table is utf8_bin which matches phrase.varname
    So I've set everything DB, table and columns to that and commented out
    Code:
    $config['Mysqli']['charset'] = 'utf8mb4';
    from my config.php

    Now the search index appears to be rebuilding !

    Thanks

    Leave a comment:


  • Wayne Luke
    replied
    What is the character set of the Word table? The character set and collation of the Database, Tables, and every text field in each table has to be exactly the same.

    What is the full error?

    Leave a comment:


  • petec
    replied
    The error is 'Error Invalid SQL: SELECT * FROM words WHERE `word` IN ....'
    I've tried using phpmyadmin to check the database and tables, but I get.

    #1062 - Duplicate entry 'x_posts--1' for key 'name_lang_type'

    The varname is showing as utf8_bin where as everything else update to latin1_swedish_ci
    So I've tried setting everything to utf8_bin and that hasn't helped.

    any suggestions ?
    Thanks

    Leave a comment:


  • petec
    replied
    Hi Wayne.

    I've uploaded the no phar files and this is now working.
    However I do get one error.

    When I try running 'Rebuild Search Index' I get a MySQL error:

    MySQL Error : Illegal mix of collations for operation 'in'
    Error Number : 1271

    I've made sure the database and all tables are set as latin1_swedish_ci and checked the columns in each table.
    Some are set and some are blank.

    Can you advise how to fix this please.

    Thanks

    Leave a comment:


  • Wayne Luke
    replied
    Do not know why you're receiving these issues. The core/vb/ directory should have two files. vb.php and vb.phar. The missing functions are in vb.phar.

    Use the non phar download to use individual files and let me know it if the issue continues.

    Leave a comment:


  • petec
    replied
    Hi Wayne,

    php-phar is installed and enabled:

    php -m
    [PHP Modules]
    Core
    ctype
    date
    dom
    filter
    gd
    hash
    iconv
    json
    libxml
    mbstring
    mysqli
    mysqlnd
    pcre
    PDO
    pdo_mysql
    pdo_sqlite
    Phar
    Reflection
    session
    SimpleXML
    SPL
    sqlite3
    standard
    tokenizer
    xml
    xmlreader
    xmlwriter

    [Zend Modules]



    php -i | grep phar

    /etc/php7/conf.d/phar.ini,
    Registered PHP Streams => php, file, glob, data, http, ftp, phar
    Phar-based phar archives => enabled
    Tar-based phar archives => enabled
    ZIP-based phar archives => enabled
    phar.cache_list => no value => no value
    phar.readonly => On => On
    phar.require_hash => On => On

    I can try the non phar files, but would like to get this working as is if possible.

    Leave a comment:


  • Wayne Luke
    replied
    Do you have PHAR enabled in PHP? It should be enabled by default but it may be disabled on your server for some odd reason.

    https://www.php.net/manual/en/phar.installation.php


    If you cannot enable PHAR for some reason, then you can download the non-PHAR version by clicking on "More Download Options" then Customize on the vBulletin 5 download screen. PHAR is the default because it provides simpler upgrades. Instead of the /core/vb directory containing hundreds of files and directories, it is zipped into a PHAR file. This means there are two files in the directory and they take up less space.

    Leave a comment:


  • petec
    replied
    I've had to edit the default http.conf and add Options Indexes FollowSymLinks
    Now mod_rewrite is working

    However this still fails to work, the error_log shows when I got to http://x.x.x.x/install/upgrade.php

    [Tue Oct 13 09:54:34.000099 2020] [php7:error] [pid 4461] [client 192.168.1.21:60177] PHP Fatal error: Trait 'vB_Trait_NoSerialize' not found in /srv/www/htdocs/core/includes/class_core.php on line 70

    [Tue Oct 13 09:54:34.002334 2020] [php7:notice] [pid 4461] [client 192.168.1.21:60177] Class 'vB_Shutdown' not found\n## /srv/www/htdocs/core/vb/vb.php(483) Exception Thrown \n#0 [internal function]: vB::shutdown()\n#1 {main}

    Any ideas ?
    Thanks

    Leave a comment:


  • petec
    replied
    Hi Wayne.

    Thanks for the reply.


    My PHP version is:
    PHP 7.2.5 (cli) ( NTS )
    Copyright (c) 1997-2018 The PHP Group
    Zend Engine v3.2.0, Copyright (c) 1998-2018 Zend Technologies

    mod_rewrite wasn't enabled, I've enabled it and restarted apache2

    a2enmod -l
    actions alias auth_basic authn_file authz_host authz_groupfile authz_core authz_user autoindex cgi dir env expires include log_config mime negotiation setenvif ssl socache_shmcb userdir reqtimeout authn_core php7-mysql php7 php7-phar rewrite

    htdocs is a directory not a link ( srv & www are also directories )
    4.0K drwxr-xr-x 10 root root 4.0K Oct 13 08:45 htdocs


    I've tried accessing the page via the LAN on 192.168.1.21 and from the local machine.

    The error_log shows nothing, but the access log shows:
    127.0.0.1 - - [13/Oct/2020:08:53:26 +0100] "GET /install/upgrade.php HTTP/1.1" 404 981 "-" "Mozilla/5.0 (X11; Linux x86_64; rv:78.0) Gecko/20100101 Firefox/78.0"


    I've confirmed using phpinfo() that mod_rewrite is installed and enabled.

    Any other ideas ?

    Thanks

    Leave a comment:


  • Wayne Luke
    replied
    I'm now trying to go to http://x.x.x.x/install/upgrade.php but I get page not found. Which would be correct as there is no install folder in htdocs.
    The rewrites in your .htaccess file aren't working then. It should redirect you to the /core/install/upgrade.php file.
    See this post: https://forum.vbulletin.com/forum/vb...40#post4391640

    Regarding errors:

    On my test server the files are in /srv/www/htdocs so I've backed that up and emptied as per the guide.
    Is /srv/www/htdocs an actual directory or a symbolic link? It needs to be a directory due to how PHP handles directory handles by default.

    Also make sure you're using the proper version of PHP. If your server had set this version via .htaccess, you would have to manually add those lines to the virtual host file or the .htaccess file provided by vBulletin.

    Leave a comment:


  • petec
    replied
    If I run http://x.x.x.x/core/install/upgrade.php I get the following in the apache2 error_log:

    [Mon Oct 12 13:43:51.123631 2020] [php7:error] [pid 4236] [client 192.168.1.21:52028] PHP Fatal error: Trait 'vB_Trait_NoSerialize' not found in /srv/www/htdocs/core/includes/class_core.php on line 70

    [Mon Oct 12 13:43:51.125958 2020] [php7:notice] [pid 4236] [client 192.168.1.21:52028] Class 'vB_Shutdown' not found\n## /srv/www/htdocs/core/vb/vb.php(483) Exception Thrown \n#0 [internal function]:

    Leave a comment:


  • petec
    started a topic Issue upgrading to 5.6.3

    Issue upgrading to 5.6.3

    Hi,
    I'm currently running 4.2.5 and have upgraded my OS so PHP is upgraded to 7.2+

    I've extracted the upload folder from the v5 zip file.
    On my test server the files are in /srv/www/htdocs so I've backed that up and emptied as per the guide.
    I've copied the contents of upload to htdocs and editted the config.php in core/includes/
    I've copied config.php.bkp to config.php
    I've renamed htaccess.txt to .htaccess


    I'm now trying to go to http://x.x.x.x/install/upgrade.php but I get page not found. Which would be correct as there is no install folder in htdocs.

    How am I meant to do this ?
    This is the guide I'm following:
    https://forum.vbulletin.com/forum/vb...lletin-connect

    Thanks

Related Topics

Collapse

Working...
X