Announcement

Collapse
No announcement yet.

Installation Error with 5.6.2 PL1

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Installation Error with 5.6.2 PL1

    Hello

    I'm trying to install vb 5 5.6.2 LP1 on my pc localhost by XAMPP but this is what happens

    1- Configuration: includes/config.php does not exist. For a new install click here
    2- I clicked here and it's fine
    3- Warning frontend already exists.
    4- I start install

    5- Warning: file_get_contents(): Filename cannot be empty in ...\install\makeconfig.php on line 271 Error - Could not open frontend config file.

    6- I`m a licensed member and waiting for help 😁

  • #2
    Please follow these steps from the vb5readme.html included in your vBulletin download package:

    Manually editing the config.php files


    Occasionally, the Configuration Builder tool will fail to write your config.php files. When this happens you will need to edit the files manually. If you're still on the Configuration Builder tool, you can copy and paste the contents of each window into their respective files and save. If not, you will need to manually edit the files using a text editor. Do so following these steps:
    1. In your vbulletin_root find the file named config.php.bkp. Rename it to config.php using your FTP client.
    2. In your vbulletin_core enter the includes folder. Look for a file named config.php.new. Rename it to config.php. You will need to edit this file. If you're using Filezilla, open the context menu (right-click in Windows) and choose "View/Edit File". It will ask you what application to use. We recommend Notepad++ or Wordpad.
    3. You will need to update several values in this file in order to connect to your database and receive error emails. These areatabase Name: $config['Database']['dbname'] = 'forum';Replace forum with your database name.Server Name: $config['MasterServer']['servername'] = 'localhost';Replace localhost with your servername if required by your hosting provider.Server Port: $config['MasterServer']['port'] = 3306;Change 3306 with the port number that your hosting company provides, if any. Otherwise don't change this.Database User Name: $config['MasterServer']['username'] = 'root';Replace root with your database user name.Database User Password: $config['MasterServer']['password'] = '';Place your database user password between the quotes.Technical Email $config['Database']['technicalemail'] = '[email protected]';Replace [email protected] with your email address.If you don't know any of these values, you will need to contact your hosting provider to obtain them. vBulletin Technical Support does not have this information.
    4. After making your changes save your file.
    5. Return to your FTP client and upload the file to your server. If you're using FileZilla and it was running in the background, it will automatically prompt to upload the updated file.
    6. Once this is completed, you can return to Step 8 of Running the Install Wizard.
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud demonstration site.
    vBulletin 5 API

    Comment


    • #3
      Perfect

      Thank you, sir

      The explanation was sufficient 💚

      After installing, I deleted install.php but I`m facing this

      Object not found!
      from http://localhost/vb/admincp

      The requested URL was not found on this server. If you entered the URL manually please check your spelling and try again.

      If you think this is a server error, please contact the webmaster.
      Error 404

      localhost
      Apache/2.4.43 (Win64) OpenSSL/1.1.1g PHP/7.4.8

      and step 8 https://forum.vbulletin.com/core/#step_8
      Is Forbidden

      I don't have permission to access /core/ on this server.

      waiting for your reply sir Click image for larger version

Name:	Screenshot 2020-08-13 10.55.48.png
Views:	89
Size:	86.9 KB
ID:	4445413
      Attached Files
      Last edited by hussain2000; Thu 13 Aug '20, 12:59am.

      Comment


      • #4
        Most likely cause is that rewrites aren't implemented. The /admincp/ directory doesn't actually exist on the server and it shouldn't.

        After installing vBulletin 5, my site is unformatted and I cannot reach the AdminCP

        This means that URL Rewriting is not working on your site. Possible causes include:
        • htaccess.txt has not been renamed to .htaccess (the leading period is important)
        • mod_rewrite is not installed for Apache 2.4
        • URL Rewrite is not installed for IIS 8.5+
        • The server configuration for NGINX has not been updated. See the file for your version of PHP within the do_not_upload folder.
        • AllowOverride is not allowed in the Apache configuration file.
        You hosting provider can help you get the ability to rewrite URLS working on your site.
        Translations provided by Google.

        Wayne Luke
        The Rabid Badger - a vBulletin Cloud demonstration site.
        vBulletin 5 API

        Comment


        • #5
          Thank you so much

          Comment


          • #6
            Hello Wayne

            kindly let me know why I`m facing this

            Click image for larger version

Name:	1.png
Views:	64
Size:	68.0 KB
ID:	4445570
            Click image for larger version

Name:	2.png
Views:	73
Size:	51.4 KB
ID:	4445571
            Attached Files

            Comment


            • #7
              Same reason as in Post #4 above.
              Translations provided by Google.

              Wayne Luke
              The Rabid Badger - a vBulletin Cloud demonstration site.
              vBulletin 5 API

              Comment


              • #8
                Dear Wayne

                what is the best software to install vb5 on pc localhost

                I mean

                another thing like xampp

                with my best regards

                Comment


                • #9
                  The best is Apache, PHP and MySQL. XAMPP already includes these so you really shouldn't have to change this.

                  You most likely have to set AllowOverride All in the httpd.conf file that ships with XAMPP. This value is disabled in a default installation. According to the XAMPP FAQ your configuration files are at:

                  The main XAMPP configuration files are located as follows:
                  • Apache configuration file: \xampp\apache\conf\httpd.conf, \xampp\apache\conf\extra\httpd-xampp.conf
                  • PHP configuration file: \xampp\php\php.ini
                  • MySQL configuration file: \xampp\mysql\bin\my.ini
                  • FileZilla Server configuration file: \xampp\FileZillaFTP\FileZilla Server.xml
                  • Apache Tomcat configuration file: \xampp\tomcat\conf\server.xml
                  • Apache Tomcat configuration file: \xampp\sendmail\sendmail.ini
                  • Mercury Mail configuration file: \xampp\MercuryMail\MERCURY.INI
                  Then you will need to edit the AllowOverride configuration. The documentation for that is here:
                  https://httpd.apache.org/docs/2.4/mo...#allowoverride

                  The easiest configuration is to set it to t ALL.
                  Translations provided by Google.

                  Wayne Luke
                  The Rabid Badger - a vBulletin Cloud demonstration site.
                  vBulletin 5 API

                  Comment


                  • #10
                    You may also have to enable mod_rewrite. Here is a third-party tutorial on this: https://lancelhoff.com/enabling-htac...he-on-windows/
                    Translations provided by Google.

                    Wayne Luke
                    The Rabid Badger - a vBulletin Cloud demonstration site.
                    vBulletin 5 API

                    Comment


                    • #11
                      # already removed from the line by xmapp owners for the latest version

                      I`ll replay you soon
                      Last edited by hussain2000; Sat 15 Aug '20, 11:51am.

                      Comment


                      • #12
                        Removed what line? If you remove a line from the Configuration files, then a default kicks in and that is the exact opposite of what you want here.
                        Translations provided by Google.

                        Wayne Luke
                        The Rabid Badger - a vBulletin Cloud demonstration site.
                        vBulletin 5 API

                        Comment


                        • #13
                          Thank you so much for your time
                          I think think that I need vBulletin cloud to rest my mind

                          with my best regards ❣❤

                          Comment


                          • #14
                            Hello Wayne

                            I'm facing this right now

                            and kindly let me know when to add
                            . for htacces.txt ,,,, before installation or after
                            Click image for larger version  Name:	s.jpg Views:	0 Size:	146.9 KB ID:	4445643
                            Last edited by hussain2000; Sun 16 Aug '20, 12:22pm.

                            Comment


                            • #15
                              This was the issue

                              $config['MasterServer']['servername'] = 'localhost';

                              should be localhost

                              thank you

                              Comment

                              Related Topics

                              Collapse

                              Working...
                              X