Announcement

Collapse
No announcement yet.

3.6.8 -> 5.6.2 upgrade issues

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 3.6.8 -> 5.6.2 upgrade issues

    Hi there.

    After some years I was forced to move my fairly old heavily modified VB368 big board to a new server finally. And apart from that move - want to update the forumsoft to current 5.6.2 version.

    Bought current vb5 connect and I am back ready to rock

    I am using th CLI, and will be posting my current progress with a kind help request from others to guide me through the night.
    I am working on a backup/test server to make the final move and update most hasslefree as possible.


    My current problem is:

    Upgrading to 3.7.0 Beta 2

    error message:

    Step 77 - Altering moderation Table (5 of 6)

    ----------------------------------
    Duplicate entry '134596-thread' for key 'PRIMARY'
    ----------------------------------
    ALTER TABLE vb_moderation ADD PRIMARY KEY (primaryid, type)


    I persume there will be many of these "duplicate" errors. Some general advice how to handle these?
    What's brewing in Poland? Find out on www.Browar.biz (in Polish)
    PL: Modyfikacje vB: www.pub.net.pl

  • #2
    This query should expose all duplicated records:

    Code:
    SELECT 
      `primaryid`, COUNT(`primaryid`)>1, 
      `type`, COUNT(`type`) > 1
    FROM
      `vb_moderation`
    GROUP BY
      `primaryid`,
      `type`
    HAVING
      (COUNT(`primaryid`) > 1) AND
      (COUNT(`type`) > 1)
    They should be deleted from the database. Then you can rerun the upgrade script and it will pick up where it left off.

    You can find more information on finding duplicate rows here: https://www.mysqltutorial.org/mysql-...licate-values/
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud demonstration site.
    vBulletin 5 API

    Comment


    • #3
      Hi Wayne, I remember You helping me out with some issues many years back, so it is nice to see You again helping me out with this too.

      After deleting the duplicates, all other stuff went unexpectedly smooth via the CLI. Nice work!

      Next thing I wanted to check how the testsite looks like after upgrade and am getting this PHP error:


      [Sat Aug 08 10:51:02 2020] [proxy_fcgi:error] [pid 24571:tid 139771917625088] [client ________4] AH01071: Got error 'PHP message: PHP Parse error: syntax error, unexpected '?' in /chroot/________/html/forum/includes/vb5/frontend/applicationlight.php on line 245\n'



      PHP Version 7.3.21

      Mentioned file seems to be ok.
      What's brewing in Poland? Find out on www.Browar.biz (in Polish)
      PL: Modyfikacje vB: www.pub.net.pl

      Comment


      • #4
        Oh shoot, false alarm, I did have an older PHP version assigned.
        What's brewing in Poland? Find out on www.Browar.biz (in Polish)
        PL: Modyfikacje vB: www.pub.net.pl

        Comment


        • #5
          Assigned the right php version for my site and it worked.

          Ok, another problem.

          As the style templates were heavily modified, the upgrade process turned some of the templates unusable and I cannot login to the admincp.

          How to make the site force using an unmodified default vb style without logging into the admincp ?
          What's brewing in Poland? Find out on www.Browar.biz (in Polish)
          PL: Modyfikacje vB: www.pub.net.pl

          Comment


          • #6
            Had to use tools.php to rebuild styles and reset the forum url (this was a little odd since I did change this url in the database vb_settings earlier and couldnt find nowhere else it could be located... are these stored in some sort of a cache now?)

            ok, I can now enjoy the standard style with no addons and can log in to the admincp. Now the real fun begins with rebuilding the site's lost capabilities.
            Last edited by Turtullo; Sat 8 Aug '20, 8:10am.
            What's brewing in Poland? Find out on www.Browar.biz (in Polish)
            PL: Modyfikacje vB: www.pub.net.pl

            Comment


            • #7
              Sorry for putting here any sort of different questions, I am using this thread as a kind of an upgrader's sketchbook so I don't forget anything that I have to deal with. I will look for answers by myself of course, but if You know how to solve some issues posted here - it would be nice to help me out with solutions


              The avatars - any hints why avatars (filesystem stored) appear in the admincp but not on the forums?
              What's brewing in Poland? Find out on www.Browar.biz (in Polish)
              PL: Modyfikacje vB: www.pub.net.pl

              Comment


              • #8
                I couldnt find the sitebuiler tools. The toggle button is only visible when the right admin userid is placed in the config.php file. Mine was =2 so I had to change from the default "1"
                What's brewing in Poland? Find out on www.Browar.biz (in Polish)
                PL: Modyfikacje vB: www.pub.net.pl

                Comment


                • #9
                  Originally posted by Turtullo View Post
                  I couldnt find the sitebuiler tools. The toggle button is only visible when the right admin userid is placed in the config.php file. Mine was =2 so I had to change from the default "1"
                  Make sure that you edit any relevant Admins permissions via:

                  AdminCP > Usergroups > Administrator Permissions

                  ...and set 'Can Use Sitebuilder' to Yes to allow other Admin accounts to use this.
                  Vote for:

                  - *Admin Settable Paid Subscription Reminder Timeframe*
                  -
                  *PM - Add ability to reply to originator only*
                  - Add Admin ability to auto-subscribe users to specific channel(s)
                  - "Quick Route" Interface...

                  Comment


                  • #10
                    Yes! Obviously the better way. Thanks!
                    What's brewing in Poland? Find out on www.Browar.biz (in Polish)
                    PL: Modyfikacje vB: www.pub.net.pl

                    Comment


                    • #11
                      Sorry that I post my issues all over the board

                      After the upgrade my problems are with:

                      attachments (stored in filesystem)
                      avatars
                      signatures
                      smilies

                      1) Some attachments in the threads are showing ok, but some are having a link when clicked report Invalid File Specified
                      2) when i go to the profile of a user who uploaded photos/attachments - i go to the media tab and see a thumbnail with last uploaded photo and attachments count. But when I click on it - there are no photos
                      3) the avatars show up in admincp when accessing a user profile, but these are not displaying on the forums/postbits or anywhere on the forum pages
                      4) the users' signatures don't show up on the postbits
                      5) the smilies don't show in the posts

                      Any suggestions would be appreciated.
                      Attached Files
                      What's brewing in Poland? Find out on www.Browar.biz (in Polish)
                      PL: Modyfikacje vB: www.pub.net.pl

                      Comment


                      • #12
                        Do you store attachments in the file system? Did you retain those files from 3.6.X when you deleted the content of the vBulletin directory?

                        Is this attachment directory broken up by digits (directories 0-0 with sub directories of 0-9) with attachments in individual directories. For example if the user is userid 868, then his attachments would be in %attachmentdirectory%/8/6/8. If his userid was 86 they would be in %attachmentdirectory%/8/6.

                        If so, reupload the files to your server into the directory specified under Attachments -> Attachment Storage Type.
                        Translations provided by Google.

                        Wayne Luke
                        The Rabid Badger - a vBulletin Cloud demonstration site.
                        vBulletin 5 API

                        Comment


                        • Turtullo
                          Turtullo commented
                          Editing a comment
                          All answers - YES. I will reupload and check. Thanks!

                      • #13
                        Originally posted by Turtullo View Post
                        3) the avatars show up in admincp when accessing a user profile, but these are not displaying on the forums/postbits or anywhere on the forum pages
                        Any suggestions with this one, please?
                        What's brewing in Poland? Find out on www.Browar.biz (in Polish)
                        PL: Modyfikacje vB: www.pub.net.pl

                        Comment


                        • #14
                          The avatar URL is incorrect for one location and not the other. What do you have entered there and what is the path of the custom avatar directory in relation to the public_html directory?
                          Translations provided by Google.

                          Wayne Luke
                          The Rabid Badger - a vBulletin Cloud demonstration site.
                          vBulletin 5 API

                          Comment


                          • #15
                            I will get back to this, thanks.

                            Now I thought I have the upgrade process trained quite well and wanted to update my live site (turned off to visitors of course). Unfortunately I am getting errors, which I did not get earlier. The upgrader stalls right at the beginning:


                            Upgrading to 3.7.0 Beta 2
                            ----------------------------------
                            Step 2 - Creating vb_userchangelog table

                            ----------------------------------
                            Can't create table `xxxxxxx`.`vb_userchangelog` (errno: 168 "Unknown (generic) error from engine")
                            ----------------------------------
                            CREATE TABLE vb_userchangelog (
                            changeid INT UNSIGNED NOT NULL AUTO_INCREMENT,
                            userid INT UNSIGNED NOT NULL DEFAULT '0',
                            fieldname VARCHAR(250) NOT NULL DEFAULT '',
                            newvalue VARCHAR(250) NOT NULL DEFAULT '',
                            oldvalue VARCHAR(250) NOT NULL DEFAULT '',
                            adminid INT UNSIGNED NOT NULL DEFAULT '0',
                            change_time INT UNSIGNED NOT NULL DEFAULT '0',
                            change_uniq VARCHAR(32) NOT NULL DEFAULT '',
                            PRIMARY KEY (changeid),
                            KEY userid (userid,change_time),
                            KEY change_time (change_time),
                            KEY change_uniq (change_uniq),
                            KEY fieldname (fieldname,change_time),
                            KEY adminid (adminid,change_time)
                            )

                            It seems like it skipped upgrade steps between 3.6.8 to 3.7.0 (why?)
                            I have tried to create this table via phpmyadmin and I get same error. when I try to create a random other table - it gets created with no errors...

                            I am using same vbulletin version files as earlier, just some data in the tables has more rows.

                            Do You have any thoughts?
                            What's brewing in Poland? Find out on www.Browar.biz (in Polish)
                            PL: Modyfikacje vB: www.pub.net.pl

                            Comment

                            Related Topics

                            Collapse

                            Working...
                            X