Announcement

Collapse
No announcement yet.

Register has wrong url after upgrade to 5.6.0

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Register has wrong url after upgrade to 5.6.0

    The register-link is going to https://www.zoopet.com/forum/register/register?urlpath=[ARG:2%20UNDEFINED] after upgrade.

    You can see it at https://www.zoopet.com/forum

    Click image for larger version

Name:	Greenshot 2020-03-31 19.29.08.png
Views:	103
Size:	40.5 KB
ID:	4437783

  • #2
    This is most likely an issue with your custom translation and/or customized templates. Please compare your modifications to the new defaults in 5.6.0.
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud demonstration site.
    vBulletin 5 API - Full / Mobile
    Vote for your favorite feature requests and the bugs you want to see fixed.

    Comment


    • #3
      i dont have modifications and have this issue, too Wayne Luke can you give us some inputs to fix this?

      Comment


      • #4
        It is a language translation issue. What language are you using?

        The only side effect is that when someone registers, they will be redirected to the home page of your site afterwards.
        Last edited by Wayne Luke; Tue 31st Mar '20, 4:03pm.
        Translations provided by Google.

        Wayne Luke
        The Rabid Badger - a vBulletin Cloud demonstration site.
        vBulletin 5 API - Full / Mobile
        Vote for your favorite feature requests and the bugs you want to see fixed.

        Comment


        • #5
          I have no modifications. Swedish language.

          I they click on register they come to error page.

          Comment


          • #6
            The problem is from the extra register in the url, not the undefined variable.

            What are the contents of your "or_sign_up" phrase?
            Delete the translation for your language. You can do this by deleting the contents of the translation box so it is empty (not even a space) and saving the phrase.
            Does the link work after that? If so, re-translate it.

            The login form was completely refactored in 5.6.0. If you're not using a language file for 5.6.0, then you will experience problems based on the translations. Swedish is not a supported translation provided by us.
            Translations provided by Google.

            Wayne Luke
            The Rabid Badger - a vBulletin Cloud demonstration site.
            vBulletin 5 API - Full / Mobile
            Vote for your favorite feature requests and the bugs you want to see fixed.

            Comment


            • zekich
              zekich commented
              Editing a comment
              can you explain "If you're not using a language file for 5.6.0" ? we came from 5.x and updated to every version vbulleton released. do we need to update the language data outside of the release?

          • #7
            Worked great! Thank you!

            Comment


            • #8
              worked for me too. changed "or_sign_up" phrase like this (im using language Deutsch (Du))

              FROM:
              oder <a id="idLoginSignup" href="{1}/register?urlpath={2}" target="_top">Registrieren</a>

              TO:
              oder <a id="idLoginSignup" href="{1}" target="_top">Registrieren</a>

              Comment

              Related Topics

              Collapse

              Working...
              X