No announcement yet.

How to restore data from 3.8.11 to 5.4.4

  • Filter
  • Time
  • Show
Clear All
new posts

  • How to restore data from 3.8.11 to 5.4.4

    i was using v3.8.11 now install 5.4.4 but I need all post and all document how can I restore it on my new version help me.

  • #2
    Overwrite all the files in the forum directory making sure you rename the to config.php the do the the same in the core/includes/ then edit this
    $config['Database']['dbname'] = 'database name;
    $config['MasterServer']['servername'] = 'localhost';
    $config['MasterServer']['port'] = 3306; You may need to change this as your server port may be different although most web hosts use the default value which is 3306
    $config['MasterServer']['username'] = 'user name';
    $config['MasterServer']['password'] = 'database password';
    Then run the upgrade script core/install/upgrade.php




    • #3
      i tried but only admin panel like old and my other docoment like members post section not come please help me. but i want only my members post and thread backup only


      • #4
        What exactly have you done to this point? Did you run the install script or the upgrade script? Did you overwrite the existing database or create a new database? Do you have a database backup of the 3.8.11 database? You haven't given us enough information to know how to help you.


        • #5
          The only way to take content from 3.8.11 into 5.4.4 is to run a full upgrade.

          You cannot import vB3 data directly into an existing 5.4.4 installation. It has to be done by upgrading.

          TalkNewsUK - My vBulletin 5.6.4 Demo
          AdminAmmo - My Cloud Demo


          • #6
            i tried to upgrade 3.8.11 to 5.4.4 but in 99% i face one error massage.

            Unexpected Text:

            <head><title>405 Not Allowed</title></head>
            <body bgcolor="white">
            <center><h1>405 Not Allowed</h1></center>

            Script: final
            Step: 15

            (Reply Posted via Ticket System)


            • #7
              405 Not Allowed - this is a server error. You should speak to your host in the first instance. Most likely they are blocking something that the upgrade script needs to run.
              MARK.B | vBULLETIN SUPPORT

              TalkNewsUK - My vBulletin 5.6.4 Demo
              AdminAmmo - My Cloud Demo


              • #8
                no there is no error hosting told me i tried again now its fix but one more problem when i click in forum logo and home page not showing why? its url issue can u help me how can i fix it?

                one more problem admincp not open its showing database error.

                Database error
                The Gsmsociety Forum database has encountered a problem.

                Please try the following:
                • Load the page again by clicking the Refresh button in your web browser.
                Last edited by mehedimw; Tue 2 Oct '18, 6:12am.


                • #9
                  The database error would have been emailed to the technical email specified in the /core/includes/config.php file. We need to see the entire error to know how to fix it.

                  The first thing to do is make sure that you didn't upload the vBulletin 5 files over the vBulletin 3 files. The /admincp directory should be empty in vBulletin 5. It is only there as a placeholder.
                  Translations provided by Google.

                  Wayne Luke
                  The Rabid Badger - a vBulletin Cloud demonstration site.
                  vBulletin 5 API


                  widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.