Announcement

Collapse
No announcement yet.

Forum Permissions Problem. Posts displayed to public when not permitted!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Forum Permissions Problem. Posts displayed to public when not permitted!

    I reported this to the ticket system on September 5 and as I have still not received any solution to this, I thought it would be a good idea to ask the community.

    I want to have the titles of some forums visible to the public, yet all posts are for members only and should not be visible to non-members. This was working fine on vb3, but is acting strangely after my upgrade to vb5. This issue is preventing me reopening my forum.

    I am doing this with forum permissions. I have been testing this on a specific category as follows.
    Permissions for each forum:
    Use Custom Permissions
    - Can View Channels = Yes
    - Follow Mod Rules = Yes
    - All others = No

    Although each Forum has the same permissions, they react differently. What is wanted is for the list of forums to be visible, but if you click on one of them, no posts are shown, from the point of view of someone who is not logged in.

    These forums are visible, without the Last Post infos being displayed on the right when NOT logged in = As wanted.
    - New Members
    - History
    - Microscopes
    - Frequencies
    - Pad, Plasma, etc.
    - Events
    - Technical Forum
    - Real Research
    - Other Topics
    - German Forum

    Then you click on each forum while NOT logged in, a few posts are displayed. None should be visible:
    - New Members = 8 out of 575 topics displayed = Bad
    - History = 0/57 topics displayed = Good
    - Microscopes = 3/92 topics displayed = Bad
    - Frequencies = 7/507 topics displayed = Bad
    - Pad, Plasma, etc. 1/121 topic displayed = Bad
    - Events = 0/38 topics displayed = Good
    - Technical Forum = 2/567 topics displayed = Bad
    - Real Research = 0/24 topics displayed = Good
    - Other Topics = 5/227 topics displayed = Bad
    - German Forum = 0/18 topics displayed = Good, despite "Can View Topic Content" set to Yes.

    All forums should be empty when viewed, yet a few posts are showing in most of them. I have no idea why.
    I have reindexed the counters under maintainance, etc.
    Made no difference.

    If I set "Can View Channels" to No, they are are no longer visible, but then that forum is no longer listed on the main page.

    Why are a few posts displayed, and the rest not? It should either be all or nothing.

    This affects other forums in other categories as well. This section is an example.

    The first level support looked at it and agreed it was strange I gave them a copy of the database to pass on to the programmers to test.

    I has also installed the vbDonate mod on the forum and was also having problems with that. Normal members were unable to see the donate buttons, yet they were visible to administrators.

    I asked Fillip Hannisdal to help with the problem with the vbDonate Mod. This is what he reported back to me:

    "I've determined the issues most likely stem from the fact that user group permissions haven't been set. However, when I attempt to set them, they do not save. Rebuilding bitfields doesn't fix the issue, which is the most common fix for this problem.

    I can't wait to find out what vB5 has changed this time...

    I'm still investigating, I'll let you know when I have more information."

    As both issues appear to be related to faulty permissions settings, the two problems could be related, ie. have a similar cause.

    To date, no solution has been found and I still cannot reopen my forum (with 13000 members bugging me for it to reopen).


    Has anyone got any ideas. I have not heard anything else from the support team, so far.
    Regards

    Peter Walker
    http://www.rifeforum.com

  • #2
    In the database run the following queries:
    Code:
    delete from datastore where title="vBUgChannelAccessG1";
    truncate table cache;
    truncate table cacheevent;
    Reload the front page of your site. When making changes to the permissions, do they update properly now?
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud customization and demonstration site.
    vBulletin 5 Documentation - Updated every Friday. Report issues here.
    vBulletin 5 API - Full / Mobile
    I am not currently available for vB Messenger Chats.

    Comment


    • #3
      I ran those queries on a test database and the effect was that now no forums are displayed to those not logged in. Not even the forums that are set to publically display.
      I then changed the Home settings to allow display of other peoples posts and then all the forums were displayed again to not logged in members.
      I reapplied the settings under channel permissions and it went back to how it was before. In forums set to not display topics, they are still displaying some topics,

      Additionally, the membership list is now showing publically, although they should only be visible to members. In vb3, there was a setting under Usergroup Options: "Viewable on the Memberlist" which is no longer there.

      How can I prevent non-members from seeing the membership list. My members very much want to preserve their privacy and do not want their names appearing on a public list. How do I prevent this?
      Last edited by Peter Walker; Wed 20th Sep '17, 6:15am.
      Regards

      Peter Walker
      http://www.rifeforum.com

      Comment


      • #4
        After running the queries did you reload the forum page as a registered user? It should rebuild the datastore. If not, then you need to edit the usergroup for a channel in Channel Permissions and save the page to force the rebuild.

        In Site Builder, you can edit the Navigation Bar and change the permissions for the Member's List link.
        Last edited by Wayne Luke; Wed 20th Sep '17, 3:01pm.
        Translations provided by Google.

        Wayne Luke
        The Rabid Badger - a vBulletin Cloud customization and demonstration site.
        vBulletin 5 Documentation - Updated every Friday. Report issues here.
        vBulletin 5 API - Full / Mobile
        I am not currently available for vB Messenger Chats.

        Comment


        • #5
          I have carefully done all the steps you suggested. After running the SQL commands, i checked that the section of the datastore had been removed and the cache entries had been emptied. That worked perfectly.

          I logged in as a registered user and reloaded the page. That did not regenerate "vBUgChannelAccessG1" or anything else I did as a registered user.

          I logged in as admin to admincp and then proceeded to change the Channel Permissions for a forum. This did regenerate "vBUgChannelAccessG1"

          I then proceeded to perform the test of looking at forums that deny access to unregistered users as an unregistered user.
          the problem has not been solved, I can still see a few entries in multiple forums as before.
          This procedure has not made any difference.
          I continue to need support to resolve these issues - my forum has been offline for over a month due to these problems and I urgently need assistance to fix this.

          The problems with vbDonate, that are permission related, have also not been resolved.

          The fix you suggested has failed.
          Regards

          Peter Walker
          http://www.rifeforum.com

          Comment


          • #6
            The issue has been reported as a bug. I am guessing through a duplicate ticket you have on the issue. We will need to wait and see what the developers say. Here is the bug ticket:
            http://tracker.vbulletin.com/browse/VBV-17675

            We can offer no support or advice on vBDonate.
            Translations provided by Google.

            Wayne Luke
            The Rabid Badger - a vBulletin Cloud customization and demonstration site.
            vBulletin 5 Documentation - Updated every Friday. Report issues here.
            vBulletin 5 API - Full / Mobile
            I am not currently available for vB Messenger Chats.

            Comment


            • #7
              It says it affects versions 5.3.2, yet I have upgraded to 5.3.3 and the problem is still there.

              This waiting is affecting me badly as I cannot reopen my forum with this issue standing. My business is folding due to this and I need to find a solution urgently. The only thing I can do is reopen the old vb3 forum which worked, fine.
              Regards

              Peter Walker
              http://www.rifeforum.com

              Comment


              • #8
                Originally posted by Peter Walker View Post
                It says it affects versions 5.3.2, yet I have upgraded to 5.3.3 and the problem is still there.

                This waiting is affecting me badly as I cannot reopen my forum with this issue standing. My business is folding due to this and I need to find a solution urgently. The only thing I can do is reopen the old vb3 forum which worked, fine.
                I'm afraid there is no magic wand for complex issues like this.

                The developers will need to investigate this and prove they can replicate the issue, then work on a fix. This also has to be prioritised in amongst other work - everything else cannot just be dropped.
                Even if that's all done, any fix will then go into the next available release, currently 5.3.4. Though if a fix is produced, we would ask if a patch could be made available for you.
                To be realistic: If you're expecting something within a day or so, I'm afraid that isn't likely to happen.
                MARK.B | vBULLETIN SUPPORT

                TalkNewsUK - My vBulletin 5.5.4 Demo
                AdminAmmo - My Cloud Demo

                Comment


                • #9
                  Originally posted by Peter Walker View Post
                  It says it affects versions 5.3.2, yet I have upgraded to 5.3.3 and the problem is still there.

                  This waiting is affecting me badly as I cannot reopen my forum with this issue standing. My business is folding due to this and I need to find a solution urgently. The only thing I can do is reopen the old vb3 forum which worked, fine.
                  The fix versions is more important on when it will be resolved. The affects version only tells the developers what version it was first reported against.
                  Translations provided by Google.

                  Wayne Luke
                  The Rabid Badger - a vBulletin Cloud customization and demonstration site.
                  vBulletin 5 Documentation - Updated every Friday. Report issues here.
                  vBulletin 5 API - Full / Mobile
                  I am not currently available for vB Messenger Chats.

                  Comment


                  • #10
                    Can confirm same behaviour with 5.4.2. Apache server hosted on Ubuntu 16

                    Comment

                    Related Topics

                    Collapse

                    Working...
                    X