Announcement

Collapse
No announcement yet.

After upgrade from VB 3.8.99 to 5.3.2 PL1, Attachments do not work.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • After upgrade from VB 3.8.99 to 5.3.2 PL1, Attachments do not work.

    I thought it would be a good idea to upgrade my perfectly working VB 3.8.9 forum to VB 5.3.2 Connect.

    I followed the instructions and went through all the upgrade steps until I got to 5.3.2 and was told all is OK. After deleting the install directory, I went to AdminCP and wanted to start configuring and testing everything.

    The first thing that happened is that the forum started emailing on my members a blank email. I had to remove the SMTP username to stop that.

    After reverting all the templates registered as incompatible, I decided to check the attachments. None of them work.

    I posted a detailed support ticket about this several days ago, but so far no reaction. So I am posting here in the hope someone can help.
    The url myforum.com in this example is invented, it is not the real url. I gave the correct urls in the support ticket.

    The Problem

    Attachments are not being downloaded from my forum. All that happens is that "I" is displayed.

    Attachments are stored in the file system at this location:
    /var/www/vhosts/myforum.com/httpdocs/tmp/attach
    The files are located there and I have set file permissions to 777 in order to make sure there are no file permissions issues.

    For example:
    File: abc.pdf
    In AdminCP, you can see it listed under Attachments/Search/View Most Popular Attachments

    The link for the file is https://www.myforum.com/attachment.p...4&d=1230922210

    View Content: https://www.myforum.com/forum/admincp/https://www.myforum.com/forum/filedata/fetch?filedataid=543

    Clicking on that link gives you:
    Debug: Error
    Invalid Page URL. If this is an error and the page should exist, please contact the system administrator and tell them how you got this message.
    occurred in file /var/www/vhosts/myforum.com/httpdocs/forum/includes/vb5/frontend/routing.php on line 246
    Trace
    Function setRoutes in file /var/www/vhosts/myforum.com/httpdocs/forum/includes/vb5/frontend/application.php line 21
    Function init in file /var/www/vhosts/myforum.com/httpdocs/forum/index.php line 48

    The View Content Link is obviously wrong, so I tried .
    [ATTACH]n543[/ATTACH] which returns: "I" on the screen.

    In the database, when I look at my_attachment
    my_attachment:
    attachmentid: 543
    contenttypeid: 1
    userid: 7
    filedataid: 543
    state: visible
    counter: 3

    The file is physically located at:
    /var/www/vhosts/myforum.com/httpdocs/tmp/attach/7/543.attach

    So the file is there, it appears to be listed correctly in the database, but it is not possible to download it, just like all other attachments.

    Attachments are currently being stored in the filesystem at /var/www/vhosts/myforum.com/httpdocs/tmp/attach and I have checked that the files are really there.

    My previous vb 3.8.9 is still running and I checked the same attachments there - everything working perfectly.

    So something killed the attachment system in the upgrade.

    I even created a parallel upgrade in another directory and database and after the successful upgrade, I had exactly the same problem.

    Now it gets interesting:

    I then went to the actual forum and was able to upload and download a file from a test post. Other attachments also appear and can be downloaded.
    But the same attachments cannot be found or downloaded from the admincp. I can search for filenames and they are not listed. It is as if the entire search system for attachments in admincp is broken.
    When I compare the actual links, they are very different for the same file.
    From admincp.
    [ATTACH]n543[/ATTACH] this does NOT work.

    Looking at the link given in the actual forum, the correct link for the same file has to be:
    https://www.myforum.com/forum/filedata/fetch?id=63594 and that WORKS!

    In the database file my_attach. nodeid 63594 is filedataid 543!

    This means that the attachment system in the admincp is buggy, referencing the wrong number.

    Can others here confirm the same problems in their forums?


    In summary:
    The attachment files are in the correct folders and are not damaged in any way. No permission problems.
    The correct directory is named under Attachment Storage Type.
    The entries in the database give the correct location for the files.
    In admincp, it is not possible to search for filenames, random files are shown instead.
    In Attachment Type Manager, the links for the filename and View Content are broken.

    As far as I can see: THIS IS A MAJOR BUG!
    Last edited by Peter Walker; Sun 17th Sep '17, 3:08pm.
    Regards

    Peter Walker
    http://www.rifeforum.com

  • #2
    The AdminCP Attachment manager has some bugs currently and is being worked on. Do the attachments work on the front end? If so, you can delete them by editing the post and deleting the attachment.
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud demonstration site.
    vBulletin 5 API - Full / Mobile
    Vote for your favorite feature requests and the bugs you want to see fixed.

    Comment

    Related Topics

    Collapse

    Working...
    X