Announcement

Collapse
No announcement yet.

Upgrade Fail

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    Hi Wayne
    I will try that as soon as the search index re-build has finished. Currently it is on 76000, not sure if that is the number of posts processed or what to be honest.
    I have worked out how to add blocks to the right hand side of every page and have added the forums advertisers search boxes there so if the header ad module doesn't work it won't be a disaster but I would rather see no errors before upgrading the live forum

    Thanks again for your help, it is much appreciated.
    Regards
    Trevor

    Comment


    • #32
      When I have created a static html box and added it to a page it is a real shame that when I go to add it to a different part of the foum that it isn't available as a drag and drop option and I have to create it again. I assume there is no way to add a static html box to the right on every page automatically? They seem to use different templates so I guess not.
      Regards
      Trevor

      Comment


      • #33
        You may be able to do this using template hook system. That's one of the ways to create plugins for vB5.

        GIPHY for vB5 AutoLinker Auto-Create Flag Report Topic Social Icons in Postbit Clear Cache Cron DragDrop Upload Topic AJAX AutoUpdate Custom Avatars Selector Stop Links in Posts...and more!

        Comment


        • #34
          Hi Glenn
          I suspect that is way beyond my limited abilities
          I just realised that there are loads of themes members can choose from, everyone would need editing.
          I would like to limit members to the default vb5 theme, do I have to delete all the others to stop them being available to members?
          Regards
          Trevor

          Comment


          • #35
            I had a great feature on my vb4 forum called Log In As User.
            It was very handy when a member thought they had a problem and I just logged in as them to check for them.
            Is that a feature that vb5 has by any chance?
            Regards
            Trevor

            Comment


            • #36
              Originally posted by Trevor Matthews View Post
              When I have created a static html box and added it to a page it is a real shame that when I go to add it to a different part of the foum that it isn't available as a drag and drop option and I have to create it again. I assume there is no way to add a static html box to the right on every page automatically? They seem to use different templates so I guess not.
              Custom Modules proved to be very problematic and were disabled early on. We would like to bring them back at some time.
              Translations provided by Google.

              Wayne Luke
              The Rabid Badger - a vBulletin Cloud demonstration site.
              vBulletin 5 API - Full / Mobile
              Vote for your favorite feature requests and the bugs you want to see fixed.

              Comment


              • #37
                OK, I understand.
                System cache has been cleared but the problem remains.
                Regards
                Trevor

                Comment


                • #38
                  I also just noticed that I have the same error if I try to click on edit after adding an Ad Module to any page.
                  Regards
                  Trevor

                  Comment


                  • #39
                    Upload tools.php from your do_not_upload folder to /core/admincp. Load it in your browser and run the tool to rebuild the routes.

                    Translations provided by Google.

                    Wayne Luke
                    The Rabid Badger - a vBulletin Cloud demonstration site.
                    vBulletin 5 API - Full / Mobile
                    Vote for your favorite feature requests and the bugs you want to see fixed.

                    Comment


                    • #40
                      Thanks Wayne
                      I will try that later.

                      I have yet another problem.
                      When I run the repair/optimize tables I get eventually get a 504 Gateway Timeout error.
                      This works perfectly on my vb4 forum on the same server.

                      Any suggestion for that one please?
                      Regards
                      Trevor

                      Comment


                      • #41
                        I have run the tools.php.
                        I used the option called Routes.
                        I ran it a number of times but nothing has changed.
                        I still get the same error when clicking on edit in the header ad module.
                        Regards
                        Trevor

                        Comment


                        • #42
                          Why are you running repair/optimize on your database? Those functions aren't necessary for day to day operations and will do nothing to improve general performance of the software.
                          Translations provided by Google.

                          Wayne Luke
                          The Rabid Badger - a vBulletin Cloud demonstration site.
                          vBulletin 5 API - Full / Mobile
                          Vote for your favorite feature requests and the bugs you want to see fixed.

                          Comment


                          • #43
                            Hi Wayne
                            Every Sunday, I clear the logs, repair/optimize the database and then backup the database and the files to a remote location.
                            If the repair/optimize part is not required then great, that will save a few minutes every week.
                            When should that option be used then? Not that I can now of course.
                            I already tried increasing the time-out value in the php.ini file.
                            Regards
                            Trevor

                            Comment


                            • #44
                              Originally posted by Trevor Matthews View Post
                              When should that option be used then? Not that I can now of course.
                              You should use Repair when you get a database error stating "XYZ Table is marked as Crashed, Run Repair". Though, you should convert all your tables to INNODB for better performance. Repair doesn't do anything for INNODB Tables.

                              Optimize should only be run when you delete large parts of your database. It will free up the deleted content so you can recover drive space. It never needs to be run otherwise.

                              I already tried increasing the time-out value in the php.ini file.
                              A 504 error would be triggered by the Web Server. It should have information in its logs on what caused the time out. Most likely, the queries took too long and the connection to MySQL was closed. We recommend a wait time of at least 120 seconds but the default value of 86440 seconds would be better.

                              Translations provided by Google.

                              Wayne Luke
                              The Rabid Badger - a vBulletin Cloud demonstration site.
                              vBulletin 5 API - Full / Mobile
                              Vote for your favorite feature requests and the bugs you want to see fixed.

                              Comment


                              • #45
                                Once again, I thank you for your help Wayne.
                                Regards
                                Trevor

                                Comment

                                Related Topics

                                Collapse

                                Working...
                                X