Announcement

Collapse
No announcement yet.

PHP Fatal error: Call to undefined function imagecreatetruecolor()

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • PHP Fatal error: Call to undefined function imagecreatetruecolor()

    My forum was running OK first thing this morning but shortly after I logged in to the Control Panel the forum died (without me changing any settings). The error message in the log files are as follows:
    [Wed Nov 16 08:47:07 2016] [error] [client 62.24.181.135] PHP Fatal error: Call to undefined function imagecreatetruecolor() in /var/zpanel/hostdata/zadmin/public_html/forum_pearldentalclinic_co_uk/core/vb/image/gd.php on line 498, referer: http://forum.pearldentalclinic.co.uk/core/image.php

    [Wed Nov 16 08:47:10 2016] [error] [client 111.118.241.77] PHP Notice: Undefined index: birthday_search in /var/zpanel/hostdata/zadmin/public_html/forum_pearldentalclinic_co_uk/core/vb/api/user.php on line 210

    [Wed Nov 16 08:47:10 2016] [error] [client 111.118.241.77] PHP Notice: Undefined index: joindate in /var/zpanel/hostdata/zadmin/public_html/forum_pearldentalclinic_co_uk/core/vb/api/user.php on line 231

    [Wed Nov 16 08:47:10 2016] [error] [client 111.118.241.77] PHP Notice: Undefined index: posts in /var/zpanel/hostdata/zadmin/public_html/forum_pearldentalclinic_co_uk/core/vb/api/user.php on line 232


    There are several more of the same "undefined index" errors that I haven't bothered to list.

    Can you suggest a cause & solution?

    Thanks, Adam

  • #2
    Are you running 5.2.4 or did you upgrade to 5.2.5?
    Vote for:

    - *Admin Settable Paid Subscription Reminder Timeframe*
    -
    *PM - Add ability to reply to originator only*
    - Add Admin ability to auto-subscribe users to specific channel(s)
    - "Quick Route" Interface...

    Comment


    • #3
      I am running 5.2.4.

      I have resolved one of the problems - that related to "PHP Fatal error: Call to undefined function imagecreatetruecolor()". I got the hosting company to initialise the "GD" services on the server.

      However, the other problems still recur, crashing the forum. It looks like whenever I log in to the Control Panel it triggers the errors like this "PHP Notice: Undefined index: ".

      Update: I have discovered that it only crashes the forum on my browser. Could this be related to cookies? If I use Chrome to access the Control Panel it causes the forum to fail when I try using Chrome to view it, but it's still OK if I view it using Firefox.
      Last edited by baobabit; Wed 16 Nov '16, 9:21am.

      Comment


      • #4
        So when you access the forum, what do you actually see when you're getting that error?
        Vote for:

        - *Admin Settable Paid Subscription Reminder Timeframe*
        -
        *PM - Add ability to reply to originator only*
        - Add Admin ability to auto-subscribe users to specific channel(s)
        - "Quick Route" Interface...

        Comment


        • #5
          The error message is as follows:

          A System Error has occured.

          The software is experiencing a systems error.

          You should attempt to repeat your last action. If this error occurs again, please contact the
          site administrator.


          I can replicate the issue as follows:
          1. Open a browser and successful view the forum
          2. Open another tab on the browser (or a new window) and access the Forum's control panel
          3. Go back to the first window/tab and hit refresh - the forum crashes and displays that error message
          4. If I close the window for the Control Panel the forum still doesn't work - but will recover in a few hours
          5. If the Control Panel and the Forum are opened with different browsers (e.g. Firefox & Chrome) the problem doesn't occur

          Comment


          • #6
            Strange that different browsers seems to get round this...

            Are the cookie prefix values the same in both config files?
            Vote for:

            - *Admin Settable Paid Subscription Reminder Timeframe*
            -
            *PM - Add ability to reply to originator only*
            - Add Admin ability to auto-subscribe users to specific channel(s)
            - "Quick Route" Interface...

            Comment


            • #7
              I can see the Cookie Prefix set to "BB" in config.php (in the root folder) which I am guessing is for the general forum pages.

              Where will I find the other config file (presumably for the Control Panel pages)?

              Comment


              • #8
                The other file is core/includes/config.php
                Vote for:

                - *Admin Settable Paid Subscription Reminder Timeframe*
                -
                *PM - Add ability to reply to originator only*
                - Add Admin ability to auto-subscribe users to specific channel(s)
                - "Quick Route" Interface...

                Comment


                • #9
                  OK, they have the same prefix - so I'm guessing I need to change one of them. Is that correct? Is it a simple case of changing the CP cookie prefix to something like "bbcp"?

                  Whilst on the subject, I noticed differences between the two settings so can you also confirm this is OK.

                  Here is the generic cookie setting:
                  $config['cookie_prefix'] = 'bb';

                  and this is the Control Panel:
                  $config['Misc']['cookieprefix'] = 'bb';

                  The first has an underscore in the middle whereas the second does not and also makes reference to ['Misc'] (whatever that's for!)

                  Thanks, Adam

                  Comment


                  • #10
                    Both cookie prefix values need to be the same. The variables are done like that, one with an underscore and one without, there are reasons for that I believe, but the actual values need to be the same.
                    MARK.B | vBULLETIN SUPPORT

                    TalkNewsUK - My vBulletin 5.6.3 Demo
                    AdminAmmo - My Cloud Demo

                    Comment


                    • #11
                      Ah, OK. Seeing as they're the same that's clearly not the problem. Any other suggestions?

                      Comment

                      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                      Working...
                      X