Announcement

Collapse
No announcement yet.

Error Duplicate entry, while reach to Upgrading to 5.2.1 Alpha 2

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error Duplicate entry, while reach to Upgrading to 5.2.1 Alpha 2

    Hi,

    I was doing a long way upgrade from 3.8.7 to 5.2.3 , through the command line as the database size almost 13GB (4M posts)

    However, I reached to step 16 in Upgrading to 5.2.1 Alpha 2.. and couldn't find answer to this error.


    Code:
    Upgrading to 5.2.1 Alpha 2
    ----------------------------------
    Step 16 - Error Duplicate entry '24-0' for key 'userid' on /home/inshad/public_html/forum/core/vb/db/query/stored.php : 124
    #0: vB_Utilities::getStackTrace() called in /[path]/core/install/includes/class_upgrade_cli.php on line 294
    #1: vB_Upgrade_Cli->execute_step(16, vB_Upgrade_521a2) called in /[path]/core/install/includes/class_upgrade_cli.php on line 223
    #2: vB_Upgrade_Cli->process_script('521a2', '0') called in /[path]/core/install/includes/class_upgrade_cli.php on line 129
    #3: vB_Upgrade_Cli->init(NULL) called in /[path]/core/install/includes/class_upgrade.php on line 711
    #4: vB_Upgrade_Abstract->__construct(vB_Registry, array[len:10], 'upgrade', NULL, array[len:0]) called in /[path]/core/install/includes/class_upgrade_cli.php on line 83
    #5: vB_Upgrade_Cli->__construct(vB_Registry, array[len:10], 'upgrade', NULL, array[len:0]) called in /[path]/core/install/includes/class_upgrade.php on line 54
    #6: vB_Upgrade::fetch_library(vB_Registry, array[len:10], '', true) called in /[path]/core/install/upgrade.php on line 132
    Please let me know if further information is required to provide the necessary assistance.

  • #2
    Just try refreshing and see if it carries on
    MARK.B | vBULLETIN SUPPORT

    TalkNewsUK - My vBulletin 5.5.4 Demo
    AdminAmmo - My Cloud Demo

    Comment


    • #3
      I'm doing it through command line .. how shall I refresh ?

      Comment


      • #4
        Exit the process and run it again...it will attempt to carry on where it left off. (That's basically all refreshing does if you were on the web interface).
        MARK.B | vBULLETIN SUPPORT

        TalkNewsUK - My vBulletin 5.5.4 Demo
        AdminAmmo - My Cloud Demo

        Comment


        • #5
          1. I did exit the process and started again.
          2. I restart mysql and apache service
          3. I reboot the server


          and with no Luck.

          Comment


          • #6
            also I'm trying to doing it through the web interface but getting :

            Code:
             
            Startup Errors
               Due to the following errors, the install/upgrade can not continue:
             
            The 'clientscript/vbulletin_css' (OR wherever you set as css file location) directory and/or its sub directories is/are not writable. Please make sure that this directory and its sub directories are writable by your web server.
            I confirm the folder permission is 777

            Comment


            • #7
              It needs to be 777 recurring, not just the folder itself.
              MARK.B | vBULLETIN SUPPORT

              TalkNewsUK - My vBulletin 5.5.4 Demo
              AdminAmmo - My Cloud Demo

              Comment


              • #8
                Both are confirmed ..

                What is the next step for me ?

                Comment


                • #9
                  Best to raise a support ticket referencing this thread. Not much more we can suggest without having full access to your server.

                  We will need admincp and FTP access.
                  MARK.B | vBULLETIN SUPPORT

                  TalkNewsUK - My vBulletin 5.5.4 Demo
                  AdminAmmo - My Cloud Demo

                  Comment


                  • #10
                    Ticketid: 1521903 is already there.

                    Comment


                    • #11
                      While access AdminCP, I'm getting the following MSG

                      ---------------------------

                      security_alert_x_still_exists


                      ---------------------------
                      Last edited by Inshad; Sun 28th Aug '16, 12:46pm.

                      Comment


                      • #12
                        I tried to do the upgrade through web interface and I got :

                        HTML Code:
                          Fatal Error Occurred
                         Duplicate entry '24-0' for key 'userid' on /home/inshad/public_html/forum/core/vb/db/query/stored.php : 124
                        
                        Script: 521a2
                        Step: 16
                        Please, the forum is down for almost 4 days! and I need any sort of help.

                        Ticket id: 1521903 is already opened for the same and all access information has been provided.

                        Comment

                        Related Topics

                        Collapse

                        Working...
                        X