Announcement

Collapse
No announcement yet.

403 Errors

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 403 Errors

    Two different licenses, two different URLs, two different hosts, both vBulletin 5.2.1 installations on new databases with empty public_html folders CHMOD 750.

    Installation appears to go fine until it completes, then upon clicking the "Go To AdminCP" button, 403 forbidden errors. "You don't have permission to access /admincp/"

    The hell I don't.

    What is wrong with the install package?

  • #2
    Hello,

    403 Forbidden errors are a way of telling “You have requested for a resource but we cannot give it to you.”
    403 Forbidden is technically not an error but a HTTP status code. 403 response headers are intentionally returned in many cases such as:

    * User is blocked from requesting that page/resource or the site as a whole.
    * User tries to access a directory but autoindex is set to off.
    * User tries to access a file that can be only accessed internally.

    Kind regards,
    George.

    Comment


    • #3
      All of the above is true and correct, however, the previous version of vBulletin 5 installed on both servers without issue.

      Therefore, the problem has to be something in the default software installation of version 5.2.1 specifically.

      Comment


      • #4
        No one has any clue as to why 5.2.0 installs perfectly but 5.2.1 causes 403 errors?

        Comment


        • #5
          I'd like to create a JIRA entry for this but I've only been able to narrow it down so far. It's either the mcrypt causing the issue (neither site having an issue has libsodium or /dev/urandom or openssl) or the PHP or MySQL versions. The PHP version in use is 5.5.31 and the MySQL version is 5.5.45. This is a Linux server in both cases. I know version 5.6 is recommended in both PHP and MySQL cases but both of these servers exceed the PHP 5.4.45 and MySQL 5.1.5 requirements. I have two different sites that can't upgrade to version 5.2.1 and having to revert both to 5.2.0PL2 was a big pain in the ass so I'd appreciate it if the next upgrade attempt worked.

          Comment


          • #6
            Just out of curiosity I decided to try upgrading from version 5.2.0PL2 instead of doing a clean install of version 5.2.1.

            It worked perfectly.

            Something is wrong with the 5.2.1 install package.

            Comment


            • #7
              ProSportsForums that is a little strange I'll have to say ... I just got my forum up and running the other week on a fresh clean install of version 5.2.1 and it works like a champ for me

              Comment


              • #8
                Please fill out a support ticket at:

                http://members.vbulletin.com/members...ontactform.php

                Please include a complete description of the problem and be sure to include the login info to your Admin CP, phpMyAdmin and FTP in the 'Sensitive Data' field.
                Vote for:

                - *Admin Settable Paid Subscription Reminder Timeframe*
                -
                *PM - Add ability to reply to originator only*
                - Add Admin ability to auto-subscribe users to specific channel(s)
                - Highlight the correct navigation tab when you are on a custom page
                - "Quick Route" Interface...
                - Allow to use custom icons for individual forums

                Comment


                • #9
                  Originally posted by Trevor Hannant View Post
                  Please fill out a support ticket at:

                  http://members.vbulletin.com/members...ontactform.php

                  Please include a complete description of the problem and be sure to include the login info to your Admin CP, phpMyAdmin and FTP in the 'Sensitive Data' field.
                  I would but I was able to get around the problem by installing 5.2.0PL2 and then upgrading to 5.2.1 so wasting the time of support is unnecessary.

                  Comment

                  widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                  Working...
                  X