Announcement

Collapse
No announcement yet.

5.1.4 PL 6 installed, now homepage of forum is blank

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 5.1.4 PL 6 installed, now homepage of forum is blank

    Hello,

    We were running 5.1.4 PL3 and just updated to PL6.
    Upgrade went fine, forums work - BUT the home page is blank.
    You can access the forum from a previous email link or by adding /forum/ on the end of the base URL, but the home page is blank and we cannot figure out why.
    All we did was install the update.

    The normal background is visible, but nothing else. Its not white.

    I have raised a support ticket, can we please get urgent support
    Ticketid: 1451528

    Regards
    James
    I am Running VB5 5.5.2 Release

  • #2
    How did you apply the patch? Did you copy the files from the patch and overwrite the existing files? When you log in to AdminCP, do you see 5.1.4 PL6 in the header?

    GIPHY for vB5 AutoLinker Auto-Create Flag Report Topic Social Icons in Postbit Clear Cache Cron DragDrop Upload Topic AJAX AutoUpdate Custom Avatars Selector Stop Links in Posts...and more!

    Comment


    • #3
      Correct.

      Copy the files over to the FTP.
      Run the upgrade.php script
      delete the install folder
      CP shows 5.1.4 PL6

      Everything works apart from the home page, from what I can tell
      James
      I am Running VB5 5.5.2 Release

      Comment


      • #4
        What is even more weird,

        is I updated our development server the same way, and had the same results. I then deleted the whole file structure from the development server, and downloaded the 5.1.4 PL6 full download from the members area, and extracted the upload folders contents. I then put in the details on the config.php file in the /core/includes folder.
        Tried to go to the upgrade.php script, and I get a Server Error 500
        Same for any other page I attempt to go to.

        Is there something wrong with this release?
        Is there something wrong with what I am doing?
        2 major issues with the same version. one upgrade, one new install.

        Regards
        James
        I am Running VB5 5.5.2 Release

        Comment


        • #5
          OK so on the Dev Forum I see this in the error log

          [13-Nov-2015 19:17:59 CST6CDT] PHP Parse error: syntax error, unexpected T_USE, expecting T_FUNCTION in /home/USERNAME/public_html/devforum/core/vb/api.php on line 16

          So 5.1.4 PL6 requires PHP 5.4.0+ then, which is NOT what it says in the members area.
          What the hell.
          James
          I am Running VB5 5.5.2 Release

          Comment


          • #6
            Host installed PHP 5.5.29 alongside our current PHP, and have set the forums to use it.
            Devforum is now fully working after a fresh install.
            main forum after the upgrade however, is not, still blank first page.
            Both control panels are indicating the new PHP version is in effect.

            I have copied over the PL6 files again to the main forum, but still nothing.
            I cannot find anything wrong.

            Did that upgrade script I ran possibly cause a problem.
            Some things I read suggest to run the script, others dont. Some say you just delete the install folder. It was there so I assumed it was designed to be run.

            ​What do I do?
            James
            I am Running VB5 5.5.2 Release

            Comment


            • #7
              Have solved the blank home page. Seems to be the update didnt copy over a required file or something. I ended up updating the whole /core/ folder with files from the full download of 5.1.4 PL6 and that seemed to solve that bit. Something seems wrong with this version or something.

              However now I have another issue in the Channel Permissions, see photo:

              Click image for larger version

Name:	2015-11-14_16-27-43.png
Views:	15
Size:	137.4 KB
ID:	4333005

              Not sure what is going on here. I have tried changing permissions, but anything custom that is not from a parent, does this error.
              Even some that are set as from parents have this error.

              Anyone have any idea ?

              Regards
              James
              I am Running VB5 5.5.2 Release

              Comment


              • #8
                Have solved the blank home page. Seems to be the update didnt copy over a required file or something. I ended up updating the whole /core/ folder with files from the full download of 5.1.4 PL6 and that seemed to solve that bit. Something seems wrong with this version or something.

                However now I have another issue in the Channel Permissions, see photo:

                Click image for larger version

Name:	2015-11-14_16-27-43.png
Views:	16
Size:	137.4 KB
ID:	4333008

                Not sure what is going on here. I have tried changing permissions, but anything custom that is not from a parent, does this error.
                Even some that are set as from parents have this error.

                Anyone have any idea ?

                Regards
                Attached Files
                James
                I am Running VB5 5.5.2 Release

                Comment


                • #9
                  Maybe you had an .htaccess file that was replaced or changed.
                  Try also to upload the full package of 5.1.4 PL6 and replace everything.
                  Usually with the latest released version (5.1.9) works as supposed to.
                  Cu Respect / Best Regards / Mit freundlichen Grüßen

                  roStyles Design LLC
                  CEO & Founder (Design and Support)
                  Romanian Translator
                  Teascu Dorin
                  [email protected]
                  https://www.rostyles.com

                  Comment


                  • #10
                    The htaccess files are correct, checked those already.

                    I will try replacing all the files with the full 5.1.4 PL6 if I cant get this sorted out. Still waiting for Support to have a look.

                    I upgraded the development server to 5.1.9 and that seems to be going OK so far.
                    Might just do a full upgrade from 5.1.4 to 5.1.9 if I cant get this sorted, and see if that solves anything. But that is a one way street really.

                    Regards
                    James
                    I am Running VB5 5.5.2 Release

                    Comment


                    • #11
                      Should really just do the full upgrade to 5.1.9 PL1.

                      We can't really provide much support for previous versions, as more often than not the issues people run into are fixed in later versions.
                      MARK.B | vBULLETIN SUPPORT

                      TalkNewsUK - My vBulletin 5.6.2 Demo
                      AdminAmmo - My Cloud Demo

                      Comment


                      • #12
                        Right.
                        Just hope whatever this issue is, is solved by doing the upgrade.

                        In the members area, it states that MariaDB is required for 5.1.8, doesnt have any notes for 5.1.9 though. But on our dev server, I left the database as sqli and it seems to be functioning.
                        What is the requirement of MariaDB and why is the member area conflicting about this, and also about what version of PHP is required? This really screwed us up. Luckily PHP seems to be sorted now.
                        James
                        I am Running VB5 5.5.2 Release

                        Comment


                        • #13
                          anyone?
                          is MariaDB a requirement or just a recommendation? (read it wrong, I see it says it supports it, not is required)
                          is sqli still fine to use or are we going to encounter problems?
                          Is there some sort of doc to show how to upgrade from sqli to mariaDB?
                          I will have to get mariaDB installed on the server from the Host first, but does the DB itself need to be converted or will it just work?
                          James
                          I am Running VB5 5.5.2 Release

                          Comment


                          • #14
                            MariaDB is not a requirement, it's just that we can now support it if required.
                            MySQLi is absolutely fine to use.
                            MARK.B | vBULLETIN SUPPORT

                            TalkNewsUK - My vBulletin 5.6.2 Demo
                            AdminAmmo - My Cloud Demo

                            Comment


                            • #15
                              Great thanks
                              James
                              I am Running VB5 5.5.2 Release

                              Comment

                              Related Topics

                              Collapse

                              Working...
                              X