Announcement

Collapse
No announcement yet.

Issue. 5.1.4 -> 5.1.7 (same PHP required BUT....)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Issue. 5.1.4 -> 5.1.7 (same PHP required BUT....)

    Hello

    Based on the members area, it states this:

    vBulletin 5.1.0 - 5.1.6 requires PHP 5.3.7 or greater, MySQL 5.1.5 or greater, and cURL to be installed.
    (Facebook features require PHP 5.4.0 or greater.)

    vBulletin 5.1.7 requires PHP 5.4.0 or greater, MySQL 5.1.5 or greater, and cURL to be installed.
    We are currently running 5.1.4, but want to upgrade to the latest version we can.
    Our server is running 5.3.26 PHP, and is the latest we can run at the moment due to other things on the server.
    I just updated our development forum to 5.1.6 PL3 as that is the latest that should apparently run with our PHP version, however as soon as I copied the files over to the ftp and attempted to run the upgrade.php, I get a 500 server error.

    These are in the error log:

    Code:
    [13-Nov-2015 14:35:36 CST6CDT] PHP Parse error:  syntax error, unexpected T_USE, expecting T_FUNCTION in /home/USERNAME/public_html/devforum/core/vb/database.php on line 24
    [13-Nov-2015 14:44:52 CST6CDT] PHP Parse error:  syntax error, unexpected T_USE, expecting T_FUNCTION in /home/USERNAME/public_html/devforum/core/vb/db/result.php on line 22
    [13-Nov-2015 14:45:56 CST6CDT] PHP Parse error:  syntax error, unexpected T_USE, expecting T_FUNCTION in /home/USERNAME/public_html/devforum/core/vb/library.php on line 21
    [13-Nov-2015 14:47:15 CST6CDT] PHP Parse error:  syntax error, unexpected T_USE, expecting T_FUNCTION in /home/USERNAME/public_html/devforum/core/vb/phrase.php on line 29
    Is that related to PHP version?
    And if so, why does it state that 5.3.7 is only required, and we are running 5.3.26 so it should be fine, right?

    Please help

    Regards
    James
    I am Running VB5 5.5.2 Release

  • #2
    Traits is a feature of PHP 5.4

    Comment


    • #3
      Hmm so I wonder why the members page states that 5.1.6 can be run under PHP 5.3.7 then.
      James
      I am Running VB5 5.5.2 Release

      Comment


      • #4
        5.1.0 through 5.1.6 were a transition period. You're best off with PHP 5.4.0. You can run multiple versions of PHP on the same server. Use an .htaccess handler to specify PHP 5.4.0+ for your vBulletin directory. In reality, people should be looking to upgrade to PHP 5.6 for stability and performance enhancements.

        Please note that we will not support anything less than PHP 5.4.0 for current versions of vBulletin 5. Even PHP 5.4.0 has reached the end of its life from the PHP Group.
        Translations provided by Google.

        Wayne Luke
        The Rabid Badger - a vBulletin Cloud demonstration site.
        vBulletin 5 API - Full / Mobile
        Vote for your favorite feature requests and the bugs you want to see fixed.

        Comment


        • #5
          Ok thanks Wayne

          We have no admin here, so doing my best to learn this on the fly.

          so if we get the server upgraded to PHP 5.6 as you say, and have a .htaccess file to specifiy the current version for our current systems (non forum things) be run, that should be OK you think?
          The vBulletin should run 5.6 no problem, and our other systems will continue to run 5.3.26 ?

          Regards
          James
          I am Running VB5 5.5.2 Release

          Comment


          • #6
            OK I have confirmed with our host what you have said, so from their end we are good to upgrade the PHP too.

            Going from 5.1.4 to the latest 5.1.9, I can only see the requirements up to 5.1.8 stated on the members area.
            What is this change in the DB?

            vBulletin 5.1.0 - 5.1.6 requires PHP 5.3.7 or greater, MySQL 5.1.5 or greater, and cURL to be installed.
            (Facebook features require PHP 5.4.0 or greater.)

            vBulletin 5.1.7 requires PHP 5.4.0 or greater, MySQL 5.1.5 or greater, and cURL to be installed.

            vBulletin 5.1.8 supports MariaDB 5.1.5 onwards.
            MariaDB ?

            Is there anything else over and above PHP version that is required to go from 5.1.4 to 5.1.9 ?

            Regards
            James
            I am Running VB5 5.5.2 Release

            Comment


            • #7
              MariaDB is an open source drop-in replacement for MySQL. If you already have MySQL, you do not need MariaDB.
              Translations provided by Google.

              Wayne Luke
              The Rabid Badger - a vBulletin Cloud demonstration site.
              vBulletin 5 API - Full / Mobile
              Vote for your favorite feature requests and the bugs you want to see fixed.

              Comment

              Related Topics

              Collapse

              Working...
              X