Announcement

Collapse
No announcement yet.

Redirection error on page update.php after clean install

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Redirection error on page update.php after clean install

    Hello vBulletin team and forum members,

    I have followed the steps of how to upgrade vBulletin 5 Connect, but when I try to access the page upgrade.php, I get a redirection error:

    The page isn't redirecting properly
    The address in my browser becomes: http://mypage/vb5/core/install/core/...tall/index.php ("mypage" is naturally an alias, once the address I use only works locally in my machine)




    More information about what I have done (the step 7 shows the error):
    1. I have built a virtual machine using vagrant;
    2. I have installed vBulletin 4.2.2 inside of this virtual machine and successfully migrated data;
    3. I have removed the files from vBulletin 4.2.2;
    4. I have copied the test file from vBulletin 5 to my vagrant and tested the environment (my environment passed in all tests);
    5. I have removed the test file;
    6. I have copied and edited vBulletin 5.1.8's files as describbed here: How to Upgrade to vBulletin 5 Connect;
    7. Then I get the redirection error when I try to access http://mypage/forums/upgrade.php or http://mypage/vb5/core/install/upgrade.php.




    Notes:

    Note 1: one of the steps of how to upgrade vBulletin 5 Connec" (step "5.X specific steps number 1") tells me to rename the file "/vb5/config.php.bkp" to "config.php". From this point, I get the redirection error. If I do not rename this file, I get a blank page.

    Note 2: inside of the file "config.php" (mentioned by me in the Note 1), there is the following line
    PHP Code:
    $config['core_path'] = realpath(dirname(__FILE__)) . '/core'
    . If I comment this line, the redirection error disappears, but I get a blank page. The result of "realpath(dirname(__FILE__))" inside of my vagrant machine is "/vagrant/vb5" (all project files are copied to "/vagrant/"). Could this be the problem?

    Note 3: the page http://mypage/install/install.php works.

    Note 4: if I try to access http://mypage/install/update.php, I am redirected to http://mypage/install/install.php works.

    Note 5: unlike this case about wrong permissions, the files "/vb5/config.php" and "/vb5/core/install/upgrade.php" have permission "wxrwxrwxr".
    Last edited by ndoktoruser; Wed 26th Aug '15, 6:48am.

  • #2
    I still have the same redirection problem with the version 5.1.9.
    I tried with Firefox 40.0.2, Chrome 44 and IE 9, but no success.

    Just for test purpose, I created a new virtual machine with no previous VB 4, however, the VB 5 update page has the same redirection problem.

    Any idea?
    Last edited by ndoktoruser; Thu 27th Aug '15, 5:40am.

    Comment


    • #3
      The redirection you're talking about occurs when the install directory does not exist and vBulletin cannot connect to the database specified in /core/includes/config.php. As per the instructions after installing, this directory should be deleted. To access it again, you would need to reupload the directory and its contents.

      When upgrading you should not need to change any config.php files. We name them the way we do so we don't overwrite your preconfigured. They only need to be changed when you first install vBulletin 5. You do not need to make any edits within /config.php. The only file you should need to edit is /core/includes/config.php. If you followed install directions and renamed these files then you overwrote the files already configured. You will need to edit the database values in /core/includes/config.php to use the upgrade system.
      Translations provided by Google.

      Wayne Luke
      The Rabid Badger - a vBulletin Cloud demonstration site.
      vBulletin 5 API - Full / Mobile
      Vote for your favorite feature requests and the bugs you want to see fixed.

      Comment


      • #4
        Reupload the install/ directory?
        Do you means install/ directory from vBulletin 4.2.2? Because I removed the whole vb4/ folder after I successfully migrated the data from my old forum tool.

        After that (removal of vB 4.2.2), I copied the folder vb5/ (vB 5.1.9) and tried to upgrade (getting the redirection error).
        I did not perform an installation of vB 5.1.9. So, before updating vB 4.2.2 to vB 5.1.9, should I install vB 5.1.9 and then upgrade it to vB 5.1.9?

        I imagined that my workflow (to migrate PHP Phorum to vBulletin 5) should be the following:
        1) install vBulletin 4;
        2) migrate the data from Phorum to vBulletin 4 (using impex);
        3) remove all files from vBulletin 4;
        4) copy vBulletin 5;
        5) use the vBulletin 5 upgrade page. (here I can't upgrade)

        Should I include "install vBulletin 5" as 5th step?
        Last edited by ndoktoruser; Fri 28th Aug '15, 6:22am.

        Comment


        • #5
          (I guess) I finally found the solution for my problem.

          What I wanted to do: upgrade from vBulletin 4.2.2 to vBulletin 5.1.9.
          What I was doing wrong: I removed all files of vBulletin 4.2.2 and copied vBulletin 5.1.9 to the server (because the documentation said "It is important to install vBulletin 5 into a clean directory. Do not attempt to overwrite your 4.X", but it seems to be wrong).
          How did I fix it: I copied all files from the folder "upload" of vBulletin 5.1.9 and pasted into the folder containing vBulletin 4.2.2 (in the server), so I could successfully access the upgrade page. After I upgraded vBulletin, I removed all source files (it was a mix of vBulletin 4.2.2 and 5.1.9) and replaced them with the content of the folder "upload" for vBulletin 5.1.9. Now I have the DB upgraded and the sources for vBulletin 5.1.9.

          Note: the upgrade process changed some data in the database (maybe they are changes from vB 4 to vB 5). For example: the table user doesn't contain the fields "password" and "salt" anymore, it contains "secret" (it seems the new version of salt) and "token" (it seems it concatenates the password and secret).

          Note 2: I noticed that many links changed between vB 4 and vB 5.

          Note 3: as I didn't follow the documentation, I will test the forum for a while to make sure that everything works as expected.
          Last edited by ndoktoruser; Tue 1st Sep '15, 2:49am.

          Comment


          • #6
            Your solution isn't a solution. In fact it will fundamentally break vBulletin 5's operations. You cannot have vBulletin 4.X files in the directory at all.

            And yes, there are many changes to the database. So many in fact that you can't go back to vBulletin 4.X or use vBulletin 4.X files without causing routing and database errors.
            Translations provided by Google.

            Wayne Luke
            The Rabid Badger - a vBulletin Cloud demonstration site.
            vBulletin 5 API - Full / Mobile
            Vote for your favorite feature requests and the bugs you want to see fixed.

            Comment


            • #7
              For some reason, I had problems when I copied the source files and edited the conf files.
              This time, I copied the content of the upload folder, removed the install.php and let the system create both conf files. After they were created, I edited (only the /core/includes/config.php) and could upgrade the system to 5.1.9.
              Thanks for the help!

              Comment


              • #8
                Sounds like you had a UTF8 BOM character in one or more files. This can break PHP processing. I am glad you have it working though.
                Translations provided by Google.

                Wayne Luke
                The Rabid Badger - a vBulletin Cloud demonstration site.
                vBulletin 5 API - Full / Mobile
                Vote for your favorite feature requests and the bugs you want to see fixed.

                Comment

                Related Topics

                Collapse

                Working...
                X