Announcement

Collapse
No announcement yet.

vb 4.2.2 to vb5.1.5 error occurred during upgrade

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • vb 4.2.2 to vb5.1.5 error occurred during upgrade

    vb 4.2.2 to vb5.1.5 error occurred during upgrade;

    Code:
     
    Action Required
    Unexpected Text: <?xml version="1.0" encoding="UTF-8"?> <upgrade> </upgrade> <fatal_error> <description><![CDATA[Duplicate route data: blogs/\?\?\?\?\?(?:/page(?P<pagenum>[0-9]+))? occurred in /home/xxxx/domains/xxxx/public_html/core/vb5/route.php in line 660]]></description> </fatal_error>
    How to solve this problem?
    [ATTACH=CONFIG]temp_64550_1413220742153_785[/ATTACH]

  • #2
    The above error, dozens refresh upgrade was successful, but the problem is more serious garbled

    Click image for larger version

Name:	1.png
Views:	7
Size:	563.1 KB
ID:	4292172

    How to solve this problem?
    [ATTACH=CONFIG]temp_64550_1413220742153_785[/ATTACH]

    Comment


    • #3
      In the language settings, what is the HTML Character Set set to?
      MARK.B | vBULLETIN SUPPORT

      TalkNewsUK - My vBulletin 5.5.6 Demo
      AdminAmmo - My Cloud Demo

      Comment


      • #4
        Thank you for your reply, this issue is resolved
        [ATTACH=CONFIG]temp_64550_1413220742153_785[/ATTACH]

        Comment


        • #5
          How did you solve the problem?

          Comment


          • #6
            1. Back up the database before upgrading (Uighur utf8 language originally deleted this time did not delete)
            2.Before upgrading core / install / includes / class_upgrade.php this file is opened, Find the following code
            Code:
            $this->db->query_write("CREATE DATABASE " . $vb5_config['Database']['dbname']);
            Replace the following code;
            Code:
            $this->db->query_write("CREATE DATABASE " . $vb5_config['Database']['dbname']." DEFAULT CHARACTER SET utf8 COLLATE utf8_general_ci");
            When upgrading the newly added database coding can be maintained utf8
            This upgrade has become
            [ATTACH=CONFIG]temp_64550_1413220742153_785[/ATTACH]

            Comment


            • anwar513
              anwar513 commented
              Editing a comment
              Reminder: My database is utf8_general_ci

          Related Topics

          Collapse

          Working...
          X