Announcement

Collapse
No announcement yet.

vBulletin vs Apache permissions + Addon Domain / CPanel = wtf?!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    Well, i got the install to finally go through:

    http://jfkrew.com/

    Now, any link you click results in an error message.

    What's this?

    I followed every single install step and verified each and still have problems with a default install.

    Comment


    • #32
      Looks like either the forum url, or the config.php files are setup incorrectly.

      Due to how long we've been working with you on this, i'm going to escalate this specific issue into the ticket system for you, to try to get it resolved properly.

      I'll need your AdminCP login info, and an ftp/ssh login.

      Comment


      • #33
        http://jfkrew.com


        what's with the errors for every link you click?

        Comment


        • #34
          Forbidden

          You don't have permission to access / on this server.

          That's a hosting issue I'm afraid - your host will need to address this.
          Vote for:

          - *Admin Settable Paid Subscription Reminder Timeframe*
          -
          *PM - Add ability to reply to originator only*
          - Add Admin ability to auto-subscribe users to specific channel(s)
          - "Quick Route" Interface...

          Comment


          • #35
            Originally posted by zzSQL View Post
            Only see the access logs looking for install.php

            71.236.XX.XXX - - [31/Jan/2013:13:00:04 -0800] "GET /core/install/install.php HTTP/1.1" 403 - "-" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0"
            71.236.XX.XXX - - [31/Jan/2013:13:00:06 -0800] "GET /core/install/install.php HTTP/1.1" 403 - "-" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0"
            403 is forbidden. You should ask your hosting provider why this isn't working.
            Translations provided by Google.

            Wayne Luke
            The Rabid Badger - a vBulletin Cloud demonstration site.
            vBulletin 5 API

            Comment


            • #36
              Ok,
              I changed to a new hoster (aSmallOrange.com)

              To the letter I followed these instructions:

              https://www.vbulletin.com/forum/entr...etin-5-connect

              FTP-ed all the files to the domain.com/forum dir

              Went to the isntall.php location: http://www.domain.com/forum/core/install/install.php

              Now, i get this awesome error:

              Parse error: syntax error, unexpected T_STRING in /home/jfkrewco/public_html/forum/core/includes/config.php on line 71

              Line 71 show no errors to my inexperienced eye:

              $config['MasterServer']['usepconnect'] = 0;


              This is the default /core/includes/config.php except for the changes mentioned in the site above.



              now what?
              Should this be so problematic?

              This is the 3rd web hoster I've tried but at least the .htaccess stopped breaking things
              Last edited by zzSQL; Thu 7 Feb '13, 7:19pm.

              Comment


              • #37
                Please use a recommended editor to avoid issues with the formatting and display of the file. PHP files are standard ASCII/ANSI plain text files and should not be saved as UTF-8 with BOM.

                Check if config.php not saved as UTF-8 with BOM and if it has an extra character on its begin

                Former vBulletin Support Staff
                Need Help?, Or P.M. Me

                Comment


                • #38
                  I'm already using notepad++


                  This has really been an unbelievable experience.

                  >: [
                  Last edited by zzSQL; Fri 8 Feb '13, 4:08am.

                  Comment


                  • #39
                    Fine, what about the previous lines??

                    Former vBulletin Support Staff
                    Need Help?, Or P.M. Me

                    Comment


                    • #40
                      Even though you're using Notepadd++, make sure it's set to save that file in ANSI format, not UTF-8 via the 'Encoding' dropdown.
                      Vote for:

                      - *Admin Settable Paid Subscription Reminder Timeframe*
                      -
                      *PM - Add ability to reply to originator only*
                      - Add Admin ability to auto-subscribe users to specific channel(s)
                      - "Quick Route" Interface...

                      Comment


                      • #41
                        Hosted at http://asmallorange.com/ at the recommendation of one of your support guys.
                        They support these features:

                        PHP 5.3.18
                        MySQL - 5.1.66
                        Apache - 2.2.23
                        Python 2.6.6
                        Perl - 5.10.1


                        Here are all the steps recommended in the VBulletin install guide I followed:
                        https://www.vbulletin.com/forum/entr...etin-5-connect

                        1. Downloaded and Unzipped vb5_connect_5-0-0_Beta_26_LICENSE#.zip

                        Using Notepad++ in default ANSI mode:

                        2. Renamed /config.php.bkp to config.php.

                        3. Edited it like this:
                        Changed:
                        $config['baseurl'] = 'http://www.yourdomain.com/folder';
                        To:
                        $config['baseurl'] = 'http://www.mydomain.com/forum';

                        4. In /upload/core/includes/config.php.new renamed to config.php, edited as such:

                        Changed
                        :
                        $config['Database']['dbname'] = 'forum';
                        To:
                        $config['Database']['dbname'] = 'domain_dbName';

                        Changed:
                        $config['Database']['technicalemail'] = '[email protected]';
                        To:
                        $config['Database']['technicalemail'] = '[email protected]';

                        Changed:
                        $config['MasterServer']['username'] = 'root';
                        $config['MasterServer']['password'] = '';
                        To:
                        $config['MasterServer']['username'] = 'user_sqlDB';
                        $config['MasterServer']['password'] = 'ComplexPass;

                        Changed:
                        $config['Misc']['forumpath'] = '';
                        To:
                        $config['Misc']['forumpath'] = '/forum';

                        5. FTP-ed all in the /upload directory to my web hoster into the /forum directory (Default in ASCII mode)

                        6. Went to http://www.mydomain.com/forum/core/install/install.php

                        7. Entered Customer Number and hit enter.

                        8. Parse error: syntax error, unexpected T_STRING in /home/jfkrewco/public_html/forum/core/includes/config.php on line 71

                        If it had worked:
                        98. Delete install.php and makeconfig.php files from core/install directory.
                        Last edited by zzSQL; Fri 8 Feb '13, 5:35am. Reason: Removing license #

                        Comment


                        • #42
                          Originally posted by zzSQL View Post
                          Here are all the steps recommended in the VBulletin install guide I followed:

                          1. Downloaded and Unzipped vb5_connect_5-0-0_Beta_26_*****.zip

                          Following these instructions very carefully here using Notepad++ in default ANSI mode:

                          https://www.vbulletin.com/forum/entr...etin-5-connect

                          2. Renamed /config.php.bkp to config.php.

                          3. Edited it like this:
                          Changed:
                          $config['baseurl'] = 'http://www.yourdomain.com/folder';
                          To:
                          $config['baseurl'] = 'http://www.mydomain.com/forum';

                          4. In /upload/core/includes/config.php.new renamed to config.php, edited as such:

                          Changed
                          :
                          $config['Database']['dbname'] = 'forum';
                          to
                          $config['Database']['dbname'] = 'domain_dbName';

                          Changed:
                          $config['Database']['technicalemail'] = '[email protected]';
                          to:
                          $config['Database']['technicalemail'] = '[email protected]';

                          Changed:
                          $config['MasterServer']['username'] = 'root';
                          $config['MasterServer']['password'] = '';
                          to:
                          $config['MasterServer']['username'] = 'user_sqlDB';
                          $config['MasterServer']['password'] = 'ComplexPass;

                          Changed:
                          $config['Misc']['forumpath'] = '';
                          to:
                          $config['Misc']['forumpath'] = '/forum';

                          5. Went to http://www.mydomain.com/forum/core/install/install.php

                          6. Entered Customer Number and hit enter.

                          7. Parse error: syntax error, unexpected T_STRING in /home/jfkrewco/public_html/forum/core/includes/config.php on line 71

                          If it had worked:
                          8. Delete install.php and makeconfig.php files from core/install directory.


                          $config['MasterServer']['password'] = 'ComplexPass;

                          that line is wrong it must be $config['MasterServer']['password'] = 'ComplexPass'; you forget to add '

                          Former vBulletin Support Staff
                          Need Help?, Or P.M. Me

                          Comment


                          • #43
                            tried it one last time and it worked.

                            I thank you for your support and am just happy this finally worked!

                            VB5 looks really complex now that i'm finally in.

                            - - - Updated - - -
                            http://www.jfkrew.com

                            How does it look?
                            Awesome huh?

                            I simply went into cpanel to turn off directory indexing and BAM, site goes down with 500 error.

                            wow.

                            I turned off indexing and ... you guessed it. Site still down l0ol.
                            Last edited by zzSQL; Fri 8 Feb '13, 3:54pm.

                            Comment


                            • #44
                              Originally posted by zzSQL View Post
                              tried it one last time and it worked.

                              I thank you for your support and am just happy this finally worked!

                              VB5 looks really complex now that i'm finally in.

                              - - - Updated - - -
                              http://www.jfkrew.com

                              How does it look?
                              Awesome huh?

                              I simply went into cpanel to turn off directory indexing and BAM, site goes down with 500 error.

                              wow.

                              I turned off indexing and ... you guessed it. Site still down l0ol.
                              You're Welcome, And welcome to vB5 connect
                              Yes because that edit .htaccess file (re-upload the .htaccess file try again)

                              Former vBulletin Support Staff
                              Need Help?, Or P.M. Me

                              Comment


                              • #45
                                Unfortunately, if you make changes to your .htaccess in cPanel, it will overwrite existing contents.

                                Set your site indexing value in cPanel... Look at the .htaccess file on your site. Copy the content from it.

                                Open the default .htaccess, paste the contents from cPanel's file at the bottom. Save. Upload this file to your server. Keep a backup of it on your local machine for future edits.
                                Translations provided by Google.

                                Wayne Luke
                                The Rabid Badger - a vBulletin Cloud demonstration site.
                                vBulletin 5 API

                                Comment

                                Related Topics

                                Collapse

                                Working...
                                X