Announcement

Collapse
No announcement yet.

Couldn't read config file config.php

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • kopq
    replied
    I deleted all the files. Then I left the DB. I uploaded new files and I ran upgrade.php. Then I ran upgrade DB from the admincp. It worked fine. Thanks.

    Leave a comment:


  • Wayne Luke
    replied
    Reupload the files.
    Connect to a new empty database
    Run install.php (not upgrade.php).

    Get a base install. Does this work on your server or do you get the same errors?

    Leave a comment:


  • kopq
    replied
    I deleted all old vb4 files and folders and installed fresh new vb5 files.

    I did not upload install.php and I tried to use makeconfig.php and I received same errors as I mentioned above.

    Instead I edited config.php in the root with the info needed and I did the same with the one in the includes folder.

    Lastly I ran /core/upgrade.php and it finished. Still I can not get to admincp as I receive a 403 forbidden error and that I do not have permission.

    The site is loading but not loading the forum. Inside the loaded site there is this error:

    An internal error has occurred and the widget cannot be displayed.
    What I should do now?

    Leave a comment:


  • AusPhotography
    replied
    Use the 2nd method for vB5 !!

    while the second method involves deleting all the old files and directories, and then uploading the new scripts.

    Leave a comment:


  • kopq
    replied
    I did not have config.php on the root folder. I just looked at the backup.

    This is not my forum, I am fixing it for someone else. They have a lot of things screwed up. FOr example I found out they have another vb4 forum in a folder called forum beside the one on the web root.

    I found out the posts about config.php here and downloaded the makeconfig.php file. It launch but it can not create the files in the web root or includes. (I do have the .bkb and .new in the two folders). I receicved this error message:

    Warning: file_put_contents(config.php) [function.file-put-contents]: failed to open stream: Permission denied in /home/****/public_html/makeconfig.php on line 62

    Warning: file_put_contents(core/includes/config.php) [function.file-put-contents]: failed to open stream: Permission denied in /home/***/public_html/makeconfig.php on line 111


    Also I can not delete the makeconfog.php file by clicking on the link. Error:

    Warning: unlink(makeconfig.php) [function.unlink]: Permission denied in /home/****/public_html/makeconfig.php on line 121
    - - - Updated - - -

    My Friends,

    I just followed what is written in the tutorial here:

    http://www.vbulletin.com/docs/html/

    There are two ways to update the scripts on your server. The first method involves overwriting all the files that were previously uploaded to your web server, while the second method involves deleting all the old files and directories, and then uploading the new scripts. In this tutorial we will use the overwrite method.
    - - - Updated - - -

    I am deleting the entire web files in public_html (it is only a VB forum) and will FTP a clean files of VB5.

    Now, do I use installp.php or add the old config.php (I only had the includes folder one) or use the makeconfig.php to make them.

    The MySQL DB is still intact and I have access to it.

    Leave a comment:


  • Ace
    replied
    Originally posted by kopq View Post
    Yes I overwrite the files as the setup manual said. I only followed the steps listed on the site. So, it is not correct?
    The 'setup manual' being readme.html that comes with the download (because the Quick Start Guide is for a fresh install and doesn't mention any Upgrade instruction?)?

    Yes, it's correct:

    After downloading vBulletin 5 Connect from the your Member's Area.

    • Unzip the package
    • Create a new directory to hold vBulletin 5. It should not contain any vBulletin 3 or 4 files.
    (It's not that big in the readme, I did that for emphasis.)

    Leave a comment:


  • AusPhotography
    replied
    You need to to delete all vB4 php/xml files and have a clean vB5 site.

    You need to edit both vB5 config files; then do the upgrade.

    Leave a comment:


  • kopq
    replied
    Yes I overwrite the files as the setup manual said. I only followed the steps listed on the site. So, it is not correct?

    Leave a comment:


  • Ace
    replied
    Did you happen to upload the vB5 Connect files over the vB4 files?

    Either that, or your config files aren't correct. (You mention "the config.php file is in the includes folder". What about the one in root, the one that error is complaining it can't find. Is that one there?)

    Leave a comment:


  • kopq
    started a topic Couldn't read config file config.php

    Couldn't read config file config.php

    I upgraded to 5 beta 14 from 4.1.11 Alpha.

    After I logged in to the admincp, I can not see my old threads or posts there. The forum was disabled so I enabled it back.

    If I try to go to the forum itself, I receive error:

    Couldn't read config file config.php
    The config.php file is in the includes folder and chmod to 644. What is the problem with the upgraded forum?

Related Topics

Collapse

Working...
X