Announcement

Collapse
No announcement yet.

Upgrade Problems

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Upgrade Problems

    I have done the upgrade after installing into a clean directory. The upgrade seemed to go fine and I can see the site using the base URL. However if I click to try to login I see an error 404 in the dropdown instead of the login script. If I check the error_log it appears that I'm getting a failure because something thinks my base URL is in DocumentRoot/vb.

    My DocumentRoot points to /local/web/html. However I have set up an Alias to place my VB5 installation at /local/web/vb5. I do see the home page if I go to the expected URL and have checked the base_url in config.php.

    I also get a blank page if I try to access base_url/admincp.

    If I try to click on one of the links (i.e. Blogs) I get an error 404 and error_log reports File does not exist /local/web/vb5/blogs

    On a hunch I tried baseurl/core/admincp and was able to see a login screen but error_log is reporting File does not exist /local/web/html/vb referrer baseurl/core/admincp.

    Prior to the upgrade my vbulletin 4 installation was working.

    Any ideas?

  • #2
    Did you upload .htaccess (for apache2) or web.config (for IIS) as vbulletin 5 does not work without mod_rewrite?
    No private support, only PM me when I ask for it. Support in the forums only.

    Comment


    • #3
      Yes, assuming I got the correct .htaccess it is loaded.

      Here's the contents:

      <IfModule mod_rewrite.c>
      RewriteEngine On
      RewriteCond %{REQUEST_FILENAME} !-f
      RewriteCond %(REQUEST_FILENAME} !-d
      RewriteRule ^(admincp/)$ index.php?routestring=$1 [L,QSA]
      </IfModule>

      Comment


      • #4
        Looks almost correct. mod_rewrite is enabled properly in Apache?

        Use this .htaccess

        Code:
        <IfModule mod_rewrite.c>
        RewriteEngine On
        RewriteCond %{REQUEST_FILENAME} !-f
        RewriteCond %{REQUEST_FILENAME} !-d
        RewriteRule ^(.*)$ index.php?routestring=$1 [L,QSA]
        
        
        #needed because admincp is an actual directory.
        RewriteRule ^(admincp/)$ index.php?routestring=$1 [L,QSA]
        </IfModule>
        Translations provided by Google.

        Wayne Luke
        The Rabid Badger - a vBulletin Cloud demonstration site.
        vBulletin 5 API - Full / Mobile
        Vote for your favorite feature requests and the bugs you want to see fixed.

        Comment


        • #5
          Actually that is what my .htaccess looks like. I left off the last part.

          I tested the redirect by adding the following after making sure the AllowOverride All was specified in my httpd.conf file, even though I think I should be able to do this in the conf.d/vbulletin.conf file:


          Options +FollowSymLinks
          RewriteEngine On
          RewriteRule (.*) http://www.inprose.com

          I then saw a redirect to that site.

          Here's something that may be adding to the confusion: My vb5 directory is not located in my DocumentRoot.

          My Document root resides at /local/web/html and my VB5 installation resides at /local/web/vb5. I have the .htaccess located in /local/web/vb5 also. I'm thinking the redirect my be trying to resolve relative to DocumentRoot instead of my installation directory. Does this sound like the problem? If so, how should I reconstruct the .htaccess files to resolve correctly.

          I'm going to experiment with this a bit, but at least I have confirmed that mod_rewrite is trying to do its job.



          Note:
          I added the following and now I think it's working:

          RewriteBase /vb5/
          Last edited by BusaDave; Thu 25th Oct '12, 6:35pm. Reason: I think I have it.

          Comment

          Related Topics

          Collapse

          Working...
          X