Announcement

Collapse
No announcement yet.

4 Errors Upgrade vB 4.2.0 PL2 to vB 5.0.0 BETA 11

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 4 Errors Upgrade vB 4.2.0 PL2 to vB 5.0.0 BETA 11

    Server Conditions:
    Apache version 2.2.23
    PHP version 5.4.7
    MySQL version 5.1.65-community-log

    I'm testing the upgrade process using a backup of my current vB 4.2.0 PL2 database. Here are the 4 errors I receive when trying to upgrade. After each error, I restarted the upgrade process. It does upgrade but vB 5.0.0 BETA 11 has some function problems pulling data from the database. All from these errors though.

    vB 4.2.0 PL2 is heavy with mods, plugins disabled when I performed the backup and the forums were turned off to prep the database to for the vB 5.0.0 BETA 11 upgrade testing.

    Code:
    An error has occurred with your database. Please contact vBulletin Support for assistance.
    
    Module: 500a14, Step 25 Database Error:1064
    
    Query:
    
    UPDATE user
                SET options = options - 
                WHERE (options & )
    Code:
    An error has occurred with your database. Please contact vBulletin Support for assistance.
    
    Module: 500a23, Step 2 Database Error:1064
    
    Query:
    
    UPDATE setting SET
                value = value | 
                WHERE varname = 'defaultregoptions'
    Code:
    An error has occurred with your database. Please contact vBulletin Support for assistance.
    
    Module: 500a29, Step 14 Database Error:1064
    
    Query:
    
    UPDATE usergroup AS usergroup SET adminpermissions = adminpermissions |  WHERE usergroupid = 6;
    Code:
    An error has occurred with your database. Please contact vBulletin Support for assistance.
    
    Module: 500a29, Step 16 Database Error:1064
    
    Query:
    
    UPDATE channel c
                    INNER JOIN node n ON n.nodeid = c.nodeid
                    INNER JOIN forum f ON f.forumid = n.oldid AND oldcontenttypeid = 3
                    SET c.category = if(f.options & , 0, 1)
                    WHERE c.category = 0;
    Looks like I will have to do a fresh install then manually add the old members/posts/blogs and such. fun fun.
    Unless impex is updated during vB Connect Gold


    after upgrade, it directs me to my renamed "admincp" but displays a blank page.
    when i go to the home page and login, the admin and mod links still show "admincp" and "modcp" not the renamed directories...

    the "forum" displays "An internal error has occurred and the widget cannot be displayed."

    On a fresh install with a clean database, I am unable to login...
    Last edited by G.I.JOE*MFA*; Thu 4th Oct '12, 3:41am. Reason: added more info to assist

  • #2
    Originally posted by G.I.JOE*MFA* View Post
    after upgrade, it directs me to my renamed "admincp" but displays a blank page.
    when i go to the home page and login, the admin and mod links still show "admincp" and "modcp" not the renamed directories...

    the "forum" displays "An internal error has occurred and the widget cannot be displayed."

    On a fresh install with a clean database, I am unable to login...
    This could be caused when you have wrong URLs submitted in your frontend config.php or when the mod_rewrite files are wrong/missing.
    No private support, only PM me when I ask for it. Support in the forums only.

    Comment


    • #3
      The first database error is probably due to an addon. Please uninstall all third-party addons before upgrading.

      The second error is a known issue and a page refresh should fix that.

      The third error is that it can't find usergroupid 6. Did you delete this usergroup for some reason? If so, you'll need to log this into JIRA.

      The fourth error is also most likely and addon that needs to be uninstalled before upgrading.
      Translations provided by Google.

      Wayne Luke
      The Rabid Badger - a vBulletin Cloud demonstration site.
      vBulletin 5 API - Full / Mobile
      Vote for your favorite feature requests and the bugs you want to see fixed.

      Comment

      Related Topics

      Collapse

      Working...
      X