Announcement

Collapse
No announcement yet.

Error in install...

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error in install...

    Tried a fresh install of Beta11 today - all seemed to install ok, however after install i get the following...

    Fatal error: Class 'vB5_Config' not found in /var/sites/p/p*******.com/public_html/vb5/includes/vb5/applicationabstract.php on line 18

    So i started again and used Joe D's config maker, however i get the same error...

    For some reason it's not finding this class???

    Any pointers appreciated...

    Cheers
    Paul

  • #2
    Make sure your core_path is correct from the root of the server.
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud demonstration site.
    vBulletin 5 API - Full / Mobile
    Vote for your favorite feature requests and the bugs you want to see fixed.

    Comment


    • #3
      Originally posted by Wayne Luke View Post
      Make sure your core_path is correct from the root of the server.
      Wayne,

      core_path?

      The line from my config is as follows....

      $config['Misc']['forumpath'] = '/var/sites/p/p**********.com/public_html/vb5/core';

      Which points to my vb5/core directory correctly as a full path - there isnt a core_path variable in my config.php at all... not even mentioned.....

      I can follow the tree and the file applicationabstract.php does exist at this location, however from the error it was almost indicating that the class didnt exist...

      Cheers
      Paul

      Comment


      • #4
        That forumpath variable shouldn't be set unless vBulletin tells you to set it.

        In vBulletin 5, there are two config.php files. The line you posted is in the /core/includes/config.php file.

        The core_path value is defined in the /config.php file. That is where you need to look.
        Translations provided by Google.

        Wayne Luke
        The Rabid Badger - a vBulletin Cloud demonstration site.
        vBulletin 5 API - Full / Mobile
        Vote for your favorite feature requests and the bugs you want to see fixed.

        Comment


        • #5
          Wayne,

          Ok im getting files confused...

          In my core/includes/config.php i have :

          $config['Misc']['forumpath'] = '';

          In my /config.php i have :

          $config['core_path'] = '/var/sites/p/p********.com/public_html/vb5/core';

          I have checked and applicationabstract.php lives in /var/sites/p/p*******.com/public_html/vb5/includes/vb5/, however i'm guessing that it just needs files to the core and it finds it's way from there....

          As i said, it's not complaining that it cant find the file, it's just complaining that "Class 'vB5_Config" is called in that file and it cant find it....

          - - - Updated - - -

          ahh... ok.. the line in question is...

          Code:
          $config = vB5_Config::instance();
          So the question is - Where does it look for vB5_Config???

          Comment


          • #6
            The error you're receiving is caused by having the incorrect core_path in the /config.php file.

            Try using the config.php file in the first post here: https://www.vbulletin.com/forum/show...See-this-first

            All you need to set in it is the URL to your site.
            Translations provided by Google.

            Wayne Luke
            The Rabid Badger - a vBulletin Cloud demonstration site.
            vBulletin 5 API - Full / Mobile
            Vote for your favorite feature requests and the bugs you want to see fixed.

            Comment


            • #7
              Originally posted by Wayne Luke View Post
              The error you're receiving is caused by having the incorrect core_path in the /config.php file.

              Try using the config.php file in the first post here: https://www.vbulletin.com/forum/show...See-this-first

              All you need to set in it is the URL to your site.
              Wayne,

              Have done this - no change at all....still errors...

              Paul

              Comment


              • #8
                You'll need to open a support ticket then.
                Translations provided by Google.

                Wayne Luke
                The Rabid Badger - a vBulletin Cloud demonstration site.
                vBulletin 5 API - Full / Mobile
                Vote for your favorite feature requests and the bugs you want to see fixed.

                Comment


                • #9
                  Originally posted by Wayne Luke View Post
                  You'll need to open a support ticket then.
                  Ahh ok - i didnt think vb5 was supported officially yet.... I'll raise one now....

                  cheers
                  Paul

                  Comment


                  • #10
                    Any news on this ? I have the EXACT same problem ... used all makeconfig.php and other tricks and still can only login into admincp via ... www/vb5/core/admincp

                    Comment


                    • #11
                      Originally posted by Mustang5ohhh View Post
                      Any news on this ? I have the EXACT same problem ... used all makeconfig.php and other tricks and still can only login into admincp via ... www/vb5/core/admincp
                      You uploaded the .htacces (for apache2) or web.config (for IIS) files?
                      No private support, only PM me when I ask for it. Support in the forums only.

                      Comment


                      • #12
                        Got it ... didn't have OSX setup to see hidden files ... working now.

                        Thanks

                        Comment

                        Related Topics

                        Collapse

                        Working...
                        X