Announcement

Collapse
No announcement yet.

Forum empty after update from 4.2.2 to 5.1.4

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Forum empty after update from 4.2.2 to 5.1.4

    Hi guys, i have a problem with my forum after update the version of this excellent script.

    I've updated my vbulletin forum from 4.2.2 to 5.1.4

    The update was completed successfully, I had no problems in this process so then delete the core/install folder.

    I can access perfectly to my admincp, but if I enter the forum, I load a blank page, all I see is a gray background with CSS code, but I see nothing more than that.

    Something strange is that if I go to mydomain.com/modcp shows me the following error message:

    Code:
    [COLOR=#000000][FONT=Times New Roman]Warning: require_once(.../modcp): failed to open stream: No such file or directory in /home/my_username_host/public_html/includes/api/interface/collapsed.php on line 118 [/FONT][/COLOR]
    [B]Fatal error[/B][COLOR=#000000][FONT=Times New Roman]: require_once(): Failed opening required '/home/my_username_host/public_html/core/modcp' (include_path='.:/usr/lib/php:/usr/local/lib/php') in [/FONT][/COLOR][B]/home/my_username_host/public_html/includes/api/interface/collapsed.php[/B][COLOR=#000000][FONT=Times New Roman] on line [/FONT][/COLOR][B]118[/B]
    I performed the upgrade process on localhost too, and have the same problem, so I doubt it's the htaccess file. My host supports mod_rewrite perfectly.

    Please I hope you can help me, thanks.
    Something

  • #2
    My first thoughts were something to do with your .htaccess file, but you say you've covered that.

    Is 5.1.4 the current version? I thought 5.1.4 was a beta and 5.1.3 is the current production version.

    PS: My understanding is that the moderator control panel (modcp) is progressively being deprecated in vB5, i.e. it's obsolete. The administrator control panel will be at mydomain.com/admincp, not at mydomain.com/modcp. So if 5.1.4 doesn't have modcp in it (I wouldn't know, I think it's a beta) then it probably wouldn't work. I'd still double check your .htaccess file.

    Another PS: another thing I'd double check is that in addition to uploading the .htaccess file you uploaded everything else into wherever your site is hosted from e.g. into the root of the site or whatever your forum directory is, including index.php.
    Last edited by jdj; Wed 22 Oct '14, 7:24am.

    Comment


    • #3
      I know the admincp is not the same as the ModCP, but specified that upon entering the URL appeared ModCP me that error message so they can know what is wrong.

      For yuor "another PS":

      My forum files are in the main root of my host, and ran the update from there too the following URL:

      http://mydomain.com/core/install/upgrade.php

      I have reuploaded my htaccess file that comes in the original package of vBulletin 5.1.4 and the problem is not solved.

      In localhost I have reuploaded all files from vBulletin 5.1.4 and I have replaced existing after installation, and still not solved.

      Thanks for your answer.
      Last edited by Fromend; Wed 22 Oct '14, 7:31am.
      Something

      Comment


      • jdj
        jdj commented
        Editing a comment
        So you've uploaded all files from vBulletin 5.1.4, not 5.1.3? I have vB4 on my live site but vB 5.1.3 on my test site. My test site tells me that 5.1.3 is the current version. I've had a white screen before with one of the 5.1.x versions and couldn't work out what I'd done; what fixed it was putting the files up there again, but I couldn't work out what I'd done.

    • #4
      So, you can practically tell me how you upgraded to vBulletin 4 to vBulletin 5.1.3?

      Thanks
      Something

      Comment


      • jdj
        jdj commented
        Editing a comment
        I run vBulletin 4 on my live site I'm testing out vB5 on my test site. So earlier this year I upgraded my test site which I think was running vB4.2.2 at the time to whatever the present version of vB5 was then. I cannot remember which one now but it was not 5.1.3. So I just ran the upgrade to the current vB5 version and there were no problems with running the upgrade from vB4 to the current vB5 version. I don't run betas on my live site so whenever I run upgrades on my live site I use the current version. The current version of vBulletin today, I.e. the one that appears in your admincp in top left after the words "Latest version available:" is 5.1.3 not 5.1.4. When I had a problem that gave me a white screen previously it was upgrading from vB5.x to vB5x on my test site just after a new version came out and because instead of unzipping the files on my PC and uploading to the server I got my host to unzip them onto my server and I transferred them across manually on the server (to see if I could minimise downtime). For some reason that gave me a white screen after I ran the upgrade. So I went back to unzipping the files locally, uploading them directly to the server. Then I ran the script again and I didn't have a white screen.

        So I have no idea what did it but I assumed that somehow I had made a mistake when transferring files on the server; one of the things about vBulletin is that it is prone to human error...i.e. 'badfinger' because you have to manually upload the files. By way of contrast one of the other PHP-based programs I use has an upload wizard and that works like a dream.

    • #5
      Your host may support mod_rewrite but have the server set up to not recognize and .htaccess file. Check with your host regarding that. They may need to set AllowOverride to All for your domain.

      Please don't PM or VM me for support - I only help out in the threads.
      vBulletin Manual & vBulletin 4.0 Code Documentation (API)
      Want help modifying your vbulletin forum? Head on over to vbulletin.org
      If I post CSS and you don't know where it goes, throw it into the additional.css template.

      W3Schools <- awesome site for html/css help

      Comment


      • #6
        The problem don't is my host, is vBulletin 5.1.4

        I updated my forum to vBulletin 5.1.3 and everything went perfect.

        So, i think that the lasted version unstable of vBulletin (5.1.4) don't work after update.

        I hope uptade to 5.1.4 soon.

        Regards.
        Something

        Comment


        • #7
          We don't support pre release versions, but 5.1.4 works fine on an upgrade from 5.1.3. Something is amiss on your setup somewhere.
          MARK.B | vBULLETIN SUPPORT

          TalkNewsUK - My vBulletin 5.6.4 Demo
          AdminAmmo - My Cloud Demo

          Comment


          • #8
            Interestingly, I affirm that vBulletin 5.1.4 fails after upgrade from versions 4.x

            So now that you mention it, i will update from 5.1.3 to 5.1.4 for a better experience.
            Something

            Comment


            • jdj
              jdj commented
              Editing a comment
              Let us know how you get on..... :-)

          Related Topics

          Collapse

          Working...
          X