Announcement

Collapse
No announcement yet.

error updating from 3.8.x to 5.x

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • error updating from 3.8.x to 5.x

    everything goes great until we hit the 5.x updates

    Upgrading to 5.0.0
    ----------------------------------
    Upgrade Complete

    Upgrading to 5.0.1 Alpha 1
    ----------------------------------
    Step 1 - Skipping step, not needed
    Step 2 - Skipping step, not needed
    Step 3 - Updating cron table
    Step 4 - Fixing imported blog information.
    Processed 2000 records
    Fixing imported blog information.
    Processed 2000 records
    Fixing imported blog information.
    Processed 2000 records
    Fixing imported blog information.
    Process done
    Step 5 - Segmentation fault (core dumped)

  • #2
    after trying to rerun the update i get this error.

    Code:
    Unexpected Text:  
     <?xml version="1.0" encoding="windows-1252"?>  			Database error in vBulletin 5.0.0:  			Invalid SQL:  				SELECT max(bu.bloguserid) AS maxid 				FROM jelsoft_node n 				INNER JOIN jelsoft_blog_user bu ON bu.bloguserid = n.userid 				WHERE n.oldcontenttypeid = 9999 				AND 				( 					(n.nodeoptions = 138 AND (bu.options <> 6 OR bu.allowsmilie <> 1)) 					OR 					( 					    n.viewperms = 2 AND 					    ( ~bu.options_member & 1 OR ~bu.options_guest & 1 ) 					) 					OR 					( 					    n.commentperms = 1 AND 					    (~bu.options_member & 2) 					) 				) 			 /**getMaxBlogUserIdToFixOptions**/;  			MySQL Error   : Unknown column 'bu.options_member' in 'where clause' 			Error Number  : 1054 			Request Date  : Thursday, September 4th 2014 @ 05:00:40 PM 			Error Date    : Thursday, September 4th 2014 @ 05:00:40 PM 			Script        : http:///community/core/install/upgrade.php 			Referrer      : http://xxx.org/community/core/install/upgrade.php 			IP Address    : xxx 			Username      : Rxxxx 			Classname     : vB_Database_MySQL 			MySQL Version : 5.5.37-cll

    Comment


    • #3
      Please restore your database, then upgrade to 4.2.2. Make a new database backup. Once that is done, please run the vBulletin 5.X upgrade. Make sure you're doing a test installation before you update your live server.

      You also need PHP to be at least version 5.3.7. However we recommend using PHP 5.4.X or 5.5.X. MySQL must be at least version 5.1.5 but we recommend using MySQL 5.5.X or 5.6.X.
      Translations provided by Google.

      Wayne Luke
      The Rabid Badger - a vBulletin Cloud demonstration site.
      vBulletin 5 API - Full / Mobile
      Vote for your favorite feature requests and the bugs you want to see fixed.

      Comment


      • #4
        upgrade works. . . 3.8 to 4.2 then to 5.x

        however site is broke, I have disabled hooks via config.php but still kills the site.

        Warning: Invalid argument supplied for foreach() in ..../includes/functions_navigation.php on line 355
        Checking if a package is enabled for an invalid package '3' on line 392 in /home/xxx/public_html/community/vb/types.php
        #0 /home/xxx/public_html/community/vb/router.php(514): vB_Types->packageEnabled('3')
        #1 /home/xxx/public_html/community/vb/router.php(577): vB_Router::assertRoutes()
        #2 /home/xxx/public_html/community/vb/route.php(236): vB_Router::getRouteSegmentFromClass('vBCms_Route_Lis...')
        #3 /home/xxx/public_html/community/vb/route.php(260): vB_Route->__construct(false, false)
        #4 /home/xxx/public_html/community/packages/vbcms/route/list.php(92): vB_Route::create('vBCms_Route_Lis...')
        #5 /home/xxx/public_html/community/includes/functions.php(3667): vBCms_Route_List::getURL(Array)
        #6 /home/xxx/public_html/community/includes/functions_forumlist.php(314): construct_memberaction_dropdown(Array)
        #7 /home/xxx/public_html/community/forum.php(611): construct_forum_bit(-1)
        #8 /home/xxx/public_html/community/index.php(43): require('/home/xxx/...')
        #9 {main}


        Fatal error: Checking if a package is enabled for an invalid package '3' on line 392 in ..../vb/types.php in ..../vb/vb.php on line 286


        Comment


        • #5
          Did you delete/remove all prior VB3 and VB4 files before uploading the VB5 files? VB5 cannot be installed over an older version, it needs to be installed to a clean directory.

          You also must delete your /core/install/ directory before you can use the site.

          Comment


          • #6
            I have been playing with the VB5 upgrade for over 5 days with no success. i did a clean install on a sub-directory mydomain.com/forums and its not connecting at all. Made the change to the .htaccess , made the change to all files that show the /UPLOAD/ name to reflect my sub-directory /forums/. what am I doing wrong?

            Comment


            • #7
              Originally posted by TeamHybrid_webguy View Post
              I have been playing with the VB5 upgrade for over 5 days with no success. i did a clean install on a sub-directory mydomain.com/forums and its not connecting at all. Made the change to the .htaccess , made the change to all files that show the /UPLOAD/ name to reflect my sub-directory /forums/. what am I doing wrong?
              Please start your own thread with full details of the problem.

              We'll need all the information specified in this post:
              http://www.vbulletin.com/forum/node/4005558
              MARK.B | vBULLETIN SUPPORT

              TalkNewsUK - My vBulletin 5.5.6 Demo
              AdminAmmo - My Cloud Demo

              Comment

              Related Topics

              Collapse

              • dustywb
                New upgrade from 4.1 to 5.2
                by dustywb
                I finally got the upgrade script to run successfully and now this is all I get (after enabling debugging mode) when trying to load the forum. Not sure what to do next.

                Error :API Error...
                Thu 7th Apr '16, 12:07am
              • geovadim
                Update errors
                by geovadim
                I am trying to update my forum vb3.7 to vb5 connect. I've copied the files from vb5 in a test forum and created a copy of the live database.

                PHP Version 5.4.38

                I went to upgrade...
                Mon 2nd Mar '15, 3:18am
              • Mevlüt Akpinar
                Error :API Error
                by Mevlüt Akpinar
                Hello,
                Etc. 5 I smoke. I do not have a shortage of time following entry but I also enter my login information (in debug mode) I get the following errors.



                Error :API E...
                Tue 22nd Dec '15, 1:42pm
              • Mevlüt Akpinar
                System Error
                by Mevlüt Akpinar
                Hello there,
                System Error Gives below.
                System Error has occurred.
                The software is Experiencing a systems error.
                You should attempt to repeat your last action. If this error occurs...
                Wed 2nd Mar '16, 12:18pm
              • tokyosama
                makeconfig
                by tokyosama
                I'm at the Configuation Builder page i enter in all my info after i click create files it giving this error message

                Warning: file_put_contents(/home/sanime/public_html/forum/config.php) ...
                Fri 25th Apr '14, 12:01am
              Working...
              X