Announcement

Collapse
No announcement yet.

Error Upgraded to 5.1.2 alpha 3

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error Upgraded to 5.1.2 alpha 3

    i have problems with upgrade vbulettin 5.1.2. previous update, i use vb 5.1.0 and then I upgraded to 5.1.2 but there is a problem in the 5.1.2 alpha 3.
    but i have an error.
    Unexpected Text:

    <? xml version = "1.0" encoding = "UTF-8"?>
    <br />
    <b> Fatal error </ b>: Call to undefined method vB_Library_Template :: rebuildTextonlyDS () in <b> /public_html/core/install/includes/class_upgrade_512a3.php </ b> on line <b> 64 </ b> <br />

    please help!

  • #2
    I'd suggest reuploading ALL of the 5.1.2 files and re-running the upgrade script

    Comment


    • #3
      I've replaced with a new update scripts(5.1.2 Patch Level 4). but still there is an error like that.
      Click image for larger version

Name:	a1.JPG
Views:	27
Size:	31.2 KB
ID:	4136314 Click image for larger version

Name:	a2.JPG
Views:	38
Size:	28.0 KB
ID:	4136315

      public function step_1()
      {
      $this->show_message($this->phrase['version'][$this->SHORT_VERSION]['updating_datastore_special_templates']);
      //changed the format of this field so we need to rebuild the datastore value.
      vB_Library::instance('template')->rebuildTextonlyDS();
      }

      Last edited by DuniaBebas; Wed 3 Sep '14, 5:21pm.

      Comment


      • #4
        What is the actual error you're getting?

        Comment


        • #5
          this is an actual error while im upgrade my forum to 5.1.2 Patch level 4

          PHP Code:
          Unexpected Text:

          <? xml version "1.0" encoding "UTF-8"?>
          <br />
          <b> Fatal error </ b>: Call to undefined method vB_Library_Template :: rebuildTextonlyDS () in <b> /public_html/core/install/includes/class_upgrade_512a3.php </ b> on line <b> 64 </ b> <br />

          Comment


          • #6
            anyone can help me?

            above problem has not been fixed, and now i have new problem in upgrade to 5.1.3. it's very confused to me!
            HTML Code:
            Fatal error: Call to undefined method vB_Api_Search::getCacheTTL() in /home/public_html/core/vb/search/criteria.php on line 1029

            Comment


            • #7
              Are you upgrading to 5.1.3 using the 5.1.0 database backup or are you trying to use the database that you used to upgrade to 5.1.2 that never finished the upgrade? You should be using the 5.1.0 database backup to do the upgrade since the other one never completed the upgrade.

              Please don't PM or VM me for support - I only help out in the threads.
              vBulletin Manual & vBulletin 4.0 Code Documentation (API)
              Want help modifying your vbulletin forum? Head on over to vbulletin.org
              If I post CSS and you don't know where it goes, throw it into the additional.css template.

              W3Schools &lt;- awesome site for html/css help

              Comment


              • #8
                i'm try use database 5.1.0 to upgrade 5.1.3, and then i click duniabebas.com/core/install/upgrade.php but in 5.1.2 alpha 3 back to error

                HTML Code:
                 Unexpected Text:   <?xml version="1.0" encoding="UTF-8"?> <br /> <b>Fatal error</b>:  Call to undefined method vB_Library_Template::rebuildTextonlyDS() in <b>/home/father66/public_html/core/install/includes/class_upgrade_512a3.php</b> on line <b>64</b><br />
                and i click my domain, i get error

                HTML Code:
                Fatal error: Call to undefined method vB_Api_Search::getCacheTTL() in /home/public_html/core/vb/search/criteria.php on line 1029
                what should I do?
                Last edited by DuniaBebas; Thu 11 Sep '14, 9:55pm.

                Comment


                • #9
                  What versions of php and MySQL are on the server?
                  MARK.B | vBULLETIN SUPPORT

                  TalkNewsUK - My vBulletin 5.6.4 Demo
                  AdminAmmo - My Cloud Demo

                  Comment


                  • #10
                    That function is in the file /core/vb/library/template.php. Have you made sure the FULL file was uploaded and that it is the 5.1.3 file and that it has the correct permissions.

                    Please don't PM or VM me for support - I only help out in the threads.
                    vBulletin Manual & vBulletin 4.0 Code Documentation (API)
                    Want help modifying your vbulletin forum? Head on over to vbulletin.org
                    If I post CSS and you don't know where it goes, throw it into the additional.css template.

                    W3Schools &lt;- awesome site for html/css help

                    Comment


                    • #11
                      Originally posted by Mark.B View Post
                      What versions of php and MySQL are on the server?
                      my server use PHP Version 5.4.32 and then MySQL 5.5.37

                      vBulletin 5.1.x requires PHP 5.3.7 or greater, MySQL 5.1.5 or greater and cURL to be installed.

                      so my server uptoded.


                      Originally posted by Lynne View Post
                      That function is in the file /core/vb/library/template.php. Have you made sure the FULL file was uploaded and that it is the 5.1.3 file and that it has the correct permissions.
                      i will try again for it.
                      Last edited by DuniaBebas; Sat 13 Sep '14, 12:39am.

                      Comment


                      • #12
                        Go back to 5.1.0 (including files) and verify that it works.
                        Download a full, fresh copy of the 5.1.3 files from the member.
                        Upload these to the server.
                        Create new versions of config.php and /core/includes/config.php. Don't copy/paste anything from the old file.
                        Make sure you edit the core config file using a proper text editor, such as Notepadd++, do not use Windows Notepad.
                        Run the upgrade script again.
                        MARK.B | vBULLETIN SUPPORT

                        TalkNewsUK - My vBulletin 5.6.4 Demo
                        AdminAmmo - My Cloud Demo

                        Comment


                        • #13
                          Originally posted by Mark.B View Post
                          Go back to 5.1.0 (including files) and verify that it works.
                          Download a full, fresh copy of the 5.1.3 files from the member.
                          Upload these to the server.
                          Create new versions of config.php and /core/includes/config.php. Don't copy/paste anything from the old file.
                          Make sure you edit the core config file using a proper text editor, such as Notepadd++, do not use Windows Notepad.
                          Run the upgrade script again.
                          yes i ready use this step, but i have fatal error

                          HTML Code:
                          Fatal error: Call to undefined function mysqli_init() in /home/father66/public_html/core/vb/database/mysqli.php on line 86
                          and then i change manually ini config.php msqli to msql, but the upgrade link rediret to http://duniabebas.com/core/install/install.php and then i have error message
                          Startup Errors
                          Due to the following errors, the install/upgrade can not continue:
                          • Database connection failed due to unexpected error:
                            • (1044) Access denied for user 'myuser'@'localhost' to database 'mydatabase'

                            Please ensure that the database and server is correctly configured and try again
                          #update

                          i try again upto 5.1.2 and workit now! but i not sure to update to 5.1.3
                          #step one i upgrade 5.1.0 to 5.1.1
                          Click image for larger version

Name:	Capture.JPG
Views:	20
Size:	69.3 KB
ID:	4146649

                          #step 2 i upgrade 5.1.1 to 5.1.2 and i have error

                          HTML Code:
                           Unexpected Text:   <?xml version="1.0" encoding="UTF-8"?> <br /> <b>Fatal error</b>:  Call to undefined method vB_Api_Phrase::getLanguageid() in <b>/home/father66/public_html/core/install/includes/class_upgrade_final.php</b> on line <b>859</b><br />
                          Last edited by DuniaBebas; Sat 13 Sep '14, 1:28am.

                          Comment


                          • #14
                            (1044) Access denied for user 'myuser'@'localhost' to database 'mydatabase'

                            That's a credentials error in the database details. Are you sure you are editing the config.php VERY carefully? Even one space in the wrong place will cause problems.
                            MARK.B | vBULLETIN SUPPORT

                            TalkNewsUK - My vBulletin 5.6.4 Demo
                            AdminAmmo - My Cloud Demo

                            Comment


                            • #15
                              Originally posted by Mark.B View Post
                              (1044) Access denied for user 'myuser'@'localhost' to database 'mydatabase'

                              That's a credentials error in the database details. Are you sure you are editing the config.php VERY carefully? Even one space in the wrong place will cause problems.
                              I just replaced the my user, and database in ne config (5.1.3) and some of the same url link with old config.php. but i get the error and then i come back use step by step with old config.php

                              i try again upto 5.1.2 and workit now! but i not sure to update to 5.1.3
                              #step one i upgrade 5.1.0 to 5.1.1
                              [ATTACH=CONFIG]n4146649[/ATTACH]

                              #step 2 i upgrade 5.1.1 to 5.1.2 and i have error

                              HTML Code:
                               Unexpected Text:   <?xml version="1.0" encoding="UTF-8"?> <br /> <b>Fatal error</b>:  Call to undefined method vB_Api_Phrase::getLanguageid() in <b>/home/father66/public_html/core/install/includes/class_upgrade_final.php</b> on line <b>859</b><br />

                              Comment

                              Related Topics

                              Collapse

                              Working...
                              X