Announcement

Collapse
No announcement yet.

Status: Processing 5.0.0 Alpha 1, Step 132 of 166

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Status: Processing 5.0.0 Alpha 1, Step 132 of 166

    Hi

    I try to upgrade from 4.2.2. to 5.1 and tbh after a week of try and error and reading forums with "solutions" I still don't have a working solution. So now I am here...

    The history: the first "upgrade" I tried with the live forums, blue-eyed as I was I didn't uninstall any addons. Then it aborted at one of the last steps somewhere in the 150ies... or even later, really short before the "done". There I got this message: "<?xml version="1.0" encoding="windows-1252"?> Duplicate route data:"

    So after a few tries I read all these forum answers here in vBulletin.com.

    What I did then:

    1. I restored the database from the original one I had backuped.
    2. I uninstalled ALL products, including CMS and blog, forumrunner, really everything.
    3. I rebuilt the forums and thread informations, deleted duplicates, repaired and optimized tables as usual before a major upgrade.
    4. I uninstalled all additional languages.
    5. I deleted all additional styles and reverted all templates
    6. I created a new directory /forums and uploaded clean vb 5 files (which really sounds DUMB forums.clubcooee.com/forums and ['forumpath'] = '/var/www/vhosts/clubcooee.com/forums/forums' COMEON GUYS ARE YOU SERIUOS???)
    7. I tried with mysqli and mysql, with disable hooks
    8. I uploaded tools.php and yeah I cleared cache right before the upgrade... so with tools.php I did all the necdessary checks besides "scan content tables", which I did not want to touch.
    9. I even didn't clone back the first one I uninstalled it all from, I even did it again from the backuped database: uninstalled it all again, uninstalled styles, language, reverted templates and all that stuff again from scratch. no change in the behaviour of vBulletin upgrade.php. It's boring.

    Ever since I had uninstalled all products every following upgrade stopped at this point: Status: Processing 5.0.0 Alpha 1, Step 132 of 166 - BEFORE that it went further, surprisingly.The first night I waited over night for the process to be done. Next morning I again had Status: Processing 5.0.0 Alpha 1, Step 132 of 166 then I saw in some threads here it's the styles, then I saw it's the language... and with each try of the next upgrade it still would show Status: Processing 5.0.0 Alpha 1, Step 132 of 166 and would got go further. Sometimes it showed me I wouldn't have an updated javascript... so I used different browsers, refreshed a hundred times... nothing helped.

    TBH: I use vBulletin as administrator since 2001. I converted this actual board from a phpBB in 2009 and did all upgrades without any problems ever. Never needed any support. It all was self-explaining and the common errors could be found in internet. THIS VERSION is the first one creating immense problems. I stopped my forums a week ago, thinking I could get the upgrade running within one day as usual. No freaking way! Days over days retry and still have no chance to upgrade my board is simply...

    Last stand: I had to upload my original vB4 forums again, and my people are still waiting on the new forums to rise. So now I run two versions: the original one on one database in / and one to be upgraded in /forums/ on the other database. With the config.phps I can swtich the 4.2.2 to both systems, so they are equal when starting... I checked... several times...

    Actually I would love to have my board up and running again some day as my moderation team lacks informations...

  • #2
    The error provided isn't enough to take action on. Enable debug mode on your site. Follow these instructions.

    1. Open your /config.php file and find the following line:
    Code:
    $config['debug'] = false;
    2. Change this line to:
    Code:
    $config['debug'] = true;
    3. Save the file and upload it to your server.

    4. Open the /core/includes/config.php file and find the following line:
    Code:
    // $config['Misc']['debug'] = true;
    5. Change it to:
    Code:
    $config['Misc']['debug'] = true;
    6. Save and upload the file to your server.

    Reload the page you had the error on.
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud demonstration site.
    vBulletin 5 API - Full / Mobile
    Vote for your favorite feature requests and the bugs you want to see fixed.

    Comment


    • #3
      Thx for the answer.

      Well I already upgraded to vbulletin 5.1 now.

      What I did:

      I used the database with all the languages and the plugins and did NOT uninstall anything as I knew from the first try THAT would the upgrade script do anyways.

      So I left it all as it was, increased memory allowed for the forums and well it upgraded fine this time. Btw: I always used the debug=true from beginning on as I know vBulletin always has errors when upgrading.

      Just One little thing:

      I can reach the ACP and it works like a charm: fast and smooth. But: there is no frontend. Any suggestions? The tables are there, also the forum structure looks okay when I check it in ACP. There is no sourcecode when I try to open /forums/ or forums/index.php or whatsoever.
      Aaaah I tried http://forums.mysite.com/forums/index without .php ending and it shows in firefox: There is a serious error and the page cannot be rendered

      IE for instance shows a 500 error on /forums/index, but it will show sourcecode on /forums/index.php:
      <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
      <HTML><HEAD><META content="IE=9.0000" http-equiv="X-UA-Compatible">

      <META content="text/html; charset=windows-1252"
      http-equiv="Content-Type"></HEAD>
      <BODY></BODY></HTML>
      Last edited by -_-wolfgang-_-; Mon 28th Apr '14, 1:20pm.

      Comment


      • #4
        oh yes I forgot: you might like to see the error code.

        Error :Invalid Page URL. If this is an error and the page should exist, please contact the system administrator and tell them how you got this message. on line 123 in /var/www/vhosts/mysite.com/forums/forums/includes/api/interface/collapsed.php
        Step 0: relay() called on line 56 in /var/www/vhosts/mysite.com/forums/forums/includes/vb5/frontend/controller/relay.php
        Step 1: legacy() called
        Step 2: call_user_func_array() called on line 72 in /var/www/vhosts/clmysite.com/forums/forums/index.php

        Comment


        • #5
          Never mind giving me an answer to this. I figured it out myself. So much about the "Premium Customer Support" thx, guys.

          For anyone interested that want to upgrade a 4.2.2. to a 5.1: increase memory allowed for vBulletin to 512 MB at least.

          Then DON'T uninstall anything, don't waste your time. vBulletin upgrade script does this for you anyways.

          After upgrade go to the styles in ACP and disable all styles but vbulletin 5 default style and don't allow users to change it. Save. You are done, the upgrade is made.
          Sure you got all kinds of settings and stuff, but the major upgrade is done AND your pages will be rendered actually if not, change some user rights and it will work like a charm. The BIG Secret is not really there. Work only with debug=true and uhm... if the script hangs, reload it... but only if it hangs...
          Last edited by -_-wolfgang-_-; Tue 29th Apr '14, 12:43pm.

          Comment

          Related Topics

          Collapse

          Working...
          X