Announcement

Collapse
No announcement yet.

After installing fresh 5.1.0 on new Linux I can't access admin control panel and there is no login form on forum page

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • After installing fresh 5.1.0 on new Linux I can't access admin control panel and there is no login form on forum page


    after installation of new fresh 5.1.0 on new Linux server:

    1) cannot access admin control panel . I have only img and js folders in admincp

    2) there is no login form on forum page . I got following error :

    Not Found

    The requested URL /forum//auth/login-form was not found on this server.

  • #2
    Make sure the .htaccess file has been uploaded to the forum root.
    Make sure the URL settings in the admincp are correct. If you're using the IP address, this needs to be in the admincp.

    You can *temporarily* access your admincp here:
    http://54.85.92.226/forum/core/admincp/

    But you'll need to remove the install directory.
    MARK.B | vBULLETIN SUPPORT

    TalkNewsUK - My vBulletin 5.6.4 Demo
    AdminAmmo - My Cloud Demo

    Comment


    • #3
      install directory removed ,
      I uploaded .htaccess file to folder : /var/www/html/forum

      I changed in .htacess following lines :
      RewriteEngine On
      RewriteBase /forum/

      In folder /var/www/html/forum/admincp stored two other folders
      img
      js

      in folder /var/www/html/forum/core/admincp a lot of *php files
      1) Do I need to copy content of /var/www/html/forum/core/admincp to /var/www/html/forum/admincp ?

      2) I'm not sure what means : "Make sure the URL settings in the admincp are correct. If you're using the IP address, this needs to be in the admincp."

      Thanks

      Comment


      • #4
        You should not copy the files out of core/admincp into admincp. There are not supposed to be any files in the /admincp directory.

        If you can't access it and you've uploaded our .htaccess, then mod_rewrite isn't working on your server properly. You need to contact your hosting provider and they need to set Allow Overrides to All in the server config.
        Translations provided by Google.

        Wayne Luke
        The Rabid Badger - a vBulletin Cloud demonstration site.
        vBulletin 5 API

        Comment


        • #5
          I found htaccess.txt file in upload folder then I rename it to .htaccess and transfer to my /var/www/html/forum/ folder

          httpd.conf contains mod_rewrite I verified it .

          In my httpd.conf I have several entries for AllowOverride -> None , should I configure in the beginning of httpd.conf :
          AllowOverride All


          Comment


          • #6
            Yes, unless you just want to allow specific permissions.

            Comment


            • #7
              I made changes in httpd.conf :


              <Directory />
              Options FollowSymLinks
              AllowOverride All
              </Directory>

              <Directory /var/www/html/forum >
              Options FollowSymLinks
              AllowOverride All
              </Directory>

              but still can access to my forum only as http://<IP>/forum//forum instead http://<IP>/forum/

              Comment


              • #8
                http://54.85.92.226/forum/

                Seems fine?

                Comment


                • #9
                  Thank you for support , forum looks OK . To summarize this topic I'd say :

                  1) installation of 5.1.0 was successful
                  2) after installation need to configure Apache httpd.conf and .htaccess file , I suggest to add such configuration to installation docs as post-installation steps

                  Comment

                  Related Topics

                  Collapse

                  Working...
                  X