Announcement

Collapse
No announcement yet.

Admin password issue after 5.0.5 to 5.1.0 upgrade

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Admin password issue after 5.0.5 to 5.1.0 upgrade

    I reset the pw using the forgotten pw button and still no luv

    the site is hemanworld.com

    My admin user indicates its changed to blowfish scheme and shows this error on login
    There has been a database error, and the current page cannot be displayed. Site staff have been notified.

    However, no email is sent listing an error

    I signed up as a new user, was emailed a new pw, gave myself admin permission and was able to log in. I also see my new user is using the blowfish scheme.

    those left to the legacy schema seem able to login and post as expected

  • #2
    In Admin CP -> Usergroups -> Usergroup Manager, Edit the Admin Usergroup. Is Password Expiry set to 0? If not change it o 0 and try again.

    Comment


    • #3
      Originally posted by Mark.B

      We would need to know what the error is. I've upgraded two sites now and not encountered this.
      Please start a topic in the vB5 support forum so we can investigate.
      All I get now is a grey box that says:
      Fatal error: Call to a member function fetch_userinfo() on a non-object in /home/hemanwor/public_html/core/vb/library/user.php on line 722

      A few members who use iPhones have been able to log in, but regular members using desktop computers seem to be unable too.

      Updated: now I am getting a red message:
      There has been a database error, and the current page cannot be displayed. Site staff have been notified.

      Although it says staff have been notified, I have recieved no such emails.
      Last edited by Captain Atkin; Sat 15 Mar '14, 1:38pm.

      Comment


      • #4
        I just signed up for an account and can confirm the issue, once I logged out I could not log back in again, I got the red text about the database error. Although you're not getting an email can you check the MySQL error log to see if an error was logged, and if so, what are the details of the error?

        Also, did you try what I asked in Post #2?
        Last edited by Joe D.; Sat 15 Mar '14, 1:53pm.

        Comment


        • #5
          Thanks Joe. The site is working fine now. Installing it at /forum/ was where the problems started. The URLJet Techs used a standard redirect to forward to /forum and apparently that is NG with 5.1.0 and it needs to be forwarded differently. They didn't look at it earlier as they were users posting and didn't think that it should be possible for cached login credentials to work while a fresh login wouldn't.

          Comment


          • #6
            Glad it was figured out!

            Comment


            • #7
              The 5.1 install for my site seems to have been fixed... but now many of my users are reporting that the grey box underneath the "Message Center" isn't working for them. In it's place a gray box keeps appearing that says "An internal error has occurred and module cannot be displayed". Also, they are telling me that they can only see whatever the last message they got was, but none of their previous messages. Any idea on what could be causing this? I have tried AdminCP > Maintenance > General Update Tools > Fix Broken User Profiles , but it does not solve the problem.

              Attached Files
              Last edited by Captain Atkin; Tue 18 Mar '14, 9:01pm.

              Comment

              Related Topics

              Collapse

              Working...
              X