Announcement

Collapse
No announcement yet.

Running VB5 on IIS 7.5, Local mySQL. SSL (HTTPS) login not working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Running VB5 on IIS 7.5, Local mySQL. SSL (HTTPS) login not working

    I'm trying to get my vBulletin 5 site to run in HTTPS and it doesn't seem to be working .... the instructions say to simply uncomment as:

    // ****** Base URLs ******
    // The following settings all deal with the url of your forum.
    // If set incorrectly your site/software will not function correctly.
    // These urls should NOT include a trailing slash
    // This is the url and web path of your root vBulletin directory
    $config['baseurl'] = 'http://xxx.xxx.com';


    // This will only be used if you wish to require https logins
    // You will not need to change this setting most of the time.
    $config['baseurl_login'] = $config['baseurl'];

    // If you do wish to use https for login, uncomment this line
    // Then fill in your https url.
    $config['baseurl_login'] = 'https://xxx.xxx.com';

    When I Set my bindings in IIS to 443 and go to https:// the page looses all formatting. Changing back to Http:// the page still works fine.

    What am I missing?

  • #2
    Is your SSL directory a mirror of the HTTP directory?

    Chances are your CSS is pointing to the wrong location for some reason. If you're using 5.0.2, you need to use the web.config file included with that version with URL Rewrite to get the CSS. If the directories aren't mirrored, then you might need to make some adjustments to the CSS paths to load the CSS from your HTTP directory in the web.config for your SSL directory. Barring that, you'll need to store CSS as Files in the AdminCP under Settings -> Options -> Style and Language Settings.
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud demonstration site.
    vBulletin 5 API

    Comment


    • #3
      Is it possible to run the entire vBulletin Forum on 443? I only have one directory (no mirror) and want everything to be in SSL.
      here's my web.config :

      <?xml version="1.0" encoding="UTF-8"?>
      <!-- This file is to support redirection in IIS.
      This file is harmless if you are running under Apache -->
      <configuration>
      <system.webServer>
      <rewrite>
      <rules>
      <rule name="Css" stopProcessing="true">
      <match url="^css.php$" ignoreCase="false" />
      <action type="Rewrite" url="core/css.php" />
      </rule>
      <rule name="Installer" stopProcessing="true">
      <match url="^install/" ignoreCase="true" />
      <action type="Rewrite" url="core/install/" />
      </rule>
      <rule name="Main Redirect" stopProcessing="true">
      <match url="^(.*)$" ignoreCase="false" />
      <conditions logicalGrouping="MatchAll">
      <add input="{REQUEST_FILENAME}" matchType="IsFile" ignoreCase="false" negate="true" />
      <add input="{REQUEST_FILENAME}" matchType="IsDirectory" ignoreCase="false" negate="true" />
      </conditions>
      <action type="Rewrite" url="index.php/{R:1}" />
      </rule>
      <rule name="Admincp" stopProcessing="true">
      <match url="^(admincp/)$" ignoreCase="false" />
      <action type="Rewrite" url="index.php/{R:1}" />
      </rule>
      </rules>
      </rewrite>
      </system.webServer>
      </configuration>

      Comment


      • #4
        The web.config looks correct. When you look at your rewrites in your IIS Manager there should be four listed.

        You should be able to run the entire forum in SSL. State that as your base URL and leave the login URL commented out in your /config.php file. Put all the files in your 443 directory. Then you need to update the core directory in your AdminCP under Settings -> Options -> Site Name / URL / Contact Details.

        The rest of the operation should be normal.
        Translations provided by Google.

        Wayne Luke
        The Rabid Badger - a vBulletin Cloud demonstration site.
        vBulletin 5 API

        Comment


        • #5
          All that is correct. I'm sure I'm missing something easy though ....

          Comment


          • #6
            Site is not "live" yet .... using internal SSL only

            Comment


            • #7
              Go into the AdminCP and set CSS to be stored as files. You can do this under Settings -> Options -> Style and Language Settings.
              Translations provided by Google.

              Wayne Luke
              The Rabid Badger - a vBulletin Cloud demonstration site.
              vBulletin 5 API

              Comment


              • #8
                That got the https://wavesbeta.waves.com page correct. However now when I log in it goes to http://wavesbeta.waves.com and formatting is messed up again.

                Comment


                • #9
                  Update your baseurl in /config.php to point to the https:// URL.

                  You'll probably have to update the Core URL in the Admin CP under Settings -> Options -> Site Name / URL / Contact Details as well.
                  Translations provided by Google.

                  Wayne Luke
                  The Rabid Badger - a vBulletin Cloud demonstration site.
                  vBulletin 5 API

                  Comment


                  • #10
                    Killing me !!!!

                    OK ... here's what I have going on ...

                    // ****** Base URLs ******
                    // The following settings all deal with the url of your forum.
                    // If set incorrectly your site/software will not function correctly.
                    // These urls should NOT include a trailing slash
                    // This is the url and web path of your root vBulletin directory
                    $config['baseurl'] = 'https://wavesbeta.waves.com';


                    // This will only be used if you wish to require https logins
                    // You will not need to change this setting most of the time.
                    $config['baseurl_login'] = $config['baseurl'];

                    // If you do wish to use https for login, uncomment this line
                    // Then fill in your https url.
                    $config['baseurl_login'] = 'https://wavesbeta.waves.com';



                    Core URL is set as : https://wavesbeta.waves.com/core

                    Store CSS StyleSheets as Files is set to YES

                    Site still is not loading the CSS ....

                    Comment


                    • #11
                      And I just upgraded to 5.0.3 hoping it would fix it .... nope ... same issue.

                      Comment


                      • #12
                        Ahh .... and now the non-logged in page and the logged in page are both not formatted correctly. (no CSS on either)

                        Comment


                        • #13
                          Fixed .... I went through and "normalized" all settings to defaults. I then went through and reset everything as above.

                          Comment

                          Related Topics

                          Collapse

                          Working...
                          X