Announcement

Collapse
No announcement yet.

The requested URL /core/install/index.php was not found on this server.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • DemOnstar
    commented on 's reply
    For this also http://tracker.vbulletin.com/browse/VBV-9535.



    Beat me to it. I had the idea last night.....

  • DemOnstar
    replied
    Originally posted by Joe D. View Post
    The above two are because either your .htaccess file was never uploaded
    This put me on the right track.

    Joe D gets his just deserves.

    Cheers Joe..... Thanks for making it simple.
    Attached Files

    Leave a comment:


  • DemOnstar
    commented on 's reply
    Using another WAMP stack package called http://www.uniformserver.com/.

  • DemOnstar
    replied
    Ok, I am up and running on localhost. It has been a while but its fine.

    Only one thing I need to understand. I merged the 2 .htaccess files together placing the WAMP server .htaccess before the vb htaccess. It was simple.



    I will place a copy here for anyone who may have the same trouble.



    Code:
    #------------------------------------------------------------------------------
    
    # Server root folder www .htaccess
    
    # This file provides server security limiting access to the localhost only.
    
    # Comment next four lines to deactivate. (Allows external access)
    
    #------------------------------------------------------------------------------
    
    
    
    Order Deny,Allow
    
    Deny from all
    
    Allow from 127.0.0.1
    
    Allow from ::1
    
    
    
    #------------------------------------------------------------------------------
    
    # To allow execution of cgi scripts in this directory uncomment next two lines.
    
    #------------------------------------------------------------------------------
    
    
    
    AddHandler cgi-script .pl .cgi
    
    Options +ExecCGI +FollowSymLinks
    
    
    
    #------------------------------------------------------------------------------
    
    # Activate this section to use the Private Server Feature!
    
    # Defaults: Username - root; Password - root
    
    # Note AuthUserFile: File path is relative to server root
    
    # To lock server, uncomment the next 4 lines. (A name and password is required)
    
    #------------------------------------------------------------------------------
    
    
    
    #AuthName "Uniform Server - Server Access"
    
    #AuthType Basic
    
    #AuthUserFile ../../../htpasswd/www/.htpasswd
    
    #Require valid-user
    
    
    
    <IfModule mod_rewrite.c>
    
           RewriteEngine On
    
    
    
           # Redirect old install path to core.
    
           RewriteRule ^install/ core/install/ [NC,L]
    
    
    
           # Main Redirect
    
           RewriteCond %{REQUEST_URI} !\.(gif|jpg|jpeg|png)$
    
           RewriteCond %{REQUEST_FILENAME} !-f
    
           RewriteCond %{REQUEST_FILENAME} !-d
    
           RewriteRule ^(.*)$ index.php?routestring=$1 [L,QSA]
    
    
    
           # Because admincp is an actual directory.
    
           RewriteRule ^(admincp/)$ index.php?routestring=$1 [L,QSA]
    
    
    
    </IfModule>
    
    
    
    <IfModule mod_deflate.c>
    
           AddOutputFilterByType DEFLATE application/atom+xml \
    
                                                       text/javascript \
    
                                                       application/javascript \
    
                                                       application/json \
    
                                                       application/rss+xml \
    
                                                       application/vnd.ms-fontobject \
    
                                                       application/x-font-ttf \
    
                                                       application/xhtml+xml \
    
                                                       application/xml \
    
                                                       font/opentype \
    
                                                       image/svg+xml \
    
                                                       image/x-icon \
    
                                                       text/css \
    
                                                       text/html \
    
                                                       text/plain \
    
                                                       text/x-component \
    
                                                       text/xml
    
    </IfModule>
    
    
    
    <IfModule mod_expires.c>
    
           ExpiresActive On
    
           ExpiresByType application/x-javascript A1209600
    
           ExpiresByType text/javascript A1209600
    
           ExpiresByType application/javascript A1209600
    
           ExpiresByType text/css A31536000
    
           ExpiresByType image/x-icon A2592000
    
           ExpiresByType image/icon A2592000
    
           ExpiresByType application/x-ico A2592000
    
           ExpiresByType application/ico A2592000
    
           ExpiresByType image/gif A2592000
    
           ExpiresByType image/jpeg A1209600
    
           ExpiresByType image/jpg A1209600
    
           ExpiresByType image/png A1209600
    
           ExpiresByType application/x-shockwave-flash A1209600
    
           ExpiresByType font/ttf A2592000
    
           ExpiresByType font/otf A2592000
    
           ExpiresByType font/x-woff A2592000
    
           ExpiresByType image/svg+xml A2592000
    
           ExpiresByType font/truetype A2592000
    
           ExpiresByType font/opentype A2592000
    
           ExpiresByType application/x-font-woff A2592000
    
           ExpiresByType application/vnd.ms-fontobject A2592000
    
    </IfModule>
    
    
    
    <IfModule mod_headers.c>
    
           Header set Connection keep-alive
    
           <filesmatch "\.(ico|flv|gif|swf|eot|woff|otf|ttf|svg)$">
    
                  Header set Cache-Control "max-age=2592000, public"
    
           </filesmatch>
    
           <filesmatch "\.(jpg|jpeg|png)$">
    
                  Header set Cache-Control "max-age=1209600, public"
    
           </filesmatch>
    
           <filesmatch "\.(eot|woff|otf|ttf|svg)$">
    
                  Header set Cache-Control "max-age=2592000, public"
    
           </filesmatch>
    
           # css and js should use private for proxy caching https://developers.google.com/speed/docs/best-practices/caching#LeverageProxyCaching
    
           <filesmatch "\.(css)$">
    
                  Header set Cache-Control "max-age=31536000, private"
    
           </filesmatch>
    
           <filesmatch "\.(js)$">
    
                  Header set Cache-Control "max-age=1209600, private"
    
           </filesmatch>
    
    </IfModule>


    Also, could somebody look at this to tell me if all is well? The site seems to work and be ready for development (again) but maybe there is something in the code that i should be wary of?



    Thanks...

    Leave a comment:


  • DemOnstar
    replied
    This is what .htaccess reads now..



    Code:
    #------------------------------------------------------------------------------
    
    # Server root folder www .htaccess
    
    # This file provides server security limiting access to the localhost only.
    
    # Comment next four lines to deactivate. (Allows external access)
    
    #------------------------------------------------------------------------------
    
    
    
    Order Deny,Allow
    
    Deny from all
    
    Allow from 127.0.0.1
    
    Allow from ::1
    
    
    
    #------------------------------------------------------------------------------
    
    # To allow execution of cgi scripts in this directory uncomment next two lines.
    
    #------------------------------------------------------------------------------
    
    
    
    AddHandler cgi-script .pl .cgi
    
    Options +ExecCGI +FollowSymLinks
    
    
    
    #------------------------------------------------------------------------------
    
    # Activate this section to use the Private Server Feature!
    
    # Defaults: Username - root; Password - root
    
    # Note AuthUserFile: File path is relative to server root
    
    # To lock server, uncomment the next 4 lines. (A name and password is required)
    
    #------------------------------------------------------------------------------
    
    
    
    #AuthName "Uniform Server - Server Access"
    
    #AuthType Basic
    
    #AuthUserFile ../../../htpasswd/www/.htpasswd
    
    #Require valid-user


    How does that look?



    And how does one uncomment an item?



    Thanks....

    Leave a comment:


  • DemOnstar
    replied
    That makes sense. The server software suggested that I use its .htaccess. Cheers Joe, I will fiddle around with it.

    Leave a comment:


  • BirdOPrey5
    replied












    The above two are because either your .htaccess file was never uploaded or url rewriting just isn't working on your server.

    Leave a comment:


  • DemOnstar
    replied
    After a number of weeks at step 11, I am now past it with little or no help at all.





    I go to admin CP and get this...





    After typing localhost in my browser, I am taken here





    Getting there inch by inch.


    Thanks.
    Attached Files

    Leave a comment:


  • The requested URL /core/install/index.php was not found on this server.

    Using another WAMP stack package called http://www.uniformserver.com/.



    I have uploaded both configs to their appropriate places and get the error NOT FOUND The requested URL /core/install/index.php was not found on this server.



    I am obviously doing something wrong, anybody got any idea what it might be?



    Thanks....

Related Topics

Collapse

Working...
X