Announcement

Collapse
No announcement yet.

Site Editor Page Template Questions

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Site Editor Page Template Questions

    So I go to a page on the site. Any page, it doesn't matter which one. I open the Site Editor and make some changes to the modules and their settings. I save the page and choose to give it a new name so that a custom template with this module layout and these settings is created. I'm done here and we'll call this starter page Page A. So I go from Page A to a different page, which we'll call Page B. I want Page B to have the same setup as Page A so all I have to do now is open the Editor and choose my newest template that I just made. Easy. I move on again to what we'll call Page C. It's here that I run into the problem. I start by opening the Editor and going to the template chooser list just like before, only now my custom template is not there and has been replaced by a generic option from the starter handful of templates that were already packaged with vB5. I go back and open up Page B and now it is also already set to that generic default template even though I never made any such change, and the custom template is also gone from the selection list here as well. I go check Page A and it's the same story there, too. This has happened several times now. What is causing this, how do I stop it, and how can I keep my custom template from disappearing?

    Also, on a related note, how do you delete template choices from the Select Template area of the Site Editor? Because I'm on, like, template ID 52 at this point from all the attempts to figure out the issue above and they're just unnecessary clutter that I'd like to not have to scroll past to in order to get to the still-functional custom templates at the end of the list.

    Thank you in advance.

  • #2
    Originally posted by drew.wilsford View Post
    So I go to a page on the site. Any page, it doesn't matter which one. I open the Site Editor and make some changes to the modules and their settings. I save the page and choose to give it a new name so that a custom template with this module layout and these settings is created. I'm done here and we'll call this starter page Page A. So I go from Page A to a different page, which we'll call Page B. I want Page B to have the same setup as Page A so all I have to do now is open the Editor and choose my newest template that I just made. Easy. I move on again to what we'll call Page C. It's here that I run into the problem. I start by opening the Editor and going to the template chooser list just like before, only now my custom template is not there and has been replaced by a generic option from the starter handful of templates that were already packaged with vB5. I go back and open up Page B and now it is also already set to that generic default template even though I never made any such change, and the custom template is also gone from the selection list here as well. I go check Page A and it's the same story there, too. This has happened several times now. What is causing this, how do I stop it, and how can I keep my custom template from disappearing?
    I don't know what is happening. I got lost trying to keep track of generic pages. What type of pages are A, B, and C. Are they all the same page type? i.e. forum channels or custom pages.

    Also, on a related note, how do you delete template choices from the Select Template area of the Site Editor? Because I'm on, like, template ID 52 at this point from all the attempts to figure out the issue above and they're just unnecessary clutter that I'd like to not have to scroll past to in order to get to the still-functional custom templates at the end of the list.
    You can use the Pages Manager in Site Builder to delete orphaned page templates. This will only list templates that aren't currently assigned to a specific page.

    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud demonstration site.
    vBulletin 5 API

    Comment


    • #3
      In this most recent case, A is the overview page of all social groups from every category, and B & C are overview pages where the social groups are only showing by specific category. We have five categories of group on the site. So that's six pages total when you count the page that shows them all, not sorted by category, and the five individual pages showing them by each of the five categories. All six are using the same custom setup template, however, created at Page A and applied on Page B, but by the time I reach Page C, the custom template is gone, a generic "Default Groups Home" template is in its place, and both A & B have also reverted to that default template when I open them back up to check on them. I've tried this so many times that there are, like, ten "Groups Home" templates at the end of the list now, not counting the one that was always in the list to begin with.

      In the meantime, orphaned templates have been deleted, at least. Thank you for that.
      Last edited by drew.wilsford; Thu 3 Jun '21, 5:55pm.

      Comment

      Related Topics

      Collapse

      Working...
      X